Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GnuCash, something is broken after last weeks updates
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JanErik
Guru
Guru


Joined: 28 Oct 2002
Posts: 488
Location: Finland

PostPosted: Mon May 19, 2014 7:43 pm    Post subject: GnuCash, something is broken after last weeks updates Reply with quote

After updating packages last weekend, GnuCash is seriously broken. When I click on the date of an entry, the date changes by a few days and empty entries are also sometimes inserted. Also in the calendar when I click on a day, the adjacent is selected but a completely different date appears in the entry.

Last edited by JanErik on Mon May 19, 2014 8:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
JanErik
Guru
Guru


Joined: 28 Oct 2002
Posts: 488
Location: Finland

PostPosted: Mon May 19, 2014 7:54 pm    Post subject: Reply with quote

Packages I see changed that are also dependencies for GnuCash:

libxml2
python
libtool

Downgrading them did not solve the problem.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon May 19, 2014 8:50 pm    Post subject: Reply with quote

JanErik wrote:
Packages I see changed that are also dependencies for GnuCash: [...] python [...]

JanErik ... just FYI, if you reply to your own posts (rather than edit the original to add further info) then they don't show in "view unanswered posts" (which is often the method people use to see who's getting help ... or not).

This python update is not so recent ...

Code:
# qlop -Cl | grep 'dev-lang/python-[2-3]' | tail -n +11
Sat Jan 18 12:37:00 2014 >>> dev-lang/python-2.7.5-r3
Sun Jan 26 13:41:00 2014 >>> dev-lang/python-3.3.3

... also there was a perl update within a similar timeframe ...

Code:
# qlop -Cl | grep 'dev-lang/perl-5'
Sun Dec 15 08:52:55 2013 >>> dev-lang/perl-5.16.3

I bring up perl as dev-perl/DateManip is also a dependency of gnucash, and this is a more likely candidate for the cause.

So, subsequent to these updates did you run 'perl-cleaner --all' and 'python-updater'?

best ... khay
Back to top
View user's profile Send private message
JanErik
Guru
Guru


Joined: 28 Oct 2002
Posts: 488
Location: Finland

PostPosted: Tue May 20, 2014 3:43 pm    Post subject: Reply with quote

Perl-cleaner seems to have done the trick.
But Python was updated from python-3.2.5-r3 to python-3.2.5-r4 last week, running ~arch.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue May 20, 2014 6:21 pm    Post subject: Reply with quote

JanErik wrote:
Perl-cleaner seems to have done the trick.

JanErik ... good, btw, I should have mentioned that running --depclean after perl-cleaner is a good idea (in my case 3 or 4 perl packages were nolonger required).

JanErik wrote:
But Python was updated from python-3.2.5-r3 to python-3.2.5-r4 last week, running ~arch.

As you can see from the above I (using stable) installed python-3.3.3 on january 26th. Anyhow, the only arch that doesn't have 3.3.3 keyworded stable is mips, so you would still get 3.3.3 ...

Code:
# awk 'NR<9 {print}; /3.3/{print}' <(eshowkw dev-lang/python)
Keywords for dev-lang/python:
             |                             | u     | 
             | a a   a           p     s   | n     | 
             | l m   r h i m m   p s   p   | u s   | r
             | p d a m p a 6 i p c 3   a x | s l   | e
             | h 6 r 6 p 6 8 p p 6 9 s r 8 | e o   | p
             | a 4 m 4 a 4 k s c 4 0 h c 6 | d t   | o
-------------+-----------------------------+-------+-------
    3.3.2-r2 | + + + + + + + ~ + + + + + + | # 3.3 | gentoo
 [I]3.3.3    | + + + + + + + ~ + + + + + + | o     | gentoo
    3.3.4    | ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ | #     | gentoo
    3.3.5    | ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ | o     | gentoo

... the 3.2.5-r4 update was the 3.2 slot ... which you can '--depclean' after setting the 3.3 slot as the python3 interpreter ... 'eselect python set {N} --python3' (where '{N}' is the number provided by 'eselect python list').

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum