Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can not unmerge Gnome/Systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Sat May 17, 2014 7:55 pm    Post subject: [SOLVED] Can not unmerge Gnome/Systemd Reply with quote

Hi,
My nVdia GPU card have been broken, and due to the fact that Gnome/Systemd does not work properly with my on-board Intel GPU (maybe there is a driver problem) –
I decided to switch to KDE/openRC.
At the moment my machine work with openRC – I double checked it with this command:
Code:
ps -p 1 -o comm=

However I have a strange situation: although I unmerged Gnome, I still have it in the login menu and can start it as well.
When I am trying to unmerge gnome again, I get the message that it does not find it. I do not know how to get rid of Gnome,
and thought that Gnome 3.10 is working only with Systemd??
Please advise!
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”


Last edited by pmam on Wed May 21, 2014 5:20 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat May 17, 2014 8:32 pm    Post subject: Reply with quote

pmam ...

did you run 'emerge --depclean --ask' subsequent to unmerging gnome-base/gnome? Also, I assume you've swtiched profiles, if so you may want to check what useflags are (dis|en)abled and 'emerge --deep --newuse --ask @world' ... this will probably remove the systemd useflag (and possibly others), after this then another 'emerge --depclean --ask' is probably in order.

HTH & best ... khay


Last edited by khayyam on Sat May 17, 2014 8:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 529

PostPosted: Sat May 17, 2014 8:32 pm    Post subject: Reply with quote

When you say that you unmerged Gnome, how did you do this? You might have unmerged the metapackage, but not Gnome itself. Did you run emerge --depclean after? Did you check your profile and USE flags for Gnome and SystemD? You might need to change profiles and USE flags.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Sun May 18, 2014 1:45 pm    Post subject: Reply with quote

Dear Khayyam & Keet,

Quote:
did you run 'emerge --depclean --ask' subsequent to unmerging gnome-base/gnome?

Think I did it and to be sure I did it again after saw your reply.

Quote:
I assume you've switched profiles

Yes, I had changed to KDE (openRC) profile and afterword run:
Code:
emerge -avuND world
Is it enough or I should run
Code:
emerge --deep --newuse --ask @world
- Is it not the same?
Quote:
Did you check your profile and USE flags for Gnome and SystemD?

No, I did not know I need to check it - When checked I found out these USE flags: gnome and -systemd -
Then I deleted gnome and left -systemd - BTW: What the difference between delete USE flag or to add '-'?

OK - After I done according your advise it seems ok - Gnome is finally deleted - it still exist in the login menu,
but if I choose it there is an 'Oh no!' massage - How can I delete it from login menu?

In order to be sure that I deeply understand how to do such switch in the right way - Can you give a short explanation of each step?!

Also I have an old locale language's problem - Although I add a locale language with KDE's settings, there is no symbol on screen and I can not change to locale language by pressing Alt+Shift (as I defined in input device setting) - I faced this problem only in this machine that was configured as Gnome/Systmed and now swtich to KDE/openRC - In my other machine KDE/RC it works ok - any idea?

Thanks a lot
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2514

PostPosted: Sun May 18, 2014 2:38 pm    Post subject: Reply with quote

Removing a flag from your USE means you accept the defaults for your profile.

-systemd -gnome means you force it to be omitted no matter what the defaults are.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun May 18, 2014 7:08 pm    Post subject: Reply with quote

pmam wrote:
I had changed to KDE (openRC) profile and afterword run:
Code:
emerge -avuND world
Is it enough or I should run
Code:
emerge --deep --newuse --ask @world
- Is it not the same?

pman ... yes, pretty much the same: '--ask, -a', '--deep, -D', '--newuse, -N', I always provde the long options on the forum as then the reader has some idea of what the option means if they are completely unfamilar.

pmam wrote:
BTW: What the difference between delete USE flag or to add '-'?

As 1clue pointed out, negating the useflag will overide it if set by the profile or via the defaults in an ebuild (IUSE).

pmam wrote:
OK - After I done according your advise it seems ok - Gnome is finally deleted - it still exist in the login menu, but if I choose it there is an 'Oh no!' massage - How can I delete it from login menu?

Have you restarted the login manager? I don't use a login manager but I imagine that whats offered is derived from /etc/X11/Sessions or /usr/share/xsessions/*.desktop. The gnome.desktop should have been removed when unmerging but the /etc/X11/Sessions prehaps not. If you delete any reference to gnome there it shouldn't turn be offered as an option (but, again, I don't use a login manager so I'm not entirely sure what method it uses).

pmam wrote:
In order to be sure that I deeply understand how to do such switch in the right way - Can you give a short explanation of each step?!

Mostly this should come as a effect of the profile change, the --depclean is run in order to remove the (nolonger required) dependencies that were installed. There isn't much to it.

pmam wrote:
Also I have an old locale language's problem - Although I add a locale language with KDE's settings, there is no symbol on screen and I can not change to locale language by pressing Alt+Shift (as I defined in input device setting) - I faced this problem only in this machine that was configured as Gnome/Systmed and now swtich to KDE/openRC - In my other machine KDE/RC it works ok - any idea?

Well, there is the 'locale' (which is really an environment setting ... type 'locale' in the terminal) and then there is internationalisation, 'i18n', and localisation, 'l10n', which are used by various applications, desktops, etc, to provide language translations, etc, for the GUI. So, these are seperate mechanisms. KDE probably installs app-i18n/kde-l10n-scripts (and perhaps other packages) for this purpose, it shouldn't be effected by gnome, at least not to my knowledge ... it may simply be a kde bug (and as I don't use kde I can only speculate).

best ... khay
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Mon May 19, 2014 7:19 am    Post subject: Reply with quote

Dear Khay,

Quote:
I always provide the long options on the forum as then the reader has some idea

It is a good idea - At least I have learnt from you more than just the abbreviation...

Quote:
Have you restarted the login manager?

Yes, I restarted and still Gnome remained - I checked in the directories you noted - /etc/X11/Sessions or /usr/share/xsessions/*.desktop -
and Gnome still there - Should I delete it manually?
BTW: You do not use login manager.. So how do you manage GUI desktops?

Quote:
it may simply be a kde bug

No - Switching between languages working ok in my other machine KDE/openRC -It may has to do to the origin installation Gnome/Systemd,
and when I switched to openRC the problem remained. Or I missed something regarding locale/internationalisation/localisation -
Please advise how can I debug/check what is missing? Can I verify app-i18n/kde-l10n-scripts?

Thanks for your helpful tips
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon May 19, 2014 12:03 pm    Post subject: Reply with quote

pmam wrote:
khayyam wrote:
Have you restarted the login manager?

Yes, I restarted and still Gnome remained - I checked in the directories you noted - /etc/X11/Sessions or /usr/share/xsessions/*.desktop - and Gnome still there - Should I delete it manually?

pmam ... yes, delete them ... you can check before hand that no package owns these with:

Code:
# equery belongs /path/to/file

pmam wrote:
BTW: You do not use login manager.. So how do you manage GUI desktops?

I don't use a "desktop" either, just a window manager. I manage this via ~/.xinitrc

pmam wrote:
khayyam wrote:
it may simply be a kde bug

No - Switching between languages working ok in my other machine KDE/openRC -It may has to do to the origin installation Gnome/Systemd, and when I switched to openRC the problem remained. Or I missed something regarding locale/internationalisation/localisation

Not having used systemd I'm not entirely sure how it handles this, though another recent thread suggests some different methodolgy is used. Anyhow, by bug I mean a bug created/encounterd when switching, though again, this is entirely speculation.

What does 'eselect locale list' show, is the localisation you're setting via kde there, and is LINGUAS set in make.conf and does it contain your language(s)? You might compare the two installs in this regard.

pmam wrote:
Please advise how can I debug/check what is missing? Can I verify app-i18n/kde-l10n-scripts?

It may not be something missing, it may be the outcome of the profile, or something set in the environment, I'm not sure. Anyhow, you can verify the content of a package with 'equery', eg:

Code:
# equery check app-i18n/kde-l10n-scripts

pmam wrote:
Thanks for your helpful tips

You're welcome ... HTH & best ... khay
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Tue May 20, 2014 6:46 pm    Post subject: Reply with quote

Dear Khay,

Oh yes! Finally I fixed the switching languages... I had done already the comparison between two machines,
but did not find any clue - However, after saw your reply I tried to add LINGUAS -
I do not use it in the other machine and did not know what LINGUAS is for,
but after adding, I saw that it enables changing the dialog/menus lang - as far as I can see.
However, during that process I found out that I missed one 'little' parameter in the input settings - once I changed this -switching lang was worked out!

Now I can rest a little and continue to the next problem - sharing directories with NFS...

Thanks a lot :)
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum