Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemas al actualizar sistema
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Thu May 15, 2014 12:36 pm    Post subject: problemas al actualizar sistema Reply with quote

Hola estoy intentando actualizar el sistema pero me salen muchos bloqueos y no se como solucionarlos

Code:
 #emerge -auvDN @system

[ebuild     U  ]  sys-devel/gcc-config-1.7.3 [1.5-r2] 15 kB
[nomerge       ] dev-libs/cyrus-sasl-2.1.23-r6:2  USE="berkdb crypt gdbm java pam ssl -authdaemond -kerberos -mysql -ntlm_unsupported_patch -openldap -postgres -sample -srp -urandom"
[nomerge       ]  dev-java/java-config-2.2.0:2 [2.1.11-r3:2] PYTHON_TARGETS="python2_7%* python3_2%* python3_3%* (-python2_6)"
[nomerge       ]   dev-java/java-config-wrapper-0.16
[ebuild     U  ]    app-portage/portage-utils-0.53 [0.8] USE="nls%* -static" 395 kB
[ebuild     U  ] sys-apps/baselayout-2.2 [2.0.3] USE="-build" 40 kB
[nomerge       ] media-video/vlc-1.1.13  USE="X a52 aac alsa cdda dbus dts dvd ffmpeg flac fontconfig gcrypt gnome libnotify matroska mmx mp3 mpeg ncurses ogg opengl png pulseaudio sse svg theora truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -bidi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -ggi -gme (-gnutls) -httpd -id3tag -ieee1394 -jack -kate -kde -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -live -lua -modplug -mtp -musepack -nsplugin -optimisememory -oss -projectm -pvr -qt4 -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -shine -shout -skins -speex -sqlite -stream (-svga) -taglib -twolame -upnp -v4l -vaapi -vcdx -vlm -win32codecs -wma-fixed -xosd -zvbi"
[ebuild     U  ]  media-libs/libpng-1.6.10:0/16 [1.5.9:0/0] USE="apng (-neon) -static-libs" ABI_X86="(64%*) (-32) (-x32)" 887 kB
[nomerge       ] media-libs/mesa-10.0.4 [7.11.2] USE="classic egl gallium llvm nptl xvmc%* -bindist -debug -gbm -gles1% -gles2% -llvm-shared-libs% -opencl% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler% (-selinux) -vdpau% -wayland% -xa% (-gles%) (-motif%) (-shared-dricore%) (-shared-glapi%*)" ABI_X86="(64%*) (-32) (-x32)" VIDEO_CARDS="(-freedreno) -i915% -i965% -ilo% -intel -nouveau -r100% -r200% -r300% -r600% -radeon -radeonsi% -vmware (-mach64%) (-mga%) (-r128%) (-savage%) (-sis%) (-tdfx%) (-via%)"
[nomerge       ]  dev-lang/python-2.7.5-r3:2.7 [2.7.2-r3:2.7] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened% -sqlite -tk -wininst"
[ebuild     U  ]   app-misc/mime-types-9 [8] 16 kB
[ebuild     U  ] sys-devel/gnuconfig-20131128 [20110202] 45 kB
[ebuild     U  ] app-arch/bzip2-1.0.6-r6 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.3] USE="nls threads -static-libs" ABI_X86="(64%*) (-32) (-x32)" 1,276 kB
[nomerge       ] www-plugins/adobe-flash-11.1.102.62  USE="64bit multilib -32bit -kde -vdpau"
[ebuild     U ~]  sys-libs/glibc-2.19:2.2 [2.12.2:2.2] USE="(multilib) vanilla* -debug -gd (-hardened) -nscd% -profile (-selinux) -suid% -systemtap% (-glibc-omitfp%) (-nls%*)" 19,749 kB
[blocks B      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks B      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-17)
[blocks B      ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-3.10.8)
[blocks B      ] sys-libs/timezone-data ("sys-libs/timezone-data" is blocking sys-libs/glibc-2.19)
[blocks B      ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.10.8)
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-26-r2)

Total: 248 packages (196 upgrades, 47 new, 3 in new slots, 2 reinstalls, 2 uninstalls), Size of downloads: 422,042 kB
Conflict: 17 blocks (6 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-fs/udev:0

  (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] required by (virtual/udev-208-r1::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-171-r5::gentoo, installed) pulled in by
    >=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, installed)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Test-Simple-0.980.0-r2::gentoo, ebuild scheduled for merge)
    >=dev-lang/perl-5.16 required by (perl-core/ExtUtils-Install-1.540.0::gentoo, ebuild scheduled for merge)
    (and 31 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/HTTP-Message-6.20.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/File-MimeInfo-0.150.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/LWP-MediaTypes-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/URI-1.590.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Daemon-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Date-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-HTTP-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (perl-core/Digest-MD5-2.510.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Encode-Locale-1.20.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.360.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/File-Listing-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.440.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/glibc-2.19::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/glibc-2.7 required by (sys-libs/pam-1.1.6-r2::gentoo, ebuild scheduled for merge)
    sys-libs/glibc required by (app-office/openoffice-bin-3.3.0::gentoo, installed)
    >=sys-libs/glibc-2.4 required by (www-plugins/adobe-flash-11.1.102.62::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (sys-devel/gcc-4.7.3-r1::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.15 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.5 required by (sys-apps/openrc-0.12.4::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.10 required by (sys-fs/udev-171-r5::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (media-video/vlc-1.1.13::gentoo, installed)
    sys-libs/glibc required by (app-arch/rar-4.0.1::gentoo, installed)
    >=sys-libs/glibc-2.6.1 required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)
    sys-libs/glibc:2.2 required by (virtual/libc-0::gentoo, installed)

  (x11-libs/gtk+-3.10.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gtk+:3 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
    x11-libs/gtk+:3 required by (media-plugins/audacious-plugins-3.1::gentoo, installed)
    >=x11-libs/gtk+-2.90.7:3 required by (sys-apps/gnome-disk-utility-3.0.2-r200::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=x11-libs/gtk+-2.90.0:3[introspection?] (>=x11-libs/gtk+-2.90.0:3[introspection]) required by (dev-libs/libunique-3.0.2::gentoo, installed)
    >=x11-libs/gtk+-3.0.8:3 required by (x11-themes/gnome-themes-standard-3.0.2::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/audacious-3.1::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-base/dconf-0.10.0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3[introspection] required by (x11-libs/vte-0.28.2-r300::gentoo, installed)

  (sys-apps/module-init-tools-3.16-r1::gentoo, installed) pulled in by
    sys-apps/module-init-tools required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)

  (x11-libs/vte-0.28.2-r300::gentoo, installed) pulled in by
    x11-libs/vte required by @selected

  (sys-apps/kmod-17::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/kmod-16 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)

  (sys-fs/udev-init-scripts-26-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)

  (sys-libs/timezone-data-2011n::gentoo, installed) pulled in by
    >=sys-libs/timezone-data-2010k required by (dev-libs/libgweather-2.30.3::gentoo, installed)
    sys-libs/timezone-data required by @selected

  (x11-base/xorg-server-1.11.2-r2::gentoo, installed) pulled in by
    x11-base/xorg-server required by @selected
    >=x11-base/xorg-server-1.5.99.901 required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    x11-base/xorg-server required by (media-video/nvidia-settings-260.19.29::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.62::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


He probado de actualizar borrar y enmascarar los paquetes pero no se soluciona tambien he hecho un :
Code:
#emerge --autounmask-keep-masks @system

[nomerge       ] app-admin/sudo-1.8.3_p2  USE="ldap nls pam -offensive (-selinux) -skey"
[nomerge       ]  dev-libs/cyrus-sasl-2.1.23-r6:2  USE="berkdb crypt gdbm java pam ssl -authdaemond -kerberos -mysql -ntlm_unsupported_patch -openldap -postgres -sample -srp -urandom"
[ebuild  N     ]   dev-libs/openssl-1.0.1g  USE="(sse2) tls-heartbeat vanilla zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test}" 0 kB
[ebuild  NS    ] sys-devel/gcc-4.7.3-r1:4.7 [4.5.3-r2:4.5] USE="cxx fortran (multilib) nls nptl openmp vanilla (-altivec) -awt -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -mudflap -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test" 81,022 kB
[ebuild     U  ]  sys-devel/binutils-2.23.2 [2.21.1-r1] USE="cxx%* nls vanilla zlib -multislot -multitarget -static-libs {-test}" 20,949 kB
[ebuild     U  ] sys-apps/diffutils-3.3 [3.0] USE="nls -static" 1,170 kB
[ebuild   R    ] sys-apps/findutils-4.4.2-r1  USE="nls (-selinux) -static" 0 kB
[ebuild     U  ] sys-devel/make-3.82-r4 [3.82-r1] USE="nls -static" 0 kB
[ebuild     U  ] sys-process/psmisc-22.20 [22.14] USE="X ipv6 nls (-selinux)" 423 kB
[ebuild     U  ] sys-apps/texinfo-4.13-r2 [4.13] USE="nls -static" 1,528 kB
[ebuild     U  ] sys-apps/sed-4.2.1-r1 [4.2.1] USE="acl nls (-selinux) -static" 879 kB
[ebuild   R    ] virtual/libc-0  0 kB
[ebuild   R    ] sys-devel/patch-2.6.1  USE="-static {-test}" 0 kB
[ebuild   R    ] virtual/pager-0  0 kB
[ebuild     U  ] sys-apps/which-2.20-r1 [2.20] 133 kB
[ebuild     U  ] sys-apps/net-tools-1.60_p20130513023548 [1.60_p20110409135728] USE="nls -old-output% (-selinux) -static" 196 kB
[nomerge       ] sys-apps/coreutils-8.21 [8.14] USE="acl nls vanilla -caps -gmp (-selinux) -static -xattr (-unicode%*)"
[blocks b      ]  app-misc/realpath ("app-misc/realpath" is blocking sys-apps/coreutils-8.21)
[uninstall     ]   app-misc/realpath-1.16  USE="nls"
[ebuild     U  ] sys-apps/coreutils-8.21 [8.14] USE="acl nls vanilla -caps -gmp (-selinux) -static -xattr (-unicode%*)" 5,281 kB
[ebuild   R    ] app-shells/bash-4.2_p45  USE="net nls (readline) vanilla -afs -bashlogger -examples -mem-scramble -plugins" 0 kB
[ebuild     U  ] sys-apps/less-457 [444] USE="pcre%* unicode" 500 kB
[nomerge       ] sys-devel/gcc-4.7.3-r1:4.7 [4.5.3-r2:4.5] USE="cxx fortran (multilib) nls nptl openmp vanilla (-altivec) -awt -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -mudflap -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test"
[ebuild     U  ]  sys-devel/gcc-config-1.7.3 [1.5-r2] 15 kB
[ebuild     U  ] sys-apps/baselayout-2.2 [2.0.3] USE="-build" 40 kB
[ebuild   R    ] virtual/os-headers-0  0 kB
[ebuild     U  ] sys-devel/gnuconfig-20131128 [20110202] 45 kB
[ebuild     U  ] app-arch/bzip2-1.0.6-r6 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.3] USE="nls threads -static-libs" ABI_X86="(64%*) (-32) (-x32)" 1,276 kB
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-26-r2)
[blocks B      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-17)
[blocks B      ] <sys-apps/sysvinit-2.88-r6 ("<sys-apps/sysvinit-2.88-r6" is blocking sys-process/procps-3.3.9)
[blocks B      ] >=sys-apps/util-linux-2.23 (">=sys-apps/util-linux-2.23" is blocking sys-apps/sysvinit-2.88-r4)
[blocks B      ] <sys-apps/sysvinit-2.88-r7 ("<sys-apps/sysvinit-2.88-r7" is blocking sys-apps/util-linux-2.24.1-r2)
[blocks B      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)

Total: 61 packages (39 upgrades, 9 new, 2 in new slots, 11 reinstalls, 2 uninstalls), Size of downloads: 144,523 kB
Conflict: 11 blocks (6 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-fs/udev:0

  (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] required by (virtual/udev-208-r1::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-171-r5::gentoo, installed) pulled in by
    >=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.20 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.7::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.13 required by (sys-power/pm-utils-1.4.1-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-171-r5::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.0::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0::gentoo, installed)
    sys-apps/util-linux required by @system
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.4::gentoo, installed)

  (sys-apps/module-init-tools-3.16-r1::gentoo, installed) pulled in by
    sys-apps/module-init-tools required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)

  (sys-apps/sysvinit-2.88-r4::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.12.4::gentoo, ebuild scheduled for merge)
    sys-apps/sysvinit required by @selected

  (sys-process/procps-3.3.9::gentoo, ebuild scheduled for merge) pulled in by
    sys-process/procps required by @system

  (sys-apps/kmod-17::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, ebuild scheduled for merge)
    >=sys-apps/kmod-16 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-init-scripts-26-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- media-libs/mesa-7.11.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (26 Mar 2014)
# Affected by multiple vulnerabilities, #445916, #471098 and #472280

- www-plugins/adobe-flash-11.1.102.62::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Pero tampoco se soluciona nada estoy bastante perdido .
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 337

PostPosted: Thu May 15, 2014 4:04 pm    Post subject: Reply with quote

Intenta actualizar por etapas:

Primero intenta esto:

Code:
#emerge -e system


y/o

Code:
 #emerge -auD @system


Por si no estas al tanto, ahora gnome y sus deps necesitan migrar a systemd. Alguna novedad en las News?
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Thu May 15, 2014 5:36 pm    Post subject: Reply with quote

Hola natrix el emerge -e system me da esto:

Code:
# emerge -e system

[ebuild     U  ]   app-misc/mime-types-9 [8] 16 kB
[ebuild     U  ] sys-apps/baselayout-2.2 [2.0.3] USE="-build" 40 kB
[nomerge       ] media-video/vlc-1.1.13  USE="X a52 aac alsa cdda dbus dts dvd ffmpeg flac fontconfig gcrypt gnome libnotify matroska mmx mp3 mpeg ncurses ogg opengl png pulseaudio sse svg theora truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -bidi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -ggi -gme (-gnutls) -httpd -id3tag -ieee1394 -jack -kate -kde -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -live -lua -modplug -mtp -musepack -nsplugin -optimisememory -oss -projectm -pvr -qt4 -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl -sdl-image -shine -shout -skins -speex -sqlite -stream (-svga) -taglib -twolame -upnp -v4l -vaapi -vcdx -vlm -win32codecs -wma-fixed -xosd -zvbi"
[ebuild     U  ]  media-libs/libpng-1.6.10:0/16 [1.5.9:0/0] USE="apng (-neon) -static-libs" ABI_X86="(64%*) (-32) (-x32)" 887 kB
[ebuild     U  ] sys-devel/gnuconfig-20131128 [20110202] 45 kB
[nomerge       ] media-plugins/audacious-plugins-3.1  USE="aac alsa cdda ffmpeg flac gnome ipv6 lame libnotify mp3 nls pulseaudio vorbis -adplug (-aqua) -bs2b -cue -fluidsynth -jack -libsamplerate -midi -mms -mtp -oss -scrobbler -sid -sndfile -wavpack"
[nomerge       ]  media-libs/libcddb-1.3.2  USE="-doc -static-libs"
[ebuild   R    ]   virtual/libiconv-0-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild   R    ] dev-libs/expat-2.1.0-r3  USE="unicode -examples -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[nomerge       ] sys-apps/util-linux-2.24.1-r2 [2.20.1-r1] USE="cramfs ncurses nls pam%* python%* suid%* udev%* unicode -bash-completion% -caps% -cytune% -fdformat% (-selinux) -slang -static-libs {-test%} -tty-helpers% (-crypt%*) (-ddate%) (-loop-aes%) (-old-linux%) (-perl%*) (-uclibc%)" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)"
[ebuild   R    ]  dev-lang/python-exec-2.0.1-r1:2  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy) (python2_6) (python2_7) (python3_2) (python3_3) (-python3_4)" 0 kB
[ebuild     U  ] app-arch/bzip2-1.0.6-r6 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[nomerge       ] app-editors/vim-7.3.409  USE="X acl gpm nls perl python -cscope -debug -minimal -ruby -vim-pager"
[nomerge       ]  app-editors/vim-core-7.3.409  USE="acl nls -livecd"
[ebuild   R    ]   virtual/libintl-0  0 kB
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.3] USE="nls threads -static-libs" ABI_X86="(64%*) (-32) (-x32)" 1,276 kB
[nomerge       ] app-mobilephone/obex-data-server-0.4.5  USE="gtk usb -debug -imagemagick"
[nomerge       ]  dev-libs/glib-2.38.2-r1:2 [2.30.2:2] USE="-debug (-fam*) (-selinux) -static-libs* -systemtap {-test} -utils -xattr (-doc%)" ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python2_7%* (-python2_6)"
[nomerge       ]   dev-libs/elfutils-0.158 [0.149] USE="bzip2 nls utils%* zlib -lzma -static-libs% {-test%} (-threads)" ABI_X86="(64%*) (-32) (-x32)"
[ebuild   R    ]    sys-libs/zlib-1.2.8-r1  USE="-minizip -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[nomerge       ] www-plugins/adobe-flash-11.1.102.62  USE="64bit multilib -32bit -kde -vdpau"
[ebuild     U ~]  sys-libs/glibc-2.19:2.2 [2.12.2:2.2] USE="(multilib) vanilla* -debug -gd (-hardened) -nscd% -profile (-selinux) -suid% -systemtap% (-glibc-omitfp%) (-nls%*)" 19,749 kB
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-26)
[blocks B      ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.10.8)
[blocks B      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-16)
[blocks B      ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-3.10.8)
[blocks B      ] sys-libs/timezone-data ("sys-libs/timezone-data" is blocking sys-libs/glibc-2.19)
[blocks B      ] >=net-misc/netifrc-0.2.1 (">=net-misc/netifrc-0.2.1" is blocking sys-fs/udev-init-scripts-26)
[blocks B      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks B      ] <sys-fs/udev-init-scripts-26-r1 ("<sys-fs/udev-init-scripts-26-r1" is blocking net-misc/netifrc-0.2.2)

Total: 306 packages (198 upgrades, 47 new, 3 in new slots, 58 reinstalls, 2 uninstalls), Size of downloads: 424,028 kB
Conflict: 20 blocks (8 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-fs/udev:0

  (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] required by (virtual/udev-208-r1::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-171-r5::gentoo, installed) pulled in by
    >=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, installed)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Test-Simple-0.980.0-r2::gentoo, ebuild scheduled for merge)
    >=dev-lang/perl-5.16 required by (perl-core/ExtUtils-Install-1.540.0::gentoo, ebuild scheduled for merge)
    (and 32 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/HTTP-Message-6.20.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/File-MimeInfo-0.150.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/LWP-MediaTypes-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/URI-1.590.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Daemon-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Date-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-HTTP-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (perl-core/Digest-MD5-2.510.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Encode-Locale-1.20.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.360.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/File-Listing-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.440.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/kmod-16::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, ebuild scheduled for merge)
    >=sys-apps/kmod-16 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/vte-0.28.2-r300::gentoo, installed) pulled in by
    x11-libs/vte required by @selected

  (sys-apps/module-init-tools-3.16-r1::gentoo, installed) pulled in by
    sys-apps/module-init-tools required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)
    sys-apps/module-init-tools required by @selected

  (sys-libs/glibc-2.19::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/glibc-2.7 required by (sys-libs/pam-1.1.6-r2::gentoo, ebuild scheduled for merge)
    sys-libs/glibc required by (app-office/openoffice-bin-3.3.0::gentoo, installed)
    >=sys-libs/glibc-2.4 required by (www-plugins/adobe-flash-11.1.102.62::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (sys-devel/gcc-4.7.3-r1::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.15 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.5 required by (sys-apps/openrc-0.12.4::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.10 required by (sys-fs/udev-171-r5::gentoo, installed)
    >=sys-libs/glibc-2.8 required by (media-video/vlc-1.1.13::gentoo, installed)
    sys-libs/glibc required by (app-arch/rar-4.0.1::gentoo, installed)
    >=sys-libs/glibc-2.6.1 required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)
    sys-libs/glibc:2.2 required by (virtual/libc-0::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-init-scripts-26::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/gtk+-3.10.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.90.7:3 required by (sys-apps/gnome-disk-utility-3.0.2-r200::gentoo, installed)
    x11-libs/gtk+:3 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
    x11-libs/gtk+:3 required by (media-plugins/audacious-plugins-3.1::gentoo, installed)
    >=x11-libs/gtk+-2.90.0:3[introspection?] (>=x11-libs/gtk+-2.90.0:3[introspection]) required by (dev-libs/libunique-3.0.2::gentoo, installed)
    >=x11-libs/gtk+-3.0.8:3 required by (x11-themes/gnome-themes-standard-3.0.2::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/audacious-3.1::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-base/dconf-0.10.0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3[introspection] required by (x11-libs/vte-0.28.2-r300::gentoo, installed)

  (sys-libs/timezone-data-2011n::gentoo, installed) pulled in by
    >=sys-libs/timezone-data-2010k required by (dev-libs/libgweather-2.30.3::gentoo, installed)
    sys-libs/timezone-data required by @selected

  (net-misc/netifrc-0.2.2::gentoo, ebuild scheduled for merge) pulled in by
    net-misc/netifrc required by (sys-apps/openrc-0.12.4::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.11.2-r2::gentoo, installed) pulled in by
    x11-base/xorg-server required by @selected
    >=x11-base/xorg-server-1.5.99.901 required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/nvidia-drivers-290.10::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    x11-base/xorg-server required by (media-video/nvidia-settings-260.19.29::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.62::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



En las news no hay novedades
Code:
# eselect news list
News items:
  [1]      2009-04-18  Generation 1 Java Setup Deprecated
  [2]      2010-03-25  Python 3.1
  [3]      2010-08-01  (2010-08-01-as-needed-default - removed?)
  [4]      2011-08-28  Mesa r600 driver now defaults to gallium
  [5]      2011-10-15  Upgrade to libpng15
  [6]      2011-11-26  Unmasking of and Upgrade to GNOME 3.2
  [7]      2012-05-21  Portage config-protect-if-modified default
  [8]      2012-11-06  PYTHON_TARGETS deployment
  [9]      2013-03-29  Upgrading udev to version >=200
  [10]     2013-06-07  Portage preserve-libs default
  [11]     2013-08-23  Language of messages in emerge logs and output
  [12]     2013-09-27  Separate /usr on Linux requires initramfs
  [13]     2013-10-14  GRUB2 migration
  [14]     2013-11-23  Upgrade to GNOME 3.8
  [15]     2014-02-25  Upgrade to >=sys-fs/udev-210
  [16]     2014-03-02  Profile EAPI 5 requirement
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Thu May 15, 2014 6:15 pm    Post subject: Reply with quote

@pedraku:
Prueba
Code:
emerge -pvuDN @world
Puede que afecte a más paquetes pero también que te salgan menos conflictos y bloqueos.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 337

PostPosted: Thu May 15, 2014 7:00 pm    Post subject: Reply with quote

Observa el News 16, si cuando migraste portage algún EAPI quedo en 4 debes pasarlo a 5.

En el News 15, más adelante tendrás que migrar de openrc a systemd para que funcione gnome.
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Thu May 15, 2014 10:15 pm    Post subject: Reply with quote

quilosaq haciendo el emerge que me dices me salen un monton de bloqueos y no se por donde tirar

Lo de el EAPI he mirado aqui y lo tengo en 5 no se si hay otro fichero EAPI
Code:
nano -w /usr/portage/profiles/default/linux/amd64/13.0/desktop/gnome/eapi

Code:
nano /usr/portage/profiles/eapi

he probado de insttalar systemd pero tampoco me deja
Code:
# emerge -pv systemd


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!


[ebuild  N     ] sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit python tcpd vanilla -audit -cryptsetup -doc -gcrypt -http -lzma -qrcode (-selinux) {-test} -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 2,335 kB
[ebuild     U  ]  sys-apps/util-linux-2.24.1-r2 [2.20.1-r1] USE="cramfs ncurses nls pam%* python%* suid%* udev%* unicode -bash-completion% -caps% -cytune% -fdformat% (-selinux) -slang -static-libs {-test%} -tty-helpers% (-crypt%*) (-ddate%) (-loop-aes%) (-old-linux%) (-perl%*) (-uclibc%)" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)" 3,461 kB
[ebuild  N     ]  sys-fs/udev-init-scripts-26  5 kB
[ebuild  N     ]  sys-apps/hwids-20140317  USE="udev" 1,585 kB
[ebuild  N     ]   virtual/udev-208-r1  USE="gudev introspection kmod (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[nomerge       ] gnome-base/gnome-light-2.32.1-r1:2.0  USE="automount"
[nomerge       ]  gnome-base/nautilus-2.32.2.1-r1  USE="gnome -doc -introspection {-test} -xmp"
[nomerge       ]   dev-libs/libunique-1.1.6-r1:1  USE="dbus introspection -debug -doc {-test}"
[ebuild     U  ]    sys-apps/dbus-1.6.18-r1 [1.4.16] USE="X systemd%* -debug -doc (-selinux) -static-libs {-test}" ABI_X86="(64%*) (-32) (-x32)" 1,872 kB

Total: 6 packages (2 upgrades, 4 new), Size of downloads: 9,256 kB

 * Error: circular dependencies:

(sys-apps/dbus-1.6.18-r1::gentoo, ebuild scheduled for merge) depends on
 (sys-apps/systemd-208-r3::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/dbus-1.6.18-r1::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- sys-apps/dbus-1.6.18-r1 (Change USE: -systemd)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/util-linux:0

  (sys-apps/util-linux-2.20.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.22 required by (sys-apps/systemd-208-r3::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.62::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Thu May 15, 2014 11:04 pm    Post subject: Reply with quote

Tendrás que ir desenmarañando el enredo poco a poco.

Elige un objetivo: un paquete concreto, varios paquetes, system o world. Haz emerge de ese objetivo y pega la salida para que te podamos ayudar. Yo elegiría world.

Si la salida es muy larga, pégala en bpaste.net y aquí pon sólo el enlace.


Last edited by quilosaq on Thu May 15, 2014 11:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 337

PostPosted: Thu May 15, 2014 11:10 pm    Post subject: Reply with quote

jajaja, interesante!!!!

Deja systemd para más adelante, no es solo un emerge. Necesitas hacer toda una migración, hechale un vistazo al manual y veras...

Intenta emerger xorg-server y glibc.Si no funciona intenta emergerlos con un --nodeps a ver que pasa.
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Fri May 16, 2014 12:04 am    Post subject: Reply with quote

quilosaq aqui dejo el enlace de la salida de emerge --update --ask @world

http://bpaste.net/show/qtyIizdAdsH61xgd5u6X/

natrix esto es lo que me sale con emerger xorg-server y glibc:

Code:
pedraku # emerge -pv --nodeps glibc
 * --tree is broken with --nodeps. Disabling...

These are the packages that would be merged, in order:

[ebuild     U ~] sys-libs/glibc-2.19:2.2 [2.12.2:2.2] USE="(multilib) vanilla* -debug -gd (-hardened) -nscd% -profile (-selinux) -suid% -systemtap% (-glibc-omitfp%) (-nls%*)" 19,749 kB

Total: 1 package (1 upgrade), Size of downloads: 19,749 kB


Code:
 pedraku # emerge -pv --nodeps xorg-server
 * --tree is broken with --nodeps. Disabling...

These are the packages that would be merged, in order:

[ebuild     U  ] x11-base/xorg-server-1.15.0:0/1.15.0 [1.11.2-r2:0/0] USE="ipv6 nptl suid%* udev xorg -dmx -doc -kdrive* -minimal (-selinux) -static-libs -tslib -unwind% -xnest -xvfb" 5,417 kB

Total: 1 package (1 upgrade), Size of downloads: 5,417 kB


y aqui dejo el enlace tras emerger xorg-server sin --nodeps

http://bpaste.net/show/mQXv5C4NwZolUeVYApgj/
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 337

PostPosted: Fri May 16, 2014 2:44 am    Post subject: Reply with quote

Ahora que arroja "#emerge -e system" ?

Mejor desinstala temporalmente el adobe-flash que te va a molestar hasta el final
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Fri May 16, 2014 6:53 am    Post subject: Reply with quote

Hola natrix aqui te dejo la salida del emerge -e system muchos bloqueos salen :

http://bpaste.net/show/Cm9QeMIY6XaspfFvcqbC/
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Sat May 17, 2014 10:56 am    Post subject: Reply with quote

Entiendo que estas todo en estable, y ninguno de los paquetes implicados esta en ~X. Lo que yo haría es:

[blocks B ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-26)
[blocks B ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.10.8)
[blocks B ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-16)
[blocks B ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-3.10.8)
[blocks B ] sys-libs/timezone-data ("sys-libs/timezone-data" is blocking sys-libs/glibc-2.19)
[blocks B ] >=net-misc/netifrc-0.2.1 (">=net-misc/netifrc-0.2.1" is blocking sys-fs/udev-init-scripts-26)
[blocks B ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks B ] <sys-fs/udev-init-scripts-26-r1 ("<sys-fs/udev-init-scripts-26-r1" is blocking net-misc/netifrc-0.2.2)

Para el Azul oscuro:
Desinstala sys-libs/timezone-data, actualiza glibc y vuelve a instalar sys-libs/timezone-data

Para el Verde:
Tienes un bloqueo circular. Yo los soluciono desinstalando uno de los paquetes, actualizando el otro y volviendo a instalar el paquete desinstalado.

Para el rojo:
Tienes otro bloqueo circular y ademas de rebote afecta a udev. Lo que yo haría es desinstalar net-misc/netifrc, y actualizar udev-init-script y udev. Y después volver a instalar netifrc

Para el indigo:
Cuarto lo mismo, desinstala x11-libs/vte, actualiza gtk y xorg-server, y después vuelves a instalar vte

Una vez este todo resuelto:
emerge -avquD
revdep-rebuild
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Sun May 18, 2014 10:48 am    Post subject: Reply with quote

hola agdg estoy siguiendo los pasos que me dices pero al actualizar glibc me sale el siguiente error :

Code:
 * ERROR: sys-libs/glibc-9999::gentoo failed (compile phase):
 *   make for amd64 failed
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called src_compile
 *         environment, line 3965:  Called eblit-run 'src_compile'
 *         environment, line 1095:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  259:  Called src_compile
 *         environment, line 3965:  Called eblit-run 'src_compile'
 *         environment, line 1095:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  267:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  166:  Called die
 * The specific snippet of code:
 *         emake || die "make for ${ABI} failed"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/glibc-9999/work/build-amd64-x86_64-pc-linux-gnu-nptl'
 * S: '/var/tmp/portage/sys-libs/glibc-9999/work/glibc-9999'

>>> Failed to emerge sys-libs/glibc-9999, Log file:

>>>  '/var/tmp/portage/sys-libs/glibc-9999/temp/build.log'

 * Messages for package sys-libs/glibc-9999:

 * ERROR: sys-libs/glibc-9999::gentoo failed (compile phase):
 *   make for amd64 failed
 *
 * Call stack:
 *           ebuild.sh, line   93:  Called src_compile
 *         environment, line 3965:  Called eblit-run 'src_compile'
 *         environment, line 1095:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  259:  Called src_compile
 *         environment, line 3965:  Called eblit-run 'src_compile'
 *         environment, line 1095:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  267:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  166:  Called die
 * The specific snippet of code:
 *         emake || die "make for ${ABI} failed"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-9999::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-9999::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/glibc-9999/work/build-amd64-x86_64-pc-linux-gnu-nptl'
 * S: '/var/tmp/portage/sys-libs/glibc-9999/work/glibc-9999'
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Sun May 18, 2014 12:43 pm    Post subject: Reply with quote

Estás queriendo instalar una versión 9999 de glibc que está fuertemente enmascarada para impedir que se instale de manera normal. Pega la salida de
Code:
emerge --info
sin omitir ningún mensaje de error o advertencia.
EDITO: No es un enmascaramiento fuerte sino falta de declaración de ACCEPT_KEYWORDS.


Last edited by quilosaq on Mon May 19, 2014 2:16 pm; edited 2 times in total
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Sun May 18, 2014 12:50 pm    Post subject: Reply with quote

aqui esta la salida quilosaq

Code:
pedraku # emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop, gcc-4.5.3, glibc-2.12.2, 3.2.1-gentoo-r2 x86_64)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-with-gentoo-2.0.3
KiB Mem:     1795408 total,     71400 free
KiB Swap:    1412092 total,   1081140 free
Timestamp of tree: Fri, 16 May 2014 23:45:01 +0000
ld GNU ld (GNU Binutils) 2.21.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1, 1.13.4
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000

ABI="amd64"
ABI_X86="64"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
AUTOCLEAN="yes"
BOOTSTRAP_USE="cxx unicode internal-glib python_targets_python3_3 python_targets_python2_7 multilib"
CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_amd64="-m64"
CFLAGS_x32="-mx32"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x32="x86_64-pc-linux-gnux32"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-1JQDuyFegz,guid=7096816ee767091dfd23b04c0000001f"
DEFAULT_ABI="amd64"
DESKTOP_AUTOSTART_ID="10d43aa29ea59beec8140021555210461500000022820000"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--ask --verbose --tree"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FETCHCOMMAND="wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; eval \"declare -a ssh_opts=(\${3})\" ; exec sftp -P \${port} \"\${ssh_opts[@]}\" \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
FFLAGS="-O2 -pipe"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
GNOME_DESKTOP_SESSION_ID="this-is-deprecated"
GNOME_KEYRING_CONTROL="/tmp/keyring-Px6JpY"
GNOME_KEYRING_PID="2243"
GPG_AGENT_INFO="/tmp/keyring-Px6JpY/gpg:0:1"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx"
GRUB_PLATFORMS=""
GSETTINGS_BACKEND="dconf"
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.21.1/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.3/info"
INPUT_DEVICES="evdev"
IUSE_IMPLICIT="prefix"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LANG="es_ES@euro.UTF-8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ADDRESS="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LC_COLLATE="C"
LC_CTYPE="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_MESSAGES="C"
LC_MONETARY="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_amd64="-m elf_x86_64"
LDFLAGS_x32="-m elf32_x86_64"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_arm="lib"
LIBDIR_arm64="lib64"
LIBDIR_n32="lib32"
LIBDIR_n64="lib64"
LIBDIR_o32="lib"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x32="libx32"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"
LINGUAS="es"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/pedraku"
MAKEOPTS="-j3"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.21.1/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.3/man:/etc/java-config/system-vm/man/"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage|udev|systemd|clang|python-exec)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OFFICE_IMPLEMENTATION="libreoffice"
OPENGL_PROFILE="xorg-x11"
ORBIT_SOCKETDIR="/tmp/orbit-pedraku"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PHP_TARGETS="php5-5"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc sparc64-freebsd ppc-openbsd x86-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd ppc64-linux x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris m68k sh arm64 x86-solaris sparc-fbsd"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary:log,warn,error,qa echo"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_GPG_SIGNING_COMMAND="gpg --sign --digest-algo SHA256 --clearsign --yes --default-key "${PORTAGE_GPG_KEY}" --homedir "${PORTAGE_GPG_DIR}" "${FILE}""
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_INTERNAL_CALLER="1"
PORTAGE_OVERRIDE_EPREFIX=""
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_PYTHONPATH="/usr/lib64/portage/pym"
PORTAGE_REPOSITORIES="[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
masters =
priority = -1000
sync-type = rsync
sync-uri = rsync://rsync.europe.gentoo.org/gentoo-portage
"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTAGE_XATTR_EXCLUDE="security.* system.nfs4_acl"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
PORT_LOGDIR_CLEAN="find "${PORT_LOGDIR}" -type f ! -name "summary.log*" -mtime +7 -delete"
PRELINK_PATH_MASK="/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so"
PROFILE_ONLY_VARIABLES="ARCH ELIBC IUSE_IMPLICIT KERNEL USERLAND USE_EXPAND_IMPLICIT USE_EXPAND_UNPREFIXED USE_EXPAND_VALUES_ARCH USE_EXPAND_VALUES_ELIBC USE_EXPAND_VALUES_KERNEL USE_EXPAND_VALUES_USERLAND"
PWD="/home/pedraku"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_3"
RESUMECOMMAND="wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port} \${3}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}" "${PORTAGE_SSH_OPTS}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.3"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby19 ruby20"
SESSION_MANAGER="local/AcuGentoo:@/tmp/.ICE-unix/2282,unix/AcuGentoo:/tmp/.ICE-unix/2282"
SHELL="/bin/bash"
SHLVL="4"
SSH_AUTH_SOCK="/tmp/keyring-Px6JpY/ssh"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
UNINSTALL_IGNORE="/lib/modules/*"
USE="3dnow X a52 aac acl acpi adns alsa amd64 apm atm berkdb bluetooth branding bzip2 cairo cdda cdr cgi cli consolekit cracklib crypt curl cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran gdbm gif gimp gnome gpm gtk hddtemp iconv icu ipv6 java jpeg lame lcms ldap libnotify lm_sensors mad matroska mdnsresponder-compat mmx mng moc modules mp3 mp4 mpeg mplayer multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf perl png policykit ppds python qt3support readline session spell sse sse2 ssl startup-notification subversion svg tcpd theora threads tiff truetype udev udisks unicode upower usb vanilla vorbis wxwidgets x264 xcb xcomposite xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS CURL_SSL DRACUT_MODULES DVB_CARDS ELIBC ENLIGHTENMENT_MODULES FCDSL_CARDS FFTOOLS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL LCD_DEVICES LIBREOFFICE_EXTENSIONS LINGUAS LIRC_DEVICES MONKEYD_PLUGINS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="ABI_MIPS ABI_PPC ABI_S390 CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_EXPAND_IMPLICIT="ARCH ELIBC KERNEL USERLAND"
USE_EXPAND_UNPREFIXED="ARCH"
USE_EXPAND_VALUES_ARCH="alpha amd64 amd64-fbsd amd64-linux arm arm-linux arm64 hppa hppa-hpux ia64 ia64-hpux ia64-linux m68k m68k-mint mips ppc ppc64 ppc64-linux ppc-aix ppc-macos ppc-openbsd s390 sh sparc sparc64-freebsd sparc64-solaris sparc-fbsd sparc-solaris x64-freebsd x64-macos x64-openbsd x64-solaris x86 x86-cygwin x86-fbsd x86-freebsd x86-interix x86-linux x86-macos x86-netbsd x86-openbsd x86-solaris x86-winnt"
USE_EXPAND_VALUES_ELIBC="AIX Cygwin Darwin DragonFly FreeBSD glibc HPUX Interix mintlib musl NetBSD OpenBSD SunOS uclibc Winnt"
USE_EXPAND_VALUES_KERNEL="AIX Cygwin Darwin FreeBSD freemint HPUX Interix linux NetBSD OpenBSD SunOS Winnt"
USE_EXPAND_VALUES_USERLAND="BSD GNU"
USE_ORDER="env:pkg:conf:defaults:pkginternal:repo:env.d"
VIDEO_CARDS="nvidia"
WINDOWPATH="7"
XAUTHORITY="/root/.xauthbRlXUN"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XDG_SESSION_COOKIE="f78bf5b62ccbdef3a490812800000009-1400215550.356422-326339997"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
_="/usr/bin/emerge"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Sun May 18, 2014 4:21 pm    Post subject: Reply with quote

Quizá lo tienes aceptado en /etc/portage. ¿Que dice
Code:
grep -R glibc /etc/portage
?
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Sun May 18, 2014 7:46 pm    Post subject: Reply with quote

aqui esta quilosaq

Code:
pedraku # grep -R glibc /etc/portage
/etc/portage/package.unmask:#=sys-libs/glibc-9999
/etc/portage/package.mask.save:#sys-libs/glibc
/etc/portage/package.mask.save:#<=sys-libs/glibc-2.19::gentoo
/etc/portage/package.mask:#sys-libs/glibc
/etc/portage/package.mask:#<=sys-libs/glibc-2.19::gentoo
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Sun May 18, 2014 9:46 pm    Post subject: Reply with quote

Has un emerge -avq glibc y pega toda la salida, incluyendo el log de compilación completo. Para no ensuciar mucho el foro, te recomiendo usar pastebin o algún servicio similar.
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Sun May 18, 2014 9:47 pm    Post subject: Reply with quote

Debes tener algo mal en los archivos del perfil. ¿Puedes hacer emerge --sync?, y ¿emerge portage?
¿Qué perfil tienes seleccionado?
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Sun May 18, 2014 10:59 pm    Post subject: Reply with quote

hola agdg esto es lo que sale de emerge -avq glibc

http://bpaste.net/show/LEirHSqLw5UxaQucklhC/


no me sale todo completo


si puedo hacer emerge --sync y emerge portage

el perfil que tengo es

Code:
pedraku # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop *
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/kde
  [7]   default/linux/amd64/13.0/desktop/kde/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/x32
  [11]  hardened/linux/amd64
  [12]  hardened/linux/amd64/selinux
  [13]  hardened/linux/amd64/no-multilib
  [14]  hardened/linux/amd64/no-multilib/selinux
  [15]  hardened/linux/amd64/x32
  [16]  hardened/linux/uclibc/amd64
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Mon May 19, 2014 12:51 am    Post subject: Reply with quote

¿Qué dice
Code:
emerge -pv glibc
?
Back to top
View user's profile Send private message
pedraku
n00b
n00b


Joined: 23 Apr 2011
Posts: 70

PostPosted: Mon May 19, 2014 3:19 pm    Post subject: Reply with quote

Hola quilosaq esto es lo que dice

Code:
pedraku # emerge -pv glibc

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/glibc-2.17:2.2 [2.12.2:2.2] USE="(multilib) vanilla* -debug -gd (-hardened) -nscd% -profile (-selinux) -suid% -systemtap% (-glibc-omitfp%) (-nls%*)" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

!!! The following installed packages are masked:
- dev-python/argparse-1.2.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (26 Apr 2014)
# (on behalf of Python team)
# Python 2.6 is no longer supported upstream and security issue fixes
# are not provided anymore. Python 2.7 is almost drop-in replacement.
# The Python itself will be masked in 30 days, and all packages will be
# removed in 60 days.
#dev-lang/python:2.6

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 337

PostPosted: Mon May 19, 2014 3:38 pm    Post subject: Reply with quote

Agrega lo siguiente a /etc/portage/package.unmask y vuelve a intentarlo.

Code:
=sys-libs/glibc


Eso desenmascara el glibc.

Para el bloqueo de udev, deberas modificar tu nucleo *general setup --> open by fhandle syscalls*. Busca mas detalles en los NEWS. Este es un cambio reciente muy importante.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 960

PostPosted: Mon May 19, 2014 4:34 pm    Post subject: Reply with quote

natrix wrote:
Agrega lo siguiente a /etc/portage/package.unmask y vuelve a intentarlo.

Code:
=sys-libs/glibc


Eso desenmascara el glibc.
...
@pedraku:
No hace falta hacer nada de esto porque glibc no te sale como enmascarado. Simplemente haz
Code:
emerge -v --oneshot glibc
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Mon May 19, 2014 7:27 pm    Post subject: Reply with quote

pedraku wrote:
hola agdg esto es lo que sale de emerge -avq glibc

http://bpaste.net/show/LEirHSqLw5UxaQucklhC/


no me sale todo completo


Prueba con:
Code:
USE=-vanilla emerge -avq glibc

_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum