Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Gentoo on Virtualbox: Increase Screen Resolution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Sum1
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2006
Posts: 104

PostPosted: Sun May 11, 2014 3:12 pm    Post subject: [SOLVED]Gentoo on Virtualbox: Increase Screen Resolution Reply with quote

Completed a Gentoo ~x86 install as a guest OS on Virtualbox.
Installed xorg-server and dwm window manager.
I appear to be stuck in 640x480 screen resolution and want to increase it to 1024x768 or 1280x768 or 1366x768.
There's no "conf.d" directory under /etc/X11.
Looks like Xorg is using the /usr/share/X11/xorg.conf.d directory call up the config on startx.
Not certain if I need to add a 40-monitor.conf config file in the /usr/share/X11/xorg.conf.d directory, or whether I'm supposed to add screen resolution settngs to the file called "glamor.conf".

I believe I've pasted the relevant sections from the Xorg.0.log:


Code:
[    50.618]
X.Org X Server 1.15.1
Release Date: 2014-04-13
[    50.619] X Protocol Version 11, Revision 0
[    50.619] Build Operating System: Linux 3.14.3-gentoo i686 Gentoo
[    50.619] Current Operating System: Linux leanto 3.14.3-gentoo #1 SMP Sat May 10 13:29$
[    50.619] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86-3.14.3-gentoo root=UUI$
[    50.620] Build Date: 11 May 2014  03:06:17AM
[    50.620]
[    50.620] Current version of pixman: 0.32.4
[    50.620]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    50.621] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    50.627] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 11 10:27:04 2014
[    50.669] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    50.709] (==) No Layout section.  Using the first Screen section.
[    50.709] (==) No screen section available. Using defaults.
[    50.709] (**) |-->Screen "Default Screen Section" (0)
[    50.709] (**) |   |-->Monitor "<default monitor>"
[    50.710] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    50.710] (==) Automatically adding devices
[    50.710] (==) Automatically enabling devices
[    50.710] (==) Automatically adding GPU devices
[    50.750] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[    50.799] Initializing built-in extension DRI3
[    50.800] Initializing built-in extension X-Resource
[    50.801] Initializing built-in extension XVideo
[    50.802] Initializing built-in extension XVideo-MotionCompensation
[    50.803] Initializing built-in extension XFree86-VidModeExtension
[    50.804] Initializing built-in extension XFree86-DGA
[    50.805] Initializing built-in extension XFree86-DRI
[    50.806] Initializing built-in extension DRI2
[    50.806] (II) "glx" will be loaded by default.
[    50.806] (II) LoadModule: "dri2"
[    50.806] (II) Module "dri2" already built-in
[    50.806] (II) LoadModule: "glamoregl"
[    50.807] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    51.140] (II) Module glamoregl: vendor="X.Org Foundation"
[    51.140]    compiled for 1.15.1, module version = 0.6.0
[    51.140]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.140] (II) LoadModule: "glx"
[    51.144] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    51.165] (II) Module glx: vendor="X.Org Foundation"
[    51.165]    compiled for 1.15.1, module version = 1.0.0
[    51.165]    ABI class: X.Org Server Extension, version 8.0
[    51.165] (==) AIGLX enabled
[    51.169] Loading extension GLX
[    51.169] (==) Matched vboxvideo as autoconfigured driver 0
[    51.169] (==) Matched modesetting as autoconfigured driver 1
[    51.169] (==) Matched fbdev as autoconfigured driver 2
[    51.169] (==) Matched vesa as autoconfigured driver 3
[    51.169] (II) LoadModule: "vboxvideo"
[    51.217] (WW) Warning, couldn't open module vboxvideo
[    51.217] (II) UnloadModule: "vboxvideo"
[    51.217] (II) Unloading vboxvideo
[    51.217] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[    51.217] (II) LoadModule: "modesetting"
[    51.217] (WW) Warning, couldn't open module modesetting
[    51.217] (II) UnloadModule: "modesetting"
[    51.217] (II) Unloading modesetting
[    51.217] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    51.217] (II) LoadModule: "fbdev"
[    51.218] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    51.241] (II) Module fbdev: vendor="X.Org Foundation"
[    51.242]    Module class: X.Org Video Driver
[    51.242]    ABI class: X.Org Video Driver, version 15.0
[    51.242] (II) LoadModule: "vesa"
[    51.242] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    51.261] (II) Module vesa: vendor="X.Org Foundation"
[    51.261]    compiled for 1.15.1, module version = 2.3.3
[    51.261]    Module class: X.Org Video Driver
[    51.261]    ABI class: X.Org Video Driver, version 15.0
[    51.261] (II) FBDEV: driver for framebuffer: fbdev
[    51.261] (II) VESA: driver for VESA chipsets: vesa
[    51.261] (--) using VT number 7
[    51.265] (II) Loading sub module "fbdevhw"
[    51.266] (II) LoadModule: "fbdevhw"
[    51.266] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    51.274] (II) Module fbdevhw: vendor="X.Org Foundation"
[    51.274]    compiled for 1.15.1, module version = 0.0.2
[    51.274]    ABI class: X.Org Video Driver, version 15.0
[    51.274] (**) FBDEV(0): claimed PCI slot 0@0:2:0
[    51.274] (II) FBDEV(0): using default device
[    51.274] (WW) Falling back to old probe method for vesa
[    51.274] (II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    51.274] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[    51.274] (==) FBDEV(0): RGB weight 888
[    51.274] (==) FBDEV(0): Default visual is TrueColor
[    51.274] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[    51.274] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[    51.274] (==) FBDEV(0): RGB weight 888
[    51.274] (==) FBDEV(0): Default visual is TrueColor
[    51.274] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[    51.274] (II) FBDEV(0): hardware: VESA VGA (video memory: 1216kB)
[    51.274] (II) FBDEV(0): checking modes against framebuffer device...
[    51.274] (II) FBDEV(0): checking modes against monitor...
[    51.274] (--) FBDEV(0): Virtual size is 640x480 (pitch 640)
[    51.274] (**) FBDEV(0):  Built-in mode "current": 30.7 MHz, 36.9 kHz, 73.3 Hz
[    51.274] (II) FBDEV(0): Modeline "current"x0.0   30.72  640 672 752 832  480 484 488 $
[    51.274] (==) FBDEV(0): DPI set to (96, 96)
[    51.274] (II) Loading sub module "fb"
[    51.274] (II) LoadModule: "fb"
[    51.275] (II) Loading /usr/lib/xorg/modules/libfb.so
[    51.284] (II) Module fb: vendor="X.Org Foundation"
[    51.284]    compiled for 1.15.1, module version = 1.0.0
[    51.284]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.284] (**) FBDEV(0): using shadow framebuffer


Thank you for reading and I appreciate any guidance.
Best regards.


Last edited by Sum1 on Mon May 12, 2014 2:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sun May 11, 2014 8:38 pm    Post subject: Reply with quote

Quote:
Code:

[    51.169] (II) LoadModule: "vboxvideo"
[    51.217] (WW) Warning, couldn't open module vboxvideo


Code:
emerge x11-drivers/xf86-video-virtualbox
Back to top
View user's profile Send private message
joeklow
n00b
n00b


Joined: 23 Jan 2011
Posts: 46

PostPosted: Mon May 12, 2014 9:42 am    Post subject: Reply with quote

Code:
man VBoxManage


Code:
VBoxManage.exe setextradata "vmname" CustomVideoMode1 1920x1200x32

_________________
Commit code back to ALSA, save your latency and CPU: rm /usr/bin/pulseaudio;touch /usr/bin/pulseaudio;chattr +i /usr/bin/pulseaudio
Back to top
View user's profile Send private message
Sum1
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2006
Posts: 104

PostPosted: Mon May 12, 2014 2:38 pm    Post subject: Reply with quote

Thank you, Ant P!!

Absolutely fabulous --

1. emerge x11-drivers/xf86-video-virtualbox
2. Added ***- modules="vboxvideo" -*** to /etc/conf.d/modules
3. Executed ***- Xorg -configure -***
4. Checked /root/xorg.conf.new to confirm under Section "Device" there was a line ***- Driver "vboxvideo" -***
5. Edited /root/xorg.conf.new ---
In Section "Monitor" added a line:
Option "PreferredMode" "1280x768"

6. cp /root/xorg.conf.new /home/username/xorg.conf

Restart X and all is Perfecto.

Thank you for your guidance.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum