Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xdg-xxxxxx directories fill up /tmp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sun May 11, 2014 7:18 am    Post subject: xdg-xxxxxx directories fill up /tmp Reply with quote

After a recent upgrade of my system - I usually upgrade once in about 2 months - I noticed that my /tmp gets filled up with tons of xdg-xxxxxx directories, and it never gets cleaned up. For example here is an output from my current /tmp:
Code:
~» l -d /tmp/xdg-*
0 /tmp/xdg-06trrm/  0 /tmp/xdg-7mKsjS/  0 /tmp/xdg-CAk57z/  0 /tmp/xdg-HrwPln/  0 /tmp/xdg-NkyAZ3/  0 /tmp/xdg-tW1jpR/
0 /tmp/xdg-0fTPNA/  0 /tmp/xdg-82eNQk/  0 /tmp/xdg-cKq7L7/  0 /tmp/xdg-iLtiBL/  0 /tmp/xdg-o1xOFT/  0 /tmp/xdg-ukXPk6/
0 /tmp/xdg-0KXAMI/  0 /tmp/xdg-8OoZyi/  0 /tmp/xdg-D18yvP/  0 /tmp/xdg-JKq635/  0 /tmp/xdg-pJkI0W/  0 /tmp/xdg-vFQcjP/
0 /tmp/xdg-0vFXgR/  0 /tmp/xdg-9XgkVQ/  0 /tmp/xdg-FeAWzh/  0 /tmp/xdg-jQC7Ft/  0 /tmp/xdg-PRSkpq/  0 /tmp/xdg-wqr4EK/
0 /tmp/xdg-1b6DJA/  0 /tmp/xdg-alPbUp/  0 /tmp/xdg-gGtbOd/  0 /tmp/xdg-JUKIJV/  0 /tmp/xdg-qCo7bA/  0 /tmp/xdg-XbuctD/
0 /tmp/xdg-26EXbc/  0 /tmp/xdg-apy0kR/  0 /tmp/xdg-gIYCAk/  0 /tmp/xdg-JvMcm0/  0 /tmp/xdg-qNuh2W/  0 /tmp/xdg-XdaGeu/
0 /tmp/xdg-3Mg6Cc/  0 /tmp/xdg-BgZpwX/  0 /tmp/xdg-gUUHsP/  0 /tmp/xdg-khGQgU/  0 /tmp/xdg-rBP961/  0 /tmp/xdg-xHiX2f/
0 /tmp/xdg-4WWte6/  0 /tmp/xdg-bIm5sm/  0 /tmp/xdg-hbyXqd/  0 /tmp/xdg-KTuiiE/  0 /tmp/xdg-ShPSiW/  0 /tmp/xdg-zOuZnM/
0 /tmp/xdg-54YSGq/  0 /tmp/xdg-bNPwtz/  0 /tmp/xdg-hc8bZb/  0 /tmp/xdg-MesSRL/  0 /tmp/xdg-SK41cc/
0 /tmp/xdg-5HokMR/  0 /tmp/xdg-c53rQN/  0 /tmp/xdg-hFFb0J/  0 /tmp/xdg-N6qsFu/  0 /tmp/xdg-Sy0yAp/

Does anyone know what program creates these tons of empty directories? I must add that pulseaudio seems to use one of these directories in another installation that I have - I have noticed that pulseaudio complains in syslog if I delete the whole bunch.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Thu May 15, 2014 4:27 am    Post subject: Reply with quote

This is ridiculous. Someone bungled up real bad. For a system that has been up for 10 days, there are 150 xdg directories in /tmp.
Code:
/tmp» l -1d xdg-* | wc -l
151
/tmp» uptime
 12:25:45 up 10 days, 16:18, 14 users,  load average: 0.45, 0.38, 0.46
(I don't know where it gets "14 users" from). There are only two users (actual users) on this machine. And one of these two is only for test purposes which I rarely, if ever, log into.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Jun 21, 2014 3:20 pm    Post subject: Reply with quote

Turns out it is e19. :?

Filed a bug report: https://phab.enlightenment.org/T1366
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum