Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE doesn't recognize my DVD drive
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Wed May 07, 2014 4:23 pm    Post subject: XFCE doesn't recognize my DVD drive Reply with quote

Everything (pendrives and harddrive partitions) shows up on Thunar and I can automount then by clicking and entering my password (btw is there a way to do it without asking for a password?). However, I can't access my DVD drive :(

pedro@gentoo ~ $ groups
wheel audio cdrom video cdrw usb users portage pedro
Back to top
View user's profile Send private message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Fri Jun 06, 2014 4:57 pm    Post subject: Reply with quote

Are you able to access the DVD drive using any other utilities? Does the 'eject' command work for you?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Jun 06, 2014 5:32 pm    Post subject: Re: XFCE doesn't recognize my DVD drive Reply with quote

moisespedro wrote:
Everything (pendrives and harddrive partitions) shows up on Thunar and I can automount then by clicking and entering my password (btw is there a way to do it without asking for a password?). However, I can't access my DVD drive :(

pedro@gentoo ~ $ groups
wheel audio cdrom video cdrw usb users portage pedro

Groups shouldn't really matter.

Important initial question: are you under systemd ?
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Fri Jun 06, 2014 7:03 pm    Post subject: Reply with quote

A quick test, you may want to do, is in command line, see if you are able to access the dvd drive (after mounted) as root or through sudo. If you are, then it's more of just access permissions. In my fstab, I have this line in my fstab, which allows me to access my dvd drive as a user. The key part of it, is having that "user" option, which tells fstab that the user is also allowed to mount that item.

Code:

/dev/cdrom              /mnt/cdrom      auto            noauto,user     0 0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum