Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Troubles configuring xorg.conf (3 monitors, 2 Nvidia cards)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ZippyF
n00b
n00b


Joined: 03 May 2014
Posts: 1

PostPosted: Sat May 03, 2014 1:45 pm    Post subject: Troubles configuring xorg.conf (3 monitors, 2 Nvidia cards) Reply with quote

I am struggling with my two nvidia gpu, three monitor setup. Any help or advice would be appreciated.
Screenshot:
[img=http://s25.postimg.org/a9h6xh8xn/screen140502_161042.jpg]

The red arrows show the pointer progression through the monitors (moving mouse left to right). When the cursor is on the top monitor, it becomes an X, and the screen is black.
Here is the matching xorg.conf
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.67  (buildmeister@swio-display-x86-rhel47-08)  Fri Apr  4 12:26:05 PDT 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer G236HL"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Acer X223W"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 610"
    BusID          "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "VGA-0: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Based on this post, I took a crack at matching the xorg.conf pattern above (monitor/device/screen sections) with a new one. I took it ask a victory that it actually didn't error out (many xorg.conf experiments have in the last couple of days). Here is my new xorg.conf with 3 screens:

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.67  (buildmeister@swio-display-x86-rhel47-08)  Fri Apr  4 12:26:16 PDT 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "Module"
   Load "dbe"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "leftAcer"
    VendorName     "Unknown"
    ModelName      "Acer G236HL"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "rightAcer"
    VendorName     "Unknown"
    ModelName      "Acer G236HL"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "topAcer"
    VendorName     "Unknown"
    ModelName      "Acer X223W"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "geforce-9600-gt-0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "geforce-9600-gt-1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Device"
    Identifier     "geforce-gt-610"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 610"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "geforce-9600-gt-0"
    Monitor        "leftAcer"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "MetaModes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "geforce-9600-gt-1"
    Monitor        "rightAcer"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-1"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "MetaModes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "geforce-gt-610"
    Monitor        "topAcer"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "MetaModes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection


This what appears with the new xorg.conf:
[img]http://s25.postimage.org/9lcxs9zln/screen140502_160314.png[/img]

"leftAcer" and "rightAcer" appear, but nothing appears on "topAcer". It appears not to be getting a signal from the gpu. I can move the pointer between "leftAcer" and "rightAcer".

Any help or advice would be greatly appreciated. Here are a few details about the hardware setup:
GeForce 9600 GT is in the PCI:1 slot. It's DVI out is going to "acerLeft", it's VGA out is going to "acerRight".
GeForce GT 610 is in PCI:2 slot. It's VGA out is going to "acerTop".

thanks!
Back to top
View user's profile Send private message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Sun May 11, 2014 12:00 am    Post subject: Reply with quote

Here is my advice, and you will have to pardon me in advance if this advice appears more than a bit ghetto.

Please consider booting yr box with Linux Mint software live environment, and then grab a copy of the xorg.conf file. Mint's hardware detection is fantastic. It could be that the output of their autodetection script may aide you in this.

Are you attempting to use the open or the blob driver?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6965

PostPosted: Sun May 11, 2014 12:50 pm    Post subject: Reply with quote

A simpler advise would just be use nvidia-settings, go to X Server Display Configuration part.
Made the output like you wish and hit the Save to X Configuration file. However because nvidia-settings put some really weird stuff in it, don't save it, just hit the "Show Preview" button and extract information you need to get the same result.

windex:
Driver "nvidia" is a good hint on what drivers he is using
Back to top
View user's profile Send private message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Sun May 11, 2014 6:07 pm    Post subject: Reply with quote

krinn wrote:
A simpler advise would just be use nvidia-settings, go to X Server Display Configuration part.

windex:
Driver "nvidia" is a good hint on what drivers he is using


Thx bro.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum