Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] keyboard and mouse not working under KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kindofblue
n00b
n00b


Joined: 13 Apr 2009
Posts: 34
Location: Montreal, Canada

PostPosted: Tue Apr 29, 2014 11:30 pm    Post subject: [Solved] keyboard and mouse not working under KDE Reply with quote

I'm running Gentoo with a recent version of the X.org server, 1.14.3. The keyboard stops working when I start a KDE session, and the mouse doesn't work either. I found a similar post on the Gentoo forums (https://forums.gentoo.org/viewtopic-t-832207-start-0.html), but it's four years old and refers to running the hal daemon to fix the problem. From what I understand hal is not needed any more since version 1.8 of X.org. I've also seen posts on other Linux forums that are more recent and they also suggest to run hal to fix the problem.

Would someone have a suggestion?
_________________
"Keep it simple: as simple as possible, but no simpler" - Einstein


Last edited by kindofblue on Fri May 02, 2014 8:59 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Apr 30, 2014 4:54 am    Post subject: Reply with quote

You have mouse and keyboard in the terminal?
You have a desktop or graphical login screen when you start kde?
ps2 or usb mouse and keyboard?
touchpad or optical mouse?
udev replaced hal
Code:
rc-update show
do you have udev and udev-mount in the sysinit run level? if not add them and reboot.
do you have INPUT_DEVICES="evdev" in /etc/portage/make.conf?
Code:
emerge wgetpaste
wgetpaste /var/log/Xorg.0.log
post the url returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
kindofblue
n00b
n00b


Joined: 13 Apr 2009
Posts: 34
Location: Montreal, Canada

PostPosted: Wed Apr 30, 2014 9:32 am    Post subject: Reply with quote

The keyboard and mouse are both USB; the mouse is optical. Yes I have a KDE login screen. /etc/make.conf has the entry INPUT_DEVICES="evdev". Here's the link for /var/log/Xorg.0.log: http://bpaste.net/show/248836/, and here's the output of rc-update show:
Code:
             bootmisc | boot                         
           consolekit |      default                 
                 dbus |      default                 
                devfs |                       sysinit
        device-mapper | boot                         
               dhcpcd |      default                 
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
    kmod-static-nodes |                       sysinit
                local |      default                 
           localmount | boot                         
                  lvm | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
             netif.lo |                       sysinit
             netmount |      default                 
            powernowd |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 sshd |      default                 
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
            syslog-ng |      default                 
         termencoding | boot                         
         tmpfiles.dev |                       sysinit
       tmpfiles.setup | boot                         
           udev-mount |                       sysinit
       udev-postmount | boot                         
            udev-save |              shutdown       
                udevd |                       sysinit
              urandom | boot                         


Thanks for the reply!
_________________
"Keep it simple: as simple as possible, but no simpler" - Einstein
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Apr 30, 2014 4:19 pm    Post subject: Reply with quote

The killer appears to be
Quote:
[ 1940.530] leaking dma buffer
which appears after
Quote:
[ 57.737] (**) Option "xkb_layout" "us"
and a substantial time delay. Having
Quote:
(**) Option "xkb_variant" ",qwerty"
appear immediately after
Quote:
(**) Option "xkb_layout" "us"
appears to be the normal progression.
The current stable xorg-server version is 1.15.0. Suggest
Code:
emerge -uND xorg-server

What is the output of
Code:
ls /etc/init.d/*udev*
?
The udev components in rc-update show output are those I remember from a couple of years ago except I don't remember udev.save at all.
Code:
emerge -s udev systemd | wgetpaste
post url.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
kindofblue
n00b
n00b


Joined: 13 Apr 2009
Posts: 34
Location: Montreal, Canada

PostPosted: Fri May 02, 2014 8:58 am    Post subject: Reply with quote

Great! I emerged xorg-server and it now works.

Thank you so much.
_________________
"Keep it simple: as simple as possible, but no simpler" - Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum