Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iscsi target wont compile-Linux 3.6 is the latest supported
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
UncleVan
n00b
n00b


Joined: 08 Feb 2011
Posts: 72

PostPosted: Mon Apr 21, 2014 7:26 pm    Post subject: iscsi target wont compile-Linux 3.6 is the latest supported Reply with quote

when trying to emerge sys-block/iscsitarget-1.4.20.2_p20130103 (latest one) I get an error message:
Code:
"Linux 3.6 is the latest supported version."

My kernel is
Code:
[IP-] [  ] sys-kernel/gentoo-sources-3.12.13:3.12.13

Does someone know how iscsi targets are supposed to be defined, configured and started with newer kernels ?
Thanks in advance !
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Tue Apr 22, 2014 12:11 am    Post subject: Reply with quote

sys-block/lio-utils ?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
UncleVan
n00b
n00b


Joined: 08 Feb 2011
Posts: 72

PostPosted: Tue Apr 22, 2014 11:27 am    Post subject: Reply with quote

Thank you for the quick response !

LIO Upstream says:
Quote:
Use targetcli instead.
lio-utils are deprecated and have been superseded by targetcli, please see the RTS OS Admin Manual.
http://linux-iscsi.org/wiki/Lio-utils

In the official portage tree both packages are disabled - still in development:
Code:
$ equery l -p sys-block/lio-utils sys-block/targetcli
 * Searching for lio-utils in sys-block ...
[-P-] [ -] sys-block/lio-utils-9999:0

 * Searching for targetcli in sys-block ...
[-P-] [ -] sys-block/targetcli-9999:0
and the overlays didnt show either.

Of course I can build from GIT, but does this mean that Gentoo doesnt officially support iSCSI targets with recent kernels ?
Im asking this because I have to make a statement myself...

Thank you so far !
Back to top
View user's profile Send private message
madchaz
l33t
l33t


Joined: 01 Jul 2003
Posts: 993
Location: Quebec, Canada

PostPosted: Thu Nov 06, 2014 10:14 pm    Post subject: Reply with quote

Resuscitating this tread. Looks like it's still unable to compile on more resent kernels.

A bug is already open for this: https://bugs.gentoo.org/show_bug.cgi?id=507288
But it doesn't look like it ever got touched.

Had a look at the "unstable" version and it supports up to 3.11
as no gentoo-sources available in portage for 3.11, the best I can get is gentoo-sources-3.10.41-r1

Anyone know if the maintainer plans to look into it?
_________________
Someone asked me once if I suffered from mental illness. I told him I enjoyed every second of it.
www.madchaz.com A small candle of a website. As my lab specs on it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum