Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth File Transfers Quit Working.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 970
Location: Stuart, Florida

PostPosted: Tue Apr 15, 2014 9:00 pm    Post subject: Bluetooth File Transfers Quit Working. Reply with quote

I use my Bluetooth to transfer files from my cell phone. It worked fine until the latest update of bluez and udev and I'd like to get it working again.

I'm running net-wireless/bluez-5.15, sys-fs/udev-208, and net-wireless/bluedevil-2.0_rc1 for KDE.

The pairing done from KDE seems to be accomplished correctly. When I try to transfer the file(s) it silently fails on the Gentoo side. I do not even get a confirmation message that a transfer is being attempted. The phone gives a message of "File Not Sent".

dmesg doesn't give any error messages.

I'd appreciate your advice on how to troubleshoot the problem.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1635
Location: United Kingdom

PostPosted: Wed Apr 16, 2014 8:44 am    Post subject: Reply with quote

You're not the only one experiencing this. I'm using KDE and have exactly the same problem. Since KDE changed from using Bluez-4 to Bluez-5, Bluetooth stopped working on my main laptop. Bluez-5 does things very differently to Bluez-4, and I think Bluez-5 or BlueDevil for Bluez-5 are not fully functional yet.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 970
Location: Stuart, Florida

PostPosted: Wed Apr 16, 2014 11:15 am    Post subject: Reply with quote

If I interpret package.keywords right, that's the default system and it doesn't work. I'll have to figure out how to revert to one that does.
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 94

PostPosted: Thu Apr 17, 2014 11:18 am    Post subject: Reply with quote

I got the same problem. I did not find anything useful to get rid of it.

I think it is a permission problem. Here are my logs:

Code:
bluetoothd[6806]: Sap driver initialization failed.
bluetoothd[6806]: sap-server: Operation not permitted


Code:
/usr/libexec/bluetooth/obexd -n
obexd[6881]: OBEX daemon 5.15
obexd[6881]: CONNECT(0x0), (null)(0xffffffff)
obexd[6881]: CONNECT(0x0), (null)(0x0)
obexd[6881]: PUT(0x2), (null)(0xffffffff)
obexd[6881]: PUT(0x2), FORBIDDEN(0x43)
obexd[6881]: DISCONNECT(0x1), (null)(0xffffffff)
obexd[6881]: DISCONNECT(0x1), SUCCESS(0x20)
obexd[6881]: disconnected: Transport got disconnected
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Thu Apr 17, 2014 12:53 pm    Post subject: Reply with quote

Bluez-5 is dépendant of Dbus. By default, Dbus is only allowing non root users who are in the lp and plugdevs group to use Bluetooth. So, if not, put your user in one of those groups and restart your session.

It is more simple to make files transferts in commands lines using for example obexftp and ussp-push. It generally work. I install everything related to obex and gvfs. bluetoothctl work well to connect.
_________________
Paul
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 94

PostPosted: Thu Apr 17, 2014 3:35 pm    Post subject: Reply with quote

My user is in both groups, plugdev and lp.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1635
Location: United Kingdom

PostPosted: Fri Apr 18, 2014 6:59 am    Post subject: Reply with quote

My user is also in both those groups. The bottom line is that Bluez-5 and BlueDevil for Bluez-5 are not working properly yet. Bluez-4 and BlueDevil for Bluez-4 worked fine in KDE. It was very convenient and fast to use the KDE GUI to transfer files from Android phones to my laptop via Bluetooth until Bluez-5 broke things.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 94

PostPosted: Sun Apr 20, 2014 12:19 pm    Post subject: Reply with quote

I downgraded to bluez-4.101-r8 and bluedevil-1.3.2, paired my phone again and now I can transfer files again.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 285

PostPosted: Wed May 28, 2014 8:34 pm    Post subject: Reply with quote

Ill put this bug-links as they fit here I believe:
https://bugs.gentoo.org/show_bug.cgi?id=506920
https://bugs.kde.org/show_bug.cgi?id=332087
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum