Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot mount nfs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Fri Apr 11, 2014 2:46 pm    Post subject: Cannot mount nfs Reply with quote

Hi. I try to mount my FreeNAS using nfs but I have some problems. I have enabled NFS on kernel.
I installed nfs-utils.
I add: rpcbind, nfs and nfsmount on boot process.
This is my /etc/fstab
Code:

192.168.1.4:/mnt/inbox-raidz/datavault           /mnt/Mirror     nfs     rw      0 0
192.168.1.4:/mnt/raidon-stripe/dataspeed        /mnt/Stripe      nfs     rw      0 0
192.168.1.4:/mnt/inbox-500                     /mnt/500          nfs     rw      0 0


This is my /etc/hosts
Code:
192.168.1.4 FreeNAS


During restart

Code:
ember@gentoo /etc $ sudo /etc/init.d/nfs restart
Password:
 * Stopping NFS mountd ...                                                                                                  [ ok ]
 * Stopping NFS daemon ...                                                                                                  [ ok ]
 * Unexporting NFS directories ...                                                                                          [ ok ]
 * Starting NFS mountd ...                                                                                                  [ ok ]
 * Starting NFS daemon ...                                                                                                  [ ok ]
 * Starting NFS smnotify ...                                                                                                [ ok ]
ember@gentoo /etc $ sudo /etc/init.d/nfsmount restart
 * Starting NFS sm-notify ...                                                                                               [ ok ]
 * Mounting NFS filesystems ...                                                                                             [ ok ]
ember@gentoo /etc $ sudo /etc/init.d/rpcbind restart
 * Unmounting NFS filesystems ...                                                                                           [ ok ]
 * Stopping NFS mountd ...                                                                                                  [ ok ]
 * Stopping NFS daemon ...                                                                                                  [ ok ]
 * Unexporting NFS directories ...                                                                                          [ ok ]
 * Stopping NFS statd ...                                                                                                   [ ok ]
 * Stopping idmapd ...                                                                                                      [ ok ]
 * Stopping rpcbind ...                                                                                                     [ ok ]
 * Starting rpcbind ...                                                                                                     [ ok ]
 * Starting idmapd ...
 * Starting NFS statd ...                                                                                                   [ ok ]
 * Starting NFS sm-notify ...                                                                                               [ ok ]
 * Mounting NFS filesystems ...                                                                                             [ ok ]
 * Starting NFS mountd ...                                                                                                  [ ok ]
 * Starting NFS daemon ...                                                                                                  [ ok ]
 * Starting NFS smnotify ...                                                                                                [ ok ]

ember@gentoo /etc $


During boot is not mounting the drives but when I login and restart the services or mount them manually, they mount just fine.
What I miss? What I do wrong?
_________________
Compile The Universe
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 425

PostPosted: Fri Apr 11, 2014 4:08 pm    Post subject: Reply with quote

I noticed this same behaviour.
A dirty workaround is to add "mount -a" to local.d
Back to top
View user's profile Send private message
sk8harddiefast
Guru
Guru


Joined: 15 Feb 2009
Posts: 335
Location: athens

PostPosted: Fri Apr 11, 2014 4:11 pm    Post subject: Reply with quote

How to add this on /etc/local.d
What I must write?
_________________
Compile The Universe
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14180

PostPosted: Sat Apr 12, 2014 12:36 am    Post subject: Reply with quote

What error message is printed during boot? You failed to mark the mounts as netdev, so they might try to mount too early.
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 425

PostPosted: Sun May 04, 2014 7:56 am    Post subject: Reply with quote

Don't add it to local.d
Apparently I had no idea what I was doing.

Like Hu hinted. Add _netdev to mount options and the netmount init script will take care of bringing them up and down.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7167

PostPosted: Sun May 04, 2014 11:25 pm    Post subject: Re: Cannot mount nfs Reply with quote

sk8harddiefast wrote:

I add: rpcbind, nfs and nfsmount on boot process.

if you mean boot runlevel, you're wrong, nfsmount goes into default runlevel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum