Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GDM have to enter username twice?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 12 Mar 2005
Posts: 2289
Location: Germany

PostPosted: Mon Mar 31, 2014 8:08 pm    Post subject: GDM have to enter username twice? Reply with quote

[I] gnome-base/gdm
     Available versions:  2.20.11-r1 3.8.4-r3 (~) {accessibility afs audit branding +consolekit debug dmx fallback fprint gnome-keyring +gnome-shell +introspection ipv6 pam plymouth remote selinux smartcard +systemd tcpd test xinerama ELIBC="glibc"}
     Installed versions: 23.03.2014)(branding introspection ipv6 systemd tcpd xinerama -accessibility -audit -debug -fprint -plymouth -selinux -smartcard -test)
     Description:         GNOME Display Manager for managing graphical display servers and user logins

Dear Sir, Madam or Searchenginealgorithm.

Since a couple of weeks i have a Bug during my login with GDM, the Version i use is listed above. Normal you have List of Users to choose with a Klick and the User enter just his/her Password and choose his favourite session by a click on a small gear wheel.

I am not sure where, but i disable the User list. Since i have too many Users and will not that the user have to scroll through the list. Think i used the archlinux Wiki and Forum for that operation. As far as i remember i had to switch to the gdm user as root like # su gdm, and read out the d-bus Season-String(?) to call and set my favourite settings with the gconfig.

Here is Just a example:

# su - gdm -s /bin/bash
# $ dbus-launch

This command will list the actual DBUS_ADRESS and a BUS_PID which we will need in the next step:
# $ export  BUS_ADDRESS=unix:abstract=/tmp/dbus-Jb433gMQHS,guid=fc14d4bf3d000e38276a5a2200000d38
# $ export DBUS_SESSION_BUS_PID=4283
# $ /usr/lib/dconf/dconf-service &

Then i set some Parameter, like the Background of the GDM-Manager...

$ GSETTINGS_BACKEND=dconf gsettings get org.gnome.desktop.background picture-uri
$ GSETTINGS_BACKEND=dconf gsettings set org.gnome.desktop.background picture-uri "file:///usr/share/backgrounds/gnome/SundownDunes.jpg"

I am not sure if i change Settings for the users which can login and some other Settings. I know that i tried different Settings to configure that right.. in /etc/gdm/custom.conf or on the Library Files. But since no update change the Settings i had set, i am very sure that i configure it through the gsettings.

But now i have Bug that appear randomly. The first Login after boot have a 80 percent probability to run normal. If i enter the wrong Password GDM is switching to the Mode where i have to enter the Username, click Next, enter Username again, click Next again.. and than i could enter the Password.

This behaviour is bad, since some Users type there password in the second User field and other could read it in plain text from the screen or maybe in the log files. But hey i did not find any Log files that complain about that issue. I also check out the pam configuration and did not find a clue. This behaviour came with an update. Not sure which one, but for a short time i know that i got this on just one machine.

If i find time ill read out all gconf Settings and check if the bug's source is a setting there.

Please if you know or could imagine what cause that, write it here down.

Thank you for your attention!

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum