Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] bluetooth HID mouse not recognized by the kernel?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tomciaaa
n00b
n00b


Joined: 27 Jan 2006
Posts: 15

PostPosted: Sat Mar 29, 2014 6:52 pm    Post subject: [SOLVED] bluetooth HID mouse not recognized by the kernel? Reply with quote

I wish I could say more about this, but after 6 hours of trying to make it work, I'm still on square one.

I have a cheapo usb dongle and a bluetooth mouse that I've verified works fine on my ancient (v10.5) hackintosh OS on the same laptop.
Code:
lsusb | fgrep -i blue
Bus 006 Device 006: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

I can get the bluetooth connection going, by using bluetoothctl power on/scan on/pair, etc. sequence. Connection and device info:
Code:
bluetoothctl
[NEW] Controller 00:15:83:0C:BF:EB BlueZ 5.15 [default]
[NEW] Device 00:60:D1:00:7B:9A Bluetooth Mouse
[bluetooth]# info 00:60:D1:00:7B:9A
Device 00:60:D1:00:7B:9A
   Name: Bluetooth Mouse
   Alias: Bluetooth Mouse
   Class: 0x002580
   Icon: input-mouse
   Paired: yes
   Trusted: yes
   Blocked: no
   Connected: yes
   LegacyPairing: yes
   UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
   UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
   Modalias: usb:v056Ep0061d001E
[bluetooth]# show 00:15:83:0C:BF:EB
Controller 00:15:83:0C:BF:EB
   Name: BlueZ 5.15
   Alias: BlueZ 5.15
   Class: 0x00010c
   Powered: yes
   Discoverable: no
   Pairable: yes
   UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
   UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
   UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
   UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
   UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
   Modalias: usb:v1D6Bp0246d050F
   Discovering: no

And I can see the new device appear on udev
Code:
udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[3050.213268] change   /devices/platform/regulatory.0 (platform)
UDEV  [3050.717106] change   /devices/platform/regulatory.0 (platform)
KERNEL[3059.596631] add      /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/bluetooth/hci0/hci0:2 (bluetooth)
UDEV  [3059.598626] add      /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/bluetooth/hci0/hci0:2 (bluetooth)
KERNEL[3061.071890] add      /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/bluetooth/hci0/hci0:2/0005:056E:0061.0003 (hid)
UDEV  [3061.072648] add      /devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/bluetooth/hci0/hci0:2/0005:056E:0061.0003 (hid)
KERNEL[3063.220683] change   /devices/platform/regulatory.0 (platform)
UDEV  [3063.225657] change   /devices/platform/regulatory.0 (platform)

But there is no event/input device being created. So I assume this is the kernel mucking up, but I've enabled every single HID/bluetooth option I could find and that wasn't clearly for specific drivers.

Installed udev/gentoo-sources/bluez versions and use flags:
Code:
sys-fs/udev-208  USE="acl firmware-loader gudev introspection kmod openrc -doc (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)"
net-wireless/bluez-5.15:0/3  USE="cups obex readline -debug (-selinux) -systemd {-test}"
sys-kernel/gentoo-sources-3.12.13:3.12.13  USE="-build -deblob -experimental -symlink"


Edit: I also know the mouse works with linux, since about a year ago I had it working with another gentoo laptop (albeit using it's internal bluetooth).
Edit #2: CONFIG_HID_ELECOM=m was what I was missing. (facepalm)

Hope you guys can help, and thanks :)
Tomas
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum