Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] KDE hangs [upd: synaptic clickpad problem]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Barbieken
n00b
n00b


Joined: 22 Mar 2014
Posts: 62

PostPosted: Sat Mar 22, 2014 5:03 pm    Post subject: [solved] KDE hangs [upd: synaptic clickpad problem] Reply with quote

Got problems with recently installed KDE ( kde-base/kde-meta-4.12.3:4 ) on a new laptop. Every so often GUI, including mouse, hangs, sound still working though. I can restart session with Alt+SysRq+K. after this KDE boots normally and works for some time. Sometimes it takes several hours before system hands, sometimes just some minutes.
I use the latest nvidia-drivers with builtin Optimus support. No bumblebee.
What can I do to fix this problem?


UPD
Fixed, sort of
this config
Code:

Section "InputClass"
          Identifier "SynPS/2 Synaptics TouchPad"
          matchIsTouchpad "yes"
          Driver    "synaptics"                 
          Option    "AreaTopEdge"   "2235"
          Option    "AreaBottomEdge"  "0"
          Option    "AreaRightEdge"   "0"
          Option    "AreaLeftEdge"  "0"
          Option    "SoftButtonAreas"   "3874 0 0 2235  2673 3873 0 2235"
          Option    "RBCornerButton"    "1"
         
        Option "VertTwoFingerScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "HorizHysteresis" "50"
        Option "VertHysteresis" "50"
        Option "PalmDetect"    "1"
        Option "PalmMinWidth"  "5"
        Option "PalmMinZ"      "40"
 EndSection

makes X freeze
this
Code:

Section "InputClass"
          Identifier "SynPS/2 Synaptics TouchPad"
          matchIsTouchpad "yes"
          Driver    "synaptics"                 
#          Option    "AreaTopEdge"   "2235"
#          Option    "AreaBottomEdge"  "0"
#          Option    "AreaRightEdge"   "0"
#          Option    "AreaLeftEdge"  "0"
          Option    "SoftButtonAreas"   "3874 0 0 2235  2673 3873 0 2235"
          Option    "RBCornerButton"    "1"
         
        Option "VertTwoFingerScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "HorizHysteresis" "50"
        Option "VertHysteresis" "50"
        Option "PalmDetect"    "1"
        Option "PalmMinWidth"  "5"
        Option "PalmMinZ"      "40"
 EndSection

does not


Last edited by Barbieken on Wed Apr 09, 2014 5:53 pm; edited 2 times in total
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Sun Mar 23, 2014 1:09 am    Post subject: Post your Xorg.0.log when it hangs Reply with quote

If possible, shell in from the network to your laptop when it hangs. There may be useful info in your /var/log/Xorg.0.log file.

You may be getting bit by something in the event loop for the latest xorg server. I have problems with a bonaire class radeon card and the xf86-video-ati driver and the glamor use flag under ~amd64. When researching, I think I saw this problem also hitting certain nvidia configs
Back to top
View user's profile Send private message
Barbieken
n00b
n00b


Joined: 22 Mar 2014
Posts: 62

PostPosted: Sun Mar 23, 2014 9:11 am    Post subject: Reply with quote

Tail of logs

Xorg.0.log
Code:

[    46.825] (**) Option "SoftButtonAreas" "3874 0 0 2235  2673 3873 0 2235"
[    46.825] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    46.825] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    46.835] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event6"
[    46.835] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    46.835] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    46.835] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    46.835] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.046
[    46.835] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    46.835] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    46.835] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    46.835] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    46.835] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    46.835] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    46.835] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    46.835] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event8)
[    46.835] (**) TPPS/2 IBM TrackPoint: Applying InputClass "evdev pointer catchall"
[    46.835] (II) Using input driver 'evdev' for 'TPPS/2 IBM TrackPoint'
[    46.835] (**) TPPS/2 IBM TrackPoint: always reports core events
[    46.835] (**) evdev: TPPS/2 IBM TrackPoint: Device: "/dev/input/event8"
[    46.835] (--) evdev: TPPS/2 IBM TrackPoint: Vendor 0x2 Product 0xa
[    46.835] (--) evdev: TPPS/2 IBM TrackPoint: Found 3 mouse buttons
[    46.835] (--) evdev: TPPS/2 IBM TrackPoint: Found relative axes
[    46.835] (--) evdev: TPPS/2 IBM TrackPoint: Found x and y relative axes
[    46.835] (II) evdev: TPPS/2 IBM TrackPoint: Configuring as mouse
[    46.835] (**) evdev: TPPS/2 IBM TrackPoint: YAxisMapping: buttons 4 and 5
[    46.835] (**) evdev: TPPS/2 IBM TrackPoint: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    46.835] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/serio2/input/input8/event8"
[    46.835] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 13)
[    46.835] (II) evdev: TPPS/2 IBM TrackPoint: initialized for relative axes.
[    46.835] (**) TPPS/2 IBM TrackPoint: (accel) keeping acceleration scheme 1
[    46.835] (**) TPPS/2 IBM TrackPoint: (accel) acceleration profile 0
[    46.835] (**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
[    46.835] (**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
[    46.835] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
[    46.835] (II) No input driver specified, ignoring this device.                                                                                                             
[    46.835] (II) This device may have been added with another device file.                                                                                                     
[    46.836] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event9)                                                                                   
[    46.836] (**) ThinkPad Extra Buttons: Applying InputClass "evdev keyboard catchall"                                                                                         
[    46.836] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'                                                                                                       
[    46.836] (**) ThinkPad Extra Buttons: always reports core events                                                                                                           
[    46.836] (**) evdev: ThinkPad Extra Buttons: Device: "/dev/input/event9"
[    46.836] (--) evdev: ThinkPad Extra Buttons: Vendor 0x17aa Product 0x5054
[    46.836] (--) evdev: ThinkPad Extra Buttons: Found keys
[    46.836] (II) evdev: ThinkPad Extra Buttons: Configuring as keyboard
[    46.836] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input10/event9"
[    46.836] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 14)
[    46.836] (**) Option "xkb_rules" "evdev"
[    46.836] (**) Option "xkb_model" "pc104"
[    46.836] (**) Option "xkb_layout" "us"
[    47.125] (II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    47.125] (II) modesetting(G0): Using EDID range info for horizontal sync
[    47.125] (II) modesetting(G0): Using EDID range info for vertical refresh
[    47.125] (II) modesetting(G0): Printing DDC gathered Modelines:
[    47.125] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    47.125] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    47.143] reporting 3 6 26 203
[    47.161] have a master to look out for
[    47.161] adjust shatters 0 2880
[    47.165] need to create shared pixmap 1(II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    47.690] (II) modesetting(G0): Using hsync ranges from config file
[    47.690] (II) modesetting(G0): Using vrefresh ranges from config file
[    47.690] (II) modesetting(G0): Printing DDC gathered Modelines:
[    47.690] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    47.690] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    47.707] reporting 3 6 26 203
[    52.972] reporting 3 6 26 203
[    53.944] (II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    53.944] (II) modesetting(G0): Using hsync ranges from config file
[    53.944] (II) modesetting(G0): Using vrefresh ranges from config file
[    53.944] (II) modesetting(G0): Printing DDC gathered Modelines:
[    53.944] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    53.944] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    53.961] reporting 3 6 26 203
[    56.435] (II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    56.435] (II) modesetting(G0): Using hsync ranges from config file
[    56.435] (II) modesetting(G0): Using vrefresh ranges from config file
[    56.436] (II) modesetting(G0): Printing DDC gathered Modelines:
[    56.436] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    56.436] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    56.453] reporting 3 6 26 203
[    56.468] (II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    56.468] (II) modesetting(G0): Using hsync ranges from config file
[    56.468] (II) modesetting(G0): Using vrefresh ranges from config file
[    56.468] (II) modesetting(G0): Printing DDC gathered Modelines:
[    56.468] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    56.468] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    56.485] reporting 3 6 26 203
[    56.991] (II) modesetting(G0): EDID vendor "MEI", prod id 38562
[    56.991] (II) modesetting(G0): Using hsync ranges from config file
[    56.991] (II) modesetting(G0): Using vrefresh ranges from config file
[    56.991] (II) modesetting(G0): Printing DDC gathered Modelines:
[    56.991] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1640 +hsync +vsync (98.3 kHz eP)
[    56.991] (II) modesetting(G0): Modeline "2880x1620"x0.0  302.50  2880 2924 2928 3076  1620 1629 1630 1967 +hsync +vsync (98.3 kHz e)
[    57.009] reporting 3 6 26 203
[    57.203] reporting 3 6 26 203
[  1138.376] reporting 3 6 26 203
[  2814.467] reporting 3 6 26 203
[  3117.213] reporting 3 6 26 203
[  3117.235] reporting 3 6 26 203
[  3117.243] reporting 3 6 26 203
[  3117.250] reporting 3 6 26 203
[  3406.135] reporting 3 6 26 203




kdm.log:
Code:

Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
Loading extension NV-GLX
Loading extension NV-CONTROL
klauncher(2714) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(2708)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

kdmgreet(2708)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
reporting 3 6 26 203
have a master to look out for
adjust shatters 0 2880
need to create shared pixmap 1reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203
reporting 3 6 26 203



Seems like the same logs I see when X in normal state

Can I do anything else?
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Tue Mar 25, 2014 4:08 am    Post subject: Try backing off to previous xorg server Reply with quote

Some of the workarounds I was looking at suggest going back to an earlier xorg server
Back to top
View user's profile Send private message
Barbieken
n00b
n00b


Joined: 22 Mar 2014
Posts: 62

PostPosted: Tue Mar 25, 2014 8:34 am    Post subject: Reply with quote

Well, narrowed down the problem to the synaptic clickpad. Yesterday I used laptop the w/hole day and didn't have any freezes. But I used it with wireless mouse. When I start using clickpad (the new one, one big button with multitouch) after a while it hangs.
config is the following:
Code:


Section "InputClass"
          Identifier "SynPS/2 Synaptics TouchPad"
          matchIsTouchpad "yes"
          Driver    "synaptics"                 
          Option    "AreaTopEdge"   "2235"
          Option    "AreaBottomEdge"  "0"
          Option    "AreaRightEdge"   "0"
          Option    "AreaLeftEdge"  "0"
          Option    "SoftButtonAreas"   "3874 0 0 2235  2673 3873 0 2235"
          Option    "RBCornerButton"    "1"
         
        Option "VertTwoFingerScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "HorizHysteresis" "50"
        Option "VertHysteresis" "50"
        Option "PalmDetect"    "1"
        Option "PalmMinWidth"  "5"
        Option "PalmMinZ"      "40"
 EndSection



Is there anything wron with it? Is there any tool or settings to debug this problem?
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Mar 25, 2014 7:50 pm    Post subject: Reply with quote

Barbieken wrote:
When I start using clickpad (the new one, one big button with multitouch) after a while it hangs.


Can you inspect the output of `dmesg` as well as the end of the log file /var/log/Xorg.0.log to see if they mention something about this hang? (It's probably not a literal hang, as in freeze; but it rather kind of disables or disconnects itself, in a way that a freeze is perceived)
Back to top
View user's profile Send private message
Barbieken
n00b
n00b


Joined: 22 Mar 2014
Posts: 62

PostPosted: Wed Mar 26, 2014 7:49 am    Post subject: Reply with quote

TomWij wrote:
Barbieken wrote:
When I start using clickpad (the new one, one big button with multitouch) after a while it hangs.


Can you inspect the output of `dmesg` as well as the end of the log file /var/log/Xorg.0.log to see if they mention something about this hang? (It's probably not a literal hang, as in freeze; but it rather kind of disables or disconnects itself, in a way that a freeze is perceived)


I'll have a look ar dmesg next time, xorg.0.log posted above, seems like nothing suspictious. You're right, X freezes not hangs. Hotkeys work - can be verified by sound, mouse and clickpad work (no cursor though) and sound works. But the picture freezes.
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Wed Mar 26, 2014 11:56 am    Post subject: Reply with quote

Barbieken wrote:
But the picture freezes.


Ah, next time check /var/log/messages too besides `dmesg`; there might be a segfault, or one or another message clarifying it.
Back to top
View user's profile Send private message
Barbieken
n00b
n00b


Joined: 22 Mar 2014
Posts: 62

PostPosted: Wed Apr 02, 2014 8:57 am    Post subject: Reply with quote

Nothing suspictious in dmesg and /var/log/messages
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum