Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to emerge dev-libs/boost-1.55.0-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1548
Location: /mnt/Gentoo/Europe

PostPosted: Sat Mar 22, 2014 12:07 pm    Post subject: Failed to emerge dev-libs/boost-1.55.0-r1 Reply with quote

Code:
In file included from ../boost/filesystem/path_traits.hpp:23:0,
                 from ../boost/filesystem/path.hpp:25,
                 from ../boost/filesystem/operations.hpp:25,
                 from regression/src/compiler_status.cpp:29:
../boost/system/error_code.hpp: At global scope:
../boost/system/error_code.hpp:222:36: warning: ‘boost::system::posix_category’ defined but not used [-Wunused-variable]
     static const error_category &  posix_category = generic_category();
                                    ^
../boost/system/error_code.hpp:223:36: warning: ‘boost::system::errno_ecat’ defined but not used [-Wunused-variable]
     static const error_category &  errno_ecat     = generic_category();
                                    ^
../boost/system/error_code.hpp:224:36: warning: ‘boost::system::native_ecat’ defined but not used [-Wunused-variable]
     static const error_category &  native_ecat    = system_category();
                                    ^
...skipped <pregression/build/bin/gcc-4.8/gentoorelease/link-static/pch-off/threading-multi>compiler_status for lack of <pregression/build/bin/gcc-4.8/gentoorelease/link-static/pch-off/threading-multi>compiler_status.o...
gcc.archive ../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a

    "/usr/x86_64-pc-linux-gnu/bin/ar"  rc "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/cmdline.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/config_file.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/options_description.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/parsers.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/variables_map.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/value_semantic.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/positional_options.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/utf8_codecvt_facet.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/convert.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/winmain.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/split.o"
    "/usr/x86_64-pc-linux-gnu/bin/ranlib" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a"

...failed updating 1 target...
 * ERROR: dev-libs/boost-1.55.0-r1::gentoo failed (compile phase):
 *   Building of Boost tools failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3569:  Called die
 * The specific snippet of code:
 *           ejam ${OPTIONS} || die "Building of Boost tools failed";
 *
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.55.0-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.55.0-r1::gentoo'`.
 * The complete build log is located at '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/environment'.
 * Working directory: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0/tools'
 * S: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0'

>>> Failed to emerge dev-libs/boost-1.55.0-r1, Log file:

>>>  '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/build.log'

 * Messages for package dev-libs/boost-1.55.0-r1:

 * ERROR: dev-libs/boost-1.55.0-r1::gentoo failed (compile phase):
 *   Building of Boost tools failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3569:  Called die
 * The specific snippet of code:
 *           ejam ${OPTIONS} || die "Building of Boost tools failed";
 *
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.55.0-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.55.0-r1::gentoo'`.
 * The complete build log is located at '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/environment'.
 * Working directory: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0/tools'
 * S: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0'
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2857
Location: Dallas area

PostPosted: Sat Mar 22, 2014 12:13 pm    Post subject: Reply with quote

edit to remove advice.
_________________
Asus m5a99fx, FX 8320 - amd64-no-multilib, 4.14.52-zen, glibc-2.26-r7, gcc-7.3.0, eudev, openrc-0.13.11
xorg-server-1.19.5-r1 w/mesa-17.3.9, openbox, nouveau and radeon, oss4(2017), profile 17.0 (no-pie)


Last edited by Anon-E-moose on Sat Mar 22, 2014 6:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12509

PostPosted: Sat Mar 22, 2014 3:41 pm    Post subject: Reply with quote

Anon-E-moose wrote:
https://forums.gentoo.org/viewtopic-p-7520078.html
That is a completely different failure. The post you cited is a failure to build the tools. This is a failure to build the libraries.

OP:
Code:
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.55.0-r1::gentoo'`,
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2857
Location: Dallas area

PostPosted: Sat Mar 22, 2014 3:52 pm    Post subject: Reply with quote

edit to remove advice
_________________
Asus m5a99fx, FX 8320 - amd64-no-multilib, 4.14.52-zen, glibc-2.26-r7, gcc-7.3.0, eudev, openrc-0.13.11
xorg-server-1.19.5-r1 w/mesa-17.3.9, openbox, nouveau and radeon, oss4(2017), profile 17.0 (no-pie)


Last edited by Anon-E-moose on Sat Mar 22, 2014 6:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Mar 22, 2014 5:55 pm    Post subject: Reply with quote

'Rebuild with -j1' is only worth trying, cause it should terminate with first eror.

The correct request was 'pastebin whole build log', but with boost, it could have been ridiculously large.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1548
Location: /mnt/Gentoo/Europe

PostPosted: Tue Mar 25, 2014 9:22 am    Post subject: Reply with quote

Code:
# emerge --info '=dev-libs/boost-1.55.0-r1::gentoo'
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/my/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.


Portage 2.2.9-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.18-r1, 3.12.8-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.12.8-gentoo-x86_64-Intel-R-_Core-TM-_i5-2450M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8081688 total,    368300 free
KiB Swap:    9767484 total,   9767412 free
Timestamp of tree: Tue, 25 Mar 2014 08:00:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.4
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo bumblebee x-my
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/ rsync://mirror.bytemark.co.uk/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/video/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/bumblebee /usr/local/my"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups cxx dbus declarative demosaic djvu dri dts dv dvd dvdr ebook embedded emboss encode exif fam ffmpeg firefox flac fortran frei0r gdbm gde gif gles2 gpm gtk iconv icu ios ipv6 java jpeg kde kdenlive kipi lcms ldap libkms libnotify lm_sensors mad melt minizip mlt mmx mng modules mp3 mp4 mpeg mysql ncurses nls nptl nsplugin ogg opengl openmp opus pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline reports scanner script sdl semantic-desktop session smp sna spell sqlite sse sse2 sse3 sse41 sse42 ssl ssse3 startup-notification svg tcpd threads tiff tools truetype udev udisks unicode upower usb vaapi vcd vorbis wxwidgets x264 xcb xcomposite xinerama xml xmp xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-libs/boost-1.55.0-r1 was built with the following:
USE="icu nls python threads -context -debug -doc -mpi -static-libs -tools" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2"
CXXFLAGS="-march=native -O2 -pipe -ggdb -std=gnu++98"
Back to top
View user's profile Send private message
TomWij
Retired Dev
Retired Dev


Joined: 04 Jul 2012
Posts: 1553

PostPosted: Tue Mar 25, 2014 7:48 pm    Post subject: Reply with quote

Can you file this bug at Gentoo Bugzilla and provide the complete build log to them? It might be a parallel build issue as suggested but it might very well be the that the error has been cut off the message; to see if there is an error, grep for error: including the colon. Read here how to write a bug report, for more in-depth details and troubleshooting steps you can read our Bugzilla HOWTO.
Back to top
View user's profile Send private message
archenroot
Apprentice
Apprentice


Joined: 13 Dec 2011
Posts: 167
Location: Lake Macha, Czech republic

PostPosted: Fri Mar 28, 2014 12:03 pm    Post subject: Bug reported Reply with quote

I reported a bug at https://bugs.gentoo.org/show_bug.cgi?id=506064
The only difference between the original post is following:
original post error row:
Code:
ejam ${OPTIONS} || die "Building of Boost tools failed";

my post, probably some changes were in place:
Code:
ejam ${OPTIONS} $(use python && echo --python-buildid=${EPYTHON#python}) || die "Building of Boost libraries failed";

_________________
Emperor wants to control outer space Yoda wants to explore inner space that's the fundamental difference between good and bad sides of the Force
Back to top
View user's profile Send private message
Pinkbyte
Developer
Developer


Joined: 01 Jun 2012
Posts: 119
Location: Rostov-on-Don, Russia

PostPosted: Mon Apr 07, 2014 11:01 am    Post subject: Reply with quote

This is fixed, thanks for the report
Back to top
View user's profile Send private message
Maxwell
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2003
Posts: 96

PostPosted: Thu May 29, 2014 2:30 pm    Post subject: Reply with quote

FYI, mu machine also failed to emerge dev-libs/boost-1.55.0-r1, but after removing MAKEOPTS="-j5" from my make.conf emerge succeeded. Maybe boost doesn't like parallel compilation? (I'm using gcc-4.8.2 and glibc-2.19)

Cheers,
_________________
Freedom works. Use it!
Linux, by Gentoo
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12509

PostPosted: Fri May 30, 2014 1:27 am    Post subject: Reply with quote

Maxwell wrote:
FYI, mu machine also failed to emerge dev-libs/boost-1.55.0-r1, but after removing MAKEOPTS="-j5" from my make.conf emerge succeeded. Maybe boost doesn't like parallel compilation? (I'm using gcc-4.8.2 and glibc-2.19)
There are many ways to fail. You might have failed due to parallelism, due to overheating, due to memory exhaustion, or due to other load-related problems. Without seeing the failure message, we cannot identify the cause.
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 114
Location: JiangSu,China

PostPosted: Tue Nov 18, 2014 8:29 am    Post subject: Reply with quote

Maxwell wrote:
FYI, mu machine also failed to emerge dev-libs/boost-1.55.0-r1, but after removing MAKEOPTS="-j5" from my make.conf emerge succeeded. Maybe boost doesn't like parallel compilation? (I'm using gcc-4.8.2 and glibc-2.19)

Cheers,



thank you .
remove MAKEOPTS="-j5" helps me too.

my error code is " Building of Boost libraries failed"

I don't know why , in my other i7-4700mq laptop,it compile with no error (with MAKEOPTS="-j9")
but in this i3-3240 desktop, it always says error. until I remove like you said
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 642
Location: Close to Annecy (France)

PostPosted: Tue Jan 13, 2015 9:45 am    Post subject: Reply with quote

Hello,

I'm facing the same issue but on my BananaPI (ARM).
Are you using distcc ?

Laurent
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 114
Location: JiangSu,China

PostPosted: Tue Jan 13, 2015 7:43 pm    Post subject: Reply with quote

destroyedlolo wrote:
Hello,

I'm facing the same issue but on my BananaPI (ARM).
Are you using distcc ?

Laurent


No,I don't use distcc.
one computer one cpu.
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 642
Location: Close to Annecy (France)

PostPosted: Wed Jan 14, 2015 10:28 am    Post subject: Reply with quote

So I did compiled boost yesterday on my bPI by removing -J option as others did.

I confirm the problem is only related to parallel compilation. Fortunately, distcc is working (fortunately as my compilation was done on my i5 instead of the A20).

As per the checks I did, it's not strictly a problem a compilation but probably a dependency missing somewhere.
Back to top
View user's profile Send private message
spudz76
n00b
n00b


Joined: 25 Feb 2015
Posts: 1

PostPosted: Wed Feb 25, 2015 12:45 am    Post subject: Reply with quote

The Boost library takes about 1GB per -j thread to compile and will "not really say OOM" when it dies. Reduce to -j1 or -j2 if you are <8GB.
Back to top
View user's profile Send private message
grrilla
n00b
n00b


Joined: 18 May 2015
Posts: 11

PostPosted: Wed May 27, 2015 10:35 pm    Post subject: Reply with quote

spudz76 wrote:
The Boost library takes about 1GB per -j thread to compile and will "not really say OOM" when it dies. Reduce to -j1 or -j2 if you are <8GB.


can also, and still, confirm this. (i5 hp elitebook) -j1 Did the trick.
Back to top
View user's profile Send private message
destreza
n00b
n00b


Joined: 04 Oct 2014
Posts: 8

PostPosted: Mon Jul 27, 2015 2:41 am    Post subject: changing -j5 to -j1 to fix issue Reply with quote

changing to -j1 fixed issue. Probably anything lesser than your max amount of of cpu cores would be help during compilation of boost lib
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum