Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ssh/tightvnc has no desktop (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
johnklug
n00b
n00b


Joined: 17 Jun 2013
Posts: 31

PostPosted: Thu Mar 20, 2014 5:57 am    Post subject: ssh/tightvnc has no desktop (solved) Reply with quote

I am using slim and fluxbox with the console, and it works.

I am using ssl/ssh vnc viewer on a non-gentoo client configured with ssh with a gentoo server running xinetd and tightvnc, and I get a password prompt, accepted password, followed by a new window with a generic "X" screen with the X as the mouse pointer, and no fluxbox.

I have seen posts that say to put startfluxbox in
    /home/USER/.vnc/startx

I have straced xinetd through Xvnc, and I never see the home directory being accessed. Here are the parameters to Xvnc:

    13831 execve("/usr/bin/Xvnc", ["Xvnc", "-inetd", "-query", "localhost", "-geometry", "1920x1200", "-depth", "24", "-fp", "/usr/share/fonts/misc/,/usr/share/fonts/Type1"], [/* 40 vars */]) = 0


I am not seeing any errors in /var/log/messages.

Xvnc does try to open /etc/X1.hosts. This file does not exist.

Any ideas on how to get this configured correctly?


Last edited by johnklug on Fri Mar 21, 2014 5:53 am; edited 1 time in total
Back to top
View user's profile Send private message
johnklug
n00b
n00b


Joined: 17 Jun 2013
Posts: 31

PostPosted: Fri Mar 21, 2014 5:52 am    Post subject: Reply with quote

I decided to use the init.d method to start vnc directly, rather than xinetd.d which I used in other distros. Once I did this, I could log in with either ssh or directly using ssl/ssh vnc viewer.
This method eliminates the graphical login and Slim, and goes right to fluxbox, which is specified in the home directory of the user.
Here is a configuration file /etc/conf.d/vnc for two screens.


    # Config file for /etc/init.d/vnc

    # Specify the user(s) Xvnc(1) should be run for. The syntax is: "username:display".
    # example: "DISPLAYS="foo:1 bar:2" You can specify more users separated by space.
    # DISPLAYS="myuser:1"

    # Specify any of vncserver(1) and Xvnc(1) options. See the respective man pages for more information.
    # VNC_OPTS=""
    DISPLAYS="klugja:63 klugja:64"
    HOME=/home/klugja
    export HOME
    VNC_OPTS="-dpi 100 -name tvscribe -geometry 1920x1080 -depth 24"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum