Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Persistent "mail authentication request" popups
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dammital
Apprentice
Apprentice


Joined: 05 Nov 2004
Posts: 189

PostPosted: Wed Mar 12, 2014 7:01 pm    Post subject: [SOLVED] Persistent "mail authentication request" Reply with quote

Updated to Gnome 3.10 two days ago (along w/ evolution 3.10.4) and now I'm prompted for imapx/pop/smtp passwords every time evolution wants to connect to a remote mail server.

The checkbox to "Add this password to the keyring" is set, of course.

The gnome-online-accounts useflag is on, and I do not see the evolution-data-server in the system:
Quote:
$ ps ax|grep evo
1640 ? SLl 0:19 /usr/libexec/evolution-source-registry
1682 ? Sl 0:00 /usr/libexec/evolution/3.10/evolution-alarm-notify
1836 ? Sl 0:00 /usr/libexec/evolution-calendar-factory
2075 ? Sl 0:00 /usr/libexec/evolution-addressbook-factory
9415 ? Sl 0:13 evolution
9547 pts/2 S+ 0:00 grep --colour=auto evo


... but I no longer see evolution-data-server in /var/lib/evolution either, so maybe it went away between 3.8 and 3.10?

Why am I having to respond to the popup every few minutes?


Last edited by Dammital on Wed Mar 19, 2014 7:32 pm; edited 2 times in total
Back to top
View user's profile Send private message
Dammital
Apprentice
Apprentice


Joined: 05 Nov 2004
Posts: 189

PostPosted: Tue Mar 18, 2014 3:51 pm    Post subject: Reply with quote

Following up on my own post for the sake of interested parties:

I discovered the line:
Code:
-session         optional        pam_systemd.so
at the bottom of /etc/pam.d/system-auth and removed the "-" from the front to form:
Code:
session         optional        pam_systemd.so

That seems to have improved things (I'm no longer prompted all the time), but I have other squirrely Gnome3 artifacts that may or may not have to do with my complete ignorance of things pam and systemd - this systemd business has been traumatic.

For now I have a usable desktop again, and things to do with it. As I find the time I'll thrash some more.

===

(Not terribly relevant here, but my Gnome3 experience has been far less than pleasant. I've given it over a month's fair shake, as the upgrade wiki suggested, but I have to say that xfce sounds better every day.

Edit: not to turn this into a Gnome3-bashing thread, but I subsequently installed xfce and removed Gnome3. My problems have all gone away - still running systemd though. I'll mark this as "solved".)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum