Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ConsoleKit Issues With glib
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ImageJPEG
n00b
n00b


Joined: 03 Feb 2013
Posts: 20
Location: North West Iowa

PostPosted: Wed Mar 12, 2014 5:10 pm    Post subject: ConsoleKit Issues With glib Reply with quote

The current version (2.38.2) of glib seems to break ConsoleKit when logging into KDM. After I type my password and press enter I'm greeted with this message:

Code:
Warning: Cannot open ConsoleKit session: Unable to open session: Unable to get information about the calling process.


This happened after upgrading glib. I was able to mask the current version and go back to the previous glib and ConsoleKit worked. (I can't remember the version because I'm running the current now)

Like I said above, I'm using the current version of glib. I've tried reinstalling consolekit, kdm and anything that deals with dbus with no luck :/

I'm still able to use the system but it's very annoying and I'm unable to use some KDE features.
Back to top
View user's profile Send private message
Spacebug
n00b
n00b


Joined: 04 Jan 2009
Posts: 18
Location: Germany

PostPosted: Wed Mar 12, 2014 6:39 pm    Post subject: Reply with quote

There is another thread on this:

[url] https://forums.gentoo.org/viewtopic-t-982964.html [/url]

and a bug-report:

[url] https://bugs.gentoo.org/show_bug.cgi?id=501330 [/url]

But still no solution other than downgrading glib, which to me seems like an overkill. Hopefully someone will figure out the problem soon. On some systems glib-2.38.2 actually works fine with consolekit.
Back to top
View user's profile Send private message
ImageJPEG
n00b
n00b


Joined: 03 Feb 2013
Posts: 20
Location: North West Iowa

PostPosted: Wed Mar 12, 2014 7:04 pm    Post subject: Reply with quote

Thanks for the quick reply. I'm having an issue now trying to mask glib :/ Wonderful!

This is how glib is in my /etc/portage/package.mask:

Code:
dev-libs/glib-2.38.2


When I try to sync I get this error:

Code:
--- Invalid atom in /etc/portage/package.mask: dev-libs/glib-2.38.2


When I do a search for glib, it tells me that the current version is still 2.38.2. This is after I uninstall glib to go to a previous version.



I've also tried using
Code:
>dev-libs/glib-2.36.4-r1
but this time it doesn't show me an invalid atom. I still shows that I can install glib 2.38.2 though :/
Back to top
View user's profile Send private message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 181
Location: Singapore

PostPosted: Fri Mar 14, 2014 1:52 am    Post subject: Reply with quote

As in the other thread, this was confirmed as a glib bug. Patch is available as well:
https://bugs.gentoo.org/show_bug.cgi?id=501330#c68
https://mail.gnome.org/archives/commits-list/2013-November/msg02586.html
Back to top
View user's profile Send private message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Fri Mar 14, 2014 5:45 pm    Post subject: Reply with quote

that patch didn't fix the problem for me :/

Switching to lastest version : 2.38.2-r1 fixed the problem for me
Back to top
View user's profile Send private message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 181
Location: Singapore

PostPosted: Fri Mar 14, 2014 10:03 pm    Post subject: Reply with quote

What arch are you on?
Back to top
View user's profile Send private message
alex6
Apprentice
Apprentice


Joined: 18 Jul 2011
Posts: 157

PostPosted: Sat Mar 15, 2014 9:52 am    Post subject: Reply with quote

amd64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum