Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"Not authorized to perform operation."
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 980

PostPosted: Wed Mar 12, 2014 3:47 pm    Post subject: "Not authorized to perform operation." Reply with quote

I'm getting the following error when trying to mount my USB camera in Thunar:

"Not authorized to perform operation."

It was working fine until I updated and rebooted this morning. Any ideas?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7896
Location: ~Brussels - Belgique

PostPosted: Wed Mar 12, 2014 4:18 pm    Post subject: Reply with quote

Hello,

Is your user in the plugdev group?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 980

PostPosted: Wed Mar 12, 2014 4:56 pm    Post subject: Reply with quote

Yes plugdev but not usb. Could that be it? The system is remote so not so easy to test.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed Mar 12, 2014 7:02 pm    Post subject: Reply with quote

Usually, this kind of error is acl related from either consolekit or systemd.
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 980

PostPosted: Wed Mar 12, 2014 7:32 pm    Post subject: Reply with quote

I'm not using systemd (unless it's used by default) and I haven't configured consolekit at all.
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 980

PostPosted: Fri Mar 14, 2014 12:35 am    Post subject: Reply with quote

Could this be because I updated udisks?
Back to top
View user's profile Send private message
berg
n00b
n00b


Joined: 02 Feb 2004
Posts: 35

PostPosted: Fri Mar 14, 2014 6:54 pm    Post subject: Reply with quote

This issue is related to Bug 501330 and can be fixed with an update to glib-2.38.2-r1.
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 980

PostPosted: Fri Mar 14, 2014 10:11 pm    Post subject: Reply with quote

That's great news. I'll try it now. Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum