Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PyQt4-4.10.3-r2 and sip-4.15.3 breaks kde-misc/synaptiks
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tamjan
n00b
n00b


Joined: 11 May 2012
Posts: 8
Location: Luleå, Sweden

PostPosted: Tue Mar 11, 2014 9:20 am    Post subject: PyQt4-4.10.3-r2 and sip-4.15.3 breaks kde-misc/synaptiks Reply with quote

PyQt4-4.10.3-r2 and sip-4.15.3 got stable recently. Upgrading from the previous stable versions makes synaptiks segfault. Downgrading those two packages (and rebuilding the packages that depend on them) restores synaptiks functionality. Has anybody experienced this? Is there another workaround that doesn't hinder the upgrading of the two packages?

And synaptiks is dead upstream. I haven't found a nice replacement though, that also disables the touchpad while typing. Any hints there?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Wed Mar 12, 2014 9:52 am    Post subject: Reply with quote

File a bug, please.

But the most likely outcome will be to stick with the old versions or remove the dead package.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 181

PostPosted: Mon Mar 24, 2014 9:40 pm    Post subject: Re: PyQt4-4.10.3-r2 and sip-4.15.3 breaks kde-misc/synaptiks Reply with quote

hi tamjan,

same problem here. I tried kde-misc/kcm_touchpad. that installs a touchpad configuration tool like synaptiks but it's the "disable touchpad when typing"-function of all things that is deactivated (greyed out). and well, this software also seems not being maintained anymore since jan 2010...

I am really surprised that nobody else seems to have this problem. I thought synaptics-touchpads would be rather common and the disable-touchpad-while-typing-function is definitely important and useful.
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 181

PostPosted: Wed Mar 26, 2014 4:56 pm    Post subject: Reply with quote

hi again,

here's the solution: syndaemon
just start it at sessions begin: syndaemon -t -d -K

since without synaptiks and kcm_touchpad, unfortunately also tapping is switched off by the default configuration, you should consider to enable that via the command line:
Code:
synclient TapButton1=1

and/or Xorg-config: https://wiki.gentoo.org/wiki/Synaptics
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum