Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update bug prevent KDE mounting of any USB device [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Tue Mar 11, 2014 12:38 am    Post subject: Update bug prevent KDE mounting of any USB device [solved] Reply with quote

After I installed software updates I am now unable to mount any USB device that I connect to my computer. The error is that KDE refuses to mount an USB device.


Using the mount command however works normally. But I can't move files from my phones or usb sticks using that way (due to root being owner). I don't remember what was changed during the update in KDE (my Desktop). My user is in the usb group as it should have been. I have not yet tested DVD/CD yet if this also applies there. I am not sure what the problem is, but I have been reading that this might have something to do with sys-fs/udisks version problem.

At least I need to resolve this. I am running the following kernel version.

Code:
uname -a
Linux jupiter 3.8.13 #1 SMP PREEMPT Mon Nov 25 00:52:14 CET 2013 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ AuthenticAMD GNU/Linux


Thanks for the help.


Last edited by jonfr on Tue Mar 11, 2014 10:15 am; edited 1 time in total
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 318
Location: 39.885° N. -88.913° W.

PostPosted: Tue Mar 11, 2014 2:33 am    Post subject: Reply with quote

jonfr

Did you also update sys-auth/polkit at the same time as the KDE items?

If you did you might look at this file.
Code:
# nano -w /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy


I had a problem after updating and edited this file by changing most of the parts that say auth_admin to " yes ".
This lets me mount them by clicking on the icon.

But I'm the only person that has access to this computer so I have no problem changing things.

Hope this helps you.
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Tue Mar 11, 2014 9:27 am    Post subject: Reply with quote

I've got this polkit software version installed.

Code:
sys-auth/polkit-kde-agent
      Latest version available: 0.99.0-r1
      Latest version installed: 0.99.0-r1
      Size of files: 33 kB
      Homepage:      http://www.kde.org
      Description:   PolKit agent module for KDE.
      License:       GPL-2


Code:
sys-auth/polkit
      Latest version available: 0.112-r1
      Latest version installed: 0.112-r1
      Size of files: 1,395 kB
      Homepage:      http://www.freedesktop.org/wiki/Software/polkit
      Description:   Policy framework for controlling privileges for system-wide services
      License:       LGPL-2


I also got this version of udisks installed.

Code:
sys-fs/udisks
      Latest version available: 2.1.2
      Latest version installed: 2.1.2
      Size of files: 878 kB
      Homepage:      http://www.freedesktop.org/wiki/Software/udisks
      Description:   Daemon providing interfaces to work with storage devices
      License:       GPL-2


I didn't see anything that I could change to "yes" in the configuration file of sys-auth/polkit.

Thanks for the help.
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Tue Mar 11, 2014 9:46 am    Post subject: Reply with quote

What does the udisks command line say?

Code:
udisksctl mount -b /dev/sdb1


If this fails, it is not a KDE problem but a problem in the polkit rules or with udisks generally. You should be able to find out the block device of your usb disk (sdb/sdc etc.) with dmesg, after you inserted the device.
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Tue Mar 11, 2014 10:19 am    Post subject: Reply with quote

I did manage to fix this. The solution is going to KDE System settings -> System Control -> Action Policy -> org.freedesktop -> The udisks project > Mount a filesystem -> Change "Any" to "Yes" and "Active Console" to "Yes". It is necessary to log in as root in order to change this settings. After that it is possible to mount usb sticks, mobile phones and such as normal user.

Thanks for all the help. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum