Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XDM: cannot authenticate
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SxN
Apprentice
Apprentice


Joined: 08 Jan 2007
Posts: 165
Location: Toronto, ON, Canada

PostPosted: Mon Mar 10, 2014 10:44 pm    Post subject: [SOLVED] XDM: cannot authenticate Reply with quote

Hi All,

On a fresh install, I'm not able to login in XDM: it allows me to type user and passwd, then after a moment, it prompts again. There is no error of typing the wrong pair user/passwd (unless I intentionally do a mistake). I found a similar situation here: https://forums.gentoo.org/viewtopic-t-931254-start-0.html. However, none of the suggestions there was helpful in my case.

My /var/log/messages looks like this:

Code:
Mar 10 23:19:47 ERiS xdm[2146]: pam_unix(xdm:session): session opened for user root by (uid=0)
Mar 10 23:19:48 ERiS xdm[2146]: pam_unix(xdm:session): session closed for user root
Mar 10 23:20:01 ERiS crond[2200]: pam_unix(crond:session): session opened for user root by (uid=0)
Mar 10 23:20:01 ERiS CROND[2203]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Mar 10 23:20:01 ERiS CROND[2200]: pam_unix(crond:session): session closed for user root


How can I tackle this one?

Thanks


Last edited by SxN on Wed Mar 12, 2014 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
SxN
Apprentice
Apprentice


Joined: 08 Jan 2007
Posts: 165
Location: Toronto, ON, Canada

PostPosted: Tue Mar 11, 2014 4:16 am    Post subject: Reply with quote

Updates:

I kept toying around and discovered the followings:
- ctrl+alt+backspace is not shutting down xdm, as I expected
- ctrl+alt+F1, F2 etc work
- after switching to terminal 1, I tried
Code:
startx -- :3

and got a twm. From inside twm I tried then
Code:
startkde
and it launched a (rather empty) plasma desktop. All the windows that I managed to launch had a twm frame, and upon leaving KDE I was sent back to twm. Leaving twm sent me back to the terminal, as it should be.

I'm concluding that I have a functional X server and a KDE, but they are not launched properly by XDM, therefore it restarts itself. So, I'm going to start digging into all the launching scripts and *rc, hoping to find the issue. But, any advice that you may have is more than welcome :)

Thanks
Back to top
View user's profile Send private message
SxN
Apprentice
Apprentice


Joined: 08 Jan 2007
Posts: 165
Location: Toronto, ON, Canada

PostPosted: Wed Mar 12, 2014 6:35 pm    Post subject: Reply with quote

As XDM is not very talkative, I switched to KDM. There I was greeted by an explicit message:
root logins are not allowed.

Knowing now what's the issue, wasn't long before I changed /usr/share/config/kdm/kdmrc to my liking, setting AllowRootLogin=true. (I think that's the flag's name).

Credit goes here: http://www.linuxquestions.org/questions/debian-26/root-logins-are-not-allowed-264279/

I know, root is bad; in my context I will go against common wisdom.

Others in similar situations may find useful my experience.

Regards,
SxN
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum