Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rkhunter: Invalid display - keyword cannot be found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Seron
Apprentice
Apprentice


Joined: 31 Dec 2002
Posts: 293
Location: Malmö, Sweden

PostPosted: Fri Mar 07, 2014 10:36 am    Post subject: rkhunter: Invalid display - keyword cannot be found Reply with quote

Lately I'm getting these error messages from a rkhunter (1.4.0) cron job:
Code:
Error: Invalid display - keyword cannot be found: Display line: display --to LOG --type INFO NETWORK_PROMISC_NO_IP
Error: Invalid display - keyword cannot be found: Display line: display --to LOG --type INFO --log-indent 2 SYSTEM_CONFIGS_SYSLOG_METALOG_RUNNING

What do they mean and how does one correct them? I couldn't find anything useful on these errors by searching.
_________________
man cannot be brave without being afraid
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Fri Mar 07, 2014 10:50 am    Post subject: Re: rkhunter: Invalid display - keyword cannot be found Reply with quote

Code:
...keyword cannot be found...

I would suspect you get a problem with your language files in /var/lib/rkhunter/db/i18n/
_________________
Back to top
View user's profile Send private message
fillerbunny
n00b
n00b


Joined: 21 May 2002
Posts: 27

PostPosted: Fri Apr 11, 2014 8:46 am    Post subject: Reply with quote

This is possibly because your language files have been updated in /var/lib/rkhunter/db/i18n/ to the rkhunter 1.4.2 versions, which have different lang strings.

I believe that the lang files on the rk update site are only for the latest version of rkhunter, which is now 1.4.2.
Gentoo latest is 1.4.0 at present.

If you have update enabled in your rkhunter cron job then it may have pulled down the 1.4.2 version.

This happened to me anyway.
I have restored my lang files from a backup and disabled rkhunter update until there is an ebuild for 1.4.2
Back to top
View user's profile Send private message
kurisu
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 147
Location: Munich, Germany

PostPosted: Tue May 20, 2014 9:22 pm    Post subject: Reply with quote

I got struck by this issue as well. Since rkhunter provides a few alternate language files (see: rkhunter --list languages) I could fix this for me by switching to de. Surely not an option for everyone though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum