Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Game client Tinyfugue missing after emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
eachna
n00b
n00b


Joined: 22 Oct 2004
Posts: 4

PostPosted: Thu Jan 22, 2015 5:05 pm    Post subject: [solved] Game client Tinyfugue missing after emerge Reply with quote

I emerged tf (tinyfugue, games-mud/tf-50_beta8-r1). It appears to complete properly. I get the following message:

Code:

Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) games-mud/tf-50_beta8-r1::gentoo
>>> Installing (1 of 1) games-mud/tf-50_beta8-r1::gentoo
>>> Jobs: 1 of 1 complete                   Load avg: 5.60, 5.12, 5.24

 * Messages for package games-mud/tf-50_beta8-r1:

 * Package:    games-mud/tf-50_beta8-r1
 * Repository: gentoo
 * Maintainer: games@gentoo.org
 * USE:        abi_x86_64 amd64 atcp elibc_glibc gmcp ipv6 kernel_linux option102 ssl userland_GNU
 * FEATURES:   preserve-libs sandbox splitdebug userpriv usersandbox
 * Applying tf-allrootpatch.txt ...
 * Applying tf-allsrcpatch.txt ...
 * Applying tf-50_beta8-pcre.patch ...
 * Applying tf-50_beta8-stdarg.patch ...
 * Remember, in order to play games, you have to
 * be in the 'games' group.
 * Just run 'gpasswd -a <USER> games', then have <USER> re-login.
 * For more info about Gentoo gaming in general, see our website:
 *    http://games.gentoo.org/
 * You have merged TinyFugue with IPv6-support.
 * Support for IPv6 is still being experimental.
 * If you experience problems with connecting to hosts,
 * try re-merging this package with USE=-ipv6
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



My user has been added to the games group.

I can't find the tf executable.

"tf", "tinyfugue" "Tf" "TF" "tf5" "tf-beta" and "tf-50_beta8-r1" all return command not found.

I tried using locate and can't find a likely binary that way. Anyone have a clue where it might end up being put?

update:
It deletes the whole install directory when it finishes compiling. I copied the build tree while compiling and poked through the files. I found config.log and at the top was this snippet:
Code:

  $ ./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --prefix=/usr/games --libdir=/usr/games/lib64 --datadir=/usr/share/games --sysconfdir=/etc/games --localstatedir=/var/games --enable-atcp --enable-gmcp --enable-option102 --enable-ssl --disable-core --enable-inet6 --enable-manpage

## --------- ##



Checking, I found the executable in /usr/games/bin. It's a non-standard place to put it but at least it's there and it works now that I added /usr/games/bin to the global PATH.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum