Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound Audio over displayport Radeon Ultimate HD6670
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 241
Location: France

PostPosted: Sun Mar 02, 2014 5:28 pm    Post subject: No sound Audio over displayport Radeon Ultimate HD6670 Reply with quote

hi,

I recently installed a new monitor samsung S27B971D with a Radeon HD6670 ultimate card. I use gnome 3 and I can see the following available devices for output in the sound parameters of gnome:
    HDMI / Diplayport - Turks/Whisler HDMI Audio [Radeon HD 6000 Series]
    Digital Output (S/PDIF) Internal audio
    Analog output - Internal audio


If choose the first one and try the speakers I get nothing.

lspci -k gives this (among other)

Quote:
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
Subsystem: PC Partner Limited / Sapphire Technology Device e194
Kernel driver in use: radeon
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
Subsystem: PC Partner Limited / Sapphire Technology Device aa90
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

Apparently the kernel driver in use seems not to be the right one.

What should I do in order to use the radeon audio driver?


Last edited by augustin2 on Mon Mar 03, 2014 6:13 am; edited 1 time in total
Back to top
View user's profile Send private message
user
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2004
Posts: 135

PostPosted: Mon Mar 03, 2014 12:13 am    Post subject: Reply with quote

hi,
first fix your thread title. :o

AMD/ATI has a long journey of NO support for HD-audio passthrough in linux for recent hardware behind.
In late 2013 this situation is fixed and documented, so even HDMI audio works on AMD R9 290x with kernel 3.13.

So,
- check your kernel is up-to-date
- watch out for this error
Code:
[    1.517158] Too many HDMI devices
[    1.517595] Consider building the kernel with CONFIG_SND_DYNAMIC_MINORS=y

- try these kernel options, its works for me(tm)
Code:
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_MAX_CARDS=4
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_CODEC_HDMI=y

- kernel module snd_hda_intel is correct for hdmi audio only. Example output from AMD R9 290X
Code:
# lspci -ks 01:00.0 ; lspci -ks 01:00.1
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT [Radeon HD 8970]
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device 0b00
        Kernel driver in use: radeon
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device aac8
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device aac8
        Kernel driver in use: snd_hda_intel

- verify your devices with aplay from package alsa-utils
Code:
# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
hdmi:CARD=Generic,DEV=1
    HD-Audio Generic, HDMI 1
    HDMI Audio Output
hdmi:CARD=Generic,DEV=2
    HD-Audio Generic, HDMI 2
    HDMI Audio Output
hdmi:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 3
    HDMI Audio Output

- produce sound with speaker-test also from package alsa-utils
Code:
# speaker-test -D hdmi -c 2 -t wav

- check with alsamixer that no channel is muted
- to listen audio via hdmi, hdmi screen must be active
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 241
Location: France

PostPosted: Mon Mar 03, 2014 6:12 am    Post subject: No sound with Audio over displayport Radeon Ultimate HD6670 Reply with quote

Thank you for this fully documented answer. But I feel a bit worried as I am used to installing the gentoo-sources (as it is recommanded) and the last are 3.10.25 and not 3.13. Is there any risk in installing 3.13 and is this absolutely mandatory?

And also, where and in what context should I watch this error ?

Quote:
[ 1.517158] Too many HDMI devices
[ 1.517595] Consider building the kernel with CONFIG_SND_DYNAMIC_MINORS=y
Back to top
View user's profile Send private message
SirRobin2318
Apprentice
Apprentice


Joined: 24 Apr 2004
Posts: 234
Location: Strasbourg, france.

PostPosted: Mon Mar 03, 2014 10:20 am    Post subject: Reply with quote

There is no real risk of using 3.13. Just keep the old kernel in /boot, if 3.13 does not work, you can still boot with 3.10.
You should watch for that error in the output of dmesg.
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 241
Location: France

PostPosted: Mon Mar 03, 2014 10:51 am    Post subject: Reply with quote

Thank you again.

At the moment I have some trouble with the monitor and I have to return it to Samsumg. Thus I will have to wait before applying what you suggest. I will come back here as soon as I receive a new monitor.
May be I will try to switch to a new kernel before that.
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 241
Location: France

PostPosted: Mon Mar 03, 2014 1:40 pm    Post subject: Reply with quote

Quote:
In late 2013 this situation is fixed and documented, so even HDMI audio works on AMD R9 290x with kernel 3.13.


According to the page : http://www.x.org/wiki/RadeonFeature/#22 it seems that HDMI audio is working but DP audio is still to do? Does this mean I cannot have audio (using displayport) with the full resolution of my screen ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum