Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdemain No DBUS session-bus found [solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Feb 28, 2014 10:43 am    Post subject: kdemain No DBUS session-bus found [solved] Reply with quote

Hello everybody,

I'm trying to come back to gentoo after some others distrib' testing... but I'm completely stuck on the installation of kde. Kdm starts and stop immediatlty with "klauncher(2252) kdemain: No DBUS session-bus found" and I don't find why !

X seems to be correctly configured because startx works well (and glxinfo show me direct rendering : Yes for my nvidia cards... but I tried with my integrated intel HD and it's the same thing !)

I use systemd, I don't know if there is a link... I'm a little noob with this :s

Here are some log :

kdm.log :

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
Current Operating System: Linux kbu 3.10.25-gentoo #2 SMP PREEMPT Thu Feb 27 22:03:35 CET 2014 x86_64
Kernel command line: root=UUID=3eae3d38-2c8a-45d3-a340-cc34231b9172 init=/usr/lib/systemd/systemd systemd.show_status=1 BOOT_IMAGE=/boot/kernel-3.10.25-gentoo root=/dev/sda8 ro init=/usr/lib/systemd/systemd
Build Date: 27 February 2014 06:26:03PM

Current version of pixman: 0.32.4
Before reporting problems, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 27 22:33:48 2014
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
Loading extension NV-GLX
Loading extension NV-CONTROL
Loading extension XINERAMA
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
klauncher(2252) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(2246)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "Not connected to D-Bus server"

kdmgreet(2246)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
setversion 1.4 failed
(EE) Server terminated successfully (0). Closing log file.

[I] kde-base/kde-meta
Available versions: (4) 4.11.5{tbz2} ~4.12.2
{accessibility aqua nls sdk semantic-desktop}
Installed versions: 4.11.5(4){tbz2}(03:03:35 25/02/2014)(nls semantic-desktop -accessibility -aqua -sdk)
Description: KDE - merge this to pull in all split kde-base/* packages

# emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.7.3, glibc-2.17, 3.13.4-200.fc20.x86_64 x86_64)
System uname: Linux-3.13.4-200.fc20.x86_64-x86_64-Intel-R-_Core-TM-_i5-2540M_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem: 16311868 total, 14647576 free
KiB Swap: 7815584 total, 7815584 free
Timestamp of tree: Thu, 27 Feb 2014 14:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.5-r3, 3.3.3
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12.4
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.17
Repositories: gentoo
CFLAGS="-march=native -O3 -pipe "
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O3 -pipe "
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aacplus acl acpi alsa amd64 avahi bbswitch berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli cracklib crypt cups cxx dbus declarative dhcpcd dri dts dvb dvd dvdr emboss encode equalizer exif faac fam ffmpeg firefox flac fortran gd gdbm gif gpm iconv ieee1394 ipv6 jack jpeg jpeg2k kde kipi lcms ldap libass libcaca libnotify mad matroska melt mmx mng modules mozilla mp3 mp4 mpeg mtp multilib multimedia musepack ncurses nls nptl ogg opengl openmp openssl p2p pam pango pcre pdf phonon plasma png policykit ppds pulseaudio pyqt4 qt3support qt4 readline resolvconf samba sdl semantic-desktop session spell sqlite sse sse2 sse3 sse4 sse4_2 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower usb v4l valgrind vdpau vorbis wavpack wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

How can I check if dbus session is working ??? And how to see what's missing ??

Thank's a lot for your help :)

Last edited by gaga on Mon Mar 10, 2014 8:54 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 01 Oct 2002
Posts: 29
Location: Sweden

PostPosted: Mon Mar 10, 2014 7:47 am    Post subject: Reply with quote

I have the same problem and I've been running KDE and Gentoo for many years. Suddenly it just stops working. I only get a blank screen, the KDE starting process seems to just quit right after I enter the password.

Starting X from a console works fine, it's just the KDM service that refuse to work.

Sadly, this type of problem (instability) happens too often in Gentoo. I love many aspects of Gentoo but this thing that things just stop working all of a sudden really annoys me. I wish the developers would be more careful not to break stuff when they change things.

edit: I'm not using systemd by the way
Back to top
View user's profile Send private message

Joined: 27 Apr 2005
Posts: 288

PostPosted: Mon Mar 10, 2014 8:53 am    Post subject: Reply with quote


Yes, I have the same feeling... now I've a Fedora and Gentoo, but I used Fedora more often than Gentoo because of that....

I solved my problem : I finally just reinstall dbus systemd polkit and add the systemd-units use flag
emerge -1av --noconfmem dbus systemd polkit

Here is the complete thread in the French section :
Back to top
View user's profile Send private message

Joined: 01 Oct 2002
Posts: 29
Location: Sweden

PostPosted: Mon Mar 10, 2014 1:35 pm    Post subject: Reply with quote

gaga wrote:

Yes, I have the same feeling... now I've a Fedora and Gentoo, but I used Fedora more often than Gentoo because of that....

I solved my problem : I finally just reinstall dbus systemd polkit and add the systemd-units use flag
emerge -1av --noconfmem dbus systemd polkit

Here is the complete thread in the French section :

Thanks for the suggestion but it didn't help.

However, I found the problem. For some reason the startup was hung up on process:

/opt/bin/nvidia-settings --load-config-only

Killing that process made the startup go on!

So apparently it didn't have much to do with dbus this time I guess, even though I get the same errors as in your first post KDE works fine now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum