Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't read cd's - works once on reboot, corrupts [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 821
Location: Alaska

PostPosted: Wed Feb 26, 2014 5:50 pm    Post subject: can't read cd's - works once on reboot, corrupts [solved] Reply with quote

I have a weird problem in which I've been trying to read old backup CDs and dolphin shows zero files. I can read the CDs in a virtualbox Windows machine, same computer. If I reboot, I can read one or two CDs before it again stops seeing files on them. The notification window does pop up when putting in a disk, and I can click "open with file manager" but it shows zero files.

I'm running ~amd x86_64, so the latest portage KDE, and nearly the latest gentoo-sources kernel (3.13.2). I have a PATA CD/DVD writer and thought maybe that was the problem. So I installed also a SATA writer I had on hand and (this is a desktop) and have the same problem with it, though once it did show the files/folders but with corrupted text for files/folders (unreadable symbols).

dmesg shows this:
Code:

[79681.255469] usb usb1: bus auto-suspend, wakeup 1
[79681.255471] ehci-pci 0000:00:12.2: suspend root hub
[82205.978536] VFS: busy inodes on changed media or resized disk sr1
[82245.427402] iso9660: Corrupted directory entry in block 0 of inode 1472
[82245.785338] iso9660: Corrupted directory entry in block 0 of inode 1472
[82245.994596] iso9660: Corrupted directory entry in block 0 of inode 1472
[82245.994608] iso9660: Corrupted directory entry in block 0 of inode 1472


Again, if I reboot, this same disk reads properly, but then the next disk or two won't. I've tried just logging out of KDE and logging back in, but it does take a complete reboot so some service or another needs to be restarted not related to KDE?

advice much welcomed. cheers, JD
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 821
Location: Alaska

PostPosted: Wed Feb 26, 2014 5:55 pm    Post subject: Reply with quote

I think I've figured it out suddenly. The coffee just kicked in and I googled the dmesg VFS line. I haven't been unmounting the previous CD properly and if I do - tested it once here - it seems to work on the next then. Sorry about wasting anyone's time. /jd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum