Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia drivers downgrade touble
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bdx
n00b
n00b


Joined: 04 Jan 2006
Posts: 64

PostPosted: Sun Feb 23, 2014 9:37 pm    Post subject: nvidia drivers downgrade touble Reply with quote

Ok, I accidentally upgraded nvidia drivers to 334.16-r7 and have troubles with mythtv segfaulting, now I am
attempting to downgrade back to nvidia drivers 331.38 and having trouble starting gnome (via startx).

There is an error message in "gnomerc-errors": libEGL.so.1 no such file or directory

Is there a workaround for this ? Not sure why the downgrade didn't work. (emerge =nvidia-drivers-331.38)
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 318
Location: 39.885° N. -88.913° W.

PostPosted: Mon Feb 24, 2014 3:02 am    Post subject: Reply with quote

bdx

I get this
Code:
equery b libEGL.so.1
 * Searching for libEGL.so.1 ...
app-emulation/emul-linux-x86-opengl-20131008 (/usr/lib32/opengl/xorg-x11/lib/libEGL.so.1 -> libEGL.so.1.0.0)
app-emulation/emul-linux-x86-opengl-20131008 (/usr/lib32/libEGL.so.1 -> opengl/xorg-x11/lib/libEGL.so.1.0.0)
media-libs/mesa-9.1.6 (/usr/lib64/opengl/xorg-x11/lib/libEGL.so.1 -> libEGL.so.1.0.0)


So you might try to rebuild these 2 packages one at a time and see if this will fix that item.
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1031
Location: Massachusetts USA

PostPosted: Mon Feb 24, 2014 4:37 am    Post subject: Reply with quote

1) eselect opengl to select xorg-x11

2) delete /usr/lib32/opengl/nvidia/lib/libEGL.so.1 and /usr/lib32/opengl/nvidia/lib/libEGL.so.334.16

3) use eselect opengl to select nvidia
Back to top
View user's profile Send private message
bdx
n00b
n00b


Joined: 04 Jan 2006
Posts: 64

PostPosted: Mon Feb 24, 2014 2:18 pm    Post subject: Reply with quote

Could not find any dependencies on this box with equery b libEGL.so.1 but I re-emerged mesa anyway which
solved the issue. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum