Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xserver on raspb.pi - No drivers - exynos in make.conf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kaTiezei
n00b
n00b


Joined: 10 Mar 2013
Posts: 39

PostPosted: Sun Feb 23, 2014 1:25 pm    Post subject: xserver on raspb.pi - No drivers - exynos in make.conf Reply with quote

Hello,

I have emerged xorg-server on my raspberry pi. When trying to startx I get an error about loading GLX. I have installed the kernel and the whole system according to http://wiki.gentoo.org/wiki/Raspberry_Pi#Kernel_and_modules. In make.conf I have
Code:
VIDEO_CARDS="exynos"

The setup of xserver worked - I also had to pull libdrm (like this: https://forums.gentoo.org/viewtopic-p-7469658.html?sid=3e9ec40c9d8593319af27b5f66de151e ):

Code:

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild   R    ] x11-base/xorg-server-1.14.3-r2:0/1.14.3  USE="ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -xnest -xvfb" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] Interrupted.






startx
Code:
xauth:  file /root/.serverauth.2531 does not exist


X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.6.11-raspberrypi+ armv6l Gentoo
Current Operating System: Linux localhost 3.6.11-raspberrypi+ #1 PREEMPT Fri Jan 3 17:47:27 CET 2014 armv6l
Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1280 bcm2708_fb.fbheight=1024 bcm2708.boardrev=0xe bcm2708.serial=######## smsc95xx.macaddr=######## sdhci-bcm2708.emmc_clock_freq=100000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  ipv6.disable=0 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext2 elevator=noop rootwait
Build Date: 08 February 2014  10:56:45AM
 
Current version of pixman: 0.32.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 23 09:55:49 2014
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Bad file descriptor
xinit: server error





Here is my full Xorg.o.log:
Code:

[ 23847.652]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[ 23847.653] X Protocol Version 11, Revision 0
[ 23847.653] Build Operating System: Linux 3.6.11-raspberrypi+ armv6l Gentoo
[ 23847.653] Current Operating System: Linux localhost 3.6.11-raspberrypi+ #1 PREEMPT Fri Jan 3 17:47:27 CET 2014 armv6l
[ 23847.653] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1280 bcm2708_fb.fbheight=1024 bcm2708.boardrev=0xe bcm2708.serial=########### smsc95xx.macaddr=########### sdhci-bcm2708.emmc_clock_freq=100000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  ipv6.disable=0 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext2 elevator=noop rootwait
[ 23847.654] Build Date: 08 February 2014  10:56:45AM
[ 23847.654] 
[ 23847.655] Current version of pixman: 0.32.4
[ 23847.655]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[ 23847.655] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 23847.656] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 23 09:55:49 2014
[ 23847.657] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 23847.658] (==) No Layout section.  Using the first Screen section.
[ 23847.658] (==) No screen section available. Using defaults.
[ 23847.659] (**) |-->Screen "Default Screen Section" (0)
[ 23847.659] (**) |   |-->Monitor "<default monitor>"
[ 23847.660] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[ 23847.661] (==) Automatically adding devices
[ 23847.661] (==) Automatically enabling devices
[ 23847.661] (==) Automatically adding GPU devices
[ 23847.661] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[ 23847.661]    Entry deleted from font path.
[ 23847.662] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 23847.662]    Entry deleted from font path.
[ 23847.662] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 23847.662]    Entry deleted from font path.
[ 23847.662] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 23847.662]    Entry deleted from font path.
[ 23847.662] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[ 23847.662]    Entry deleted from font path.
[ 23847.662] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[ 23847.663]    Entry deleted from font path.
[ 23847.663] (==) FontPath set to:
   
[ 23847.663] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 23847.663] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 23847.663] (II) Loader magic: 0x1c0e28
[ 23847.663] (II) Module ABI versions:
[ 23847.663]    X.Org ANSI C Emulation: 0.4
[ 23847.663]    X.Org Video Driver: 14.1
[ 23847.663]    X.Org XInput driver : 19.1
[ 23847.664]    X.Org Server Extension : 7.0
[ 23847.665] Initializing built-in extension Generic Event Extension
[ 23847.665] Initializing built-in extension SHAPE
[ 23847.665] Initializing built-in extension MIT-SHM
[ 23847.665] Initializing built-in extension XInputExtension
[ 23847.665] Initializing built-in extension XTEST
[ 23847.665] Initializing built-in extension BIG-REQUESTS
[ 23847.666] Initializing built-in extension SYNC
[ 23847.666] Initializing built-in extension XKEYBOARD
[ 23847.666] Initializing built-in extension XC-MISC
[ 23847.666] Initializing built-in extension XINERAMA
[ 23847.666] Initializing built-in extension XFIXES
[ 23847.666] Initializing built-in extension RENDER
[ 23847.666] Initializing built-in extension RANDR
[ 23847.666] Initializing built-in extension COMPOSITE
[ 23847.667] Initializing built-in extension DAMAGE
[ 23847.667] Initializing built-in extension MIT-SCREEN-SAVER
[ 23847.667] Initializing built-in extension DOUBLE-BUFFER
[ 23847.667] Initializing built-in extension RECORD
[ 23847.667] Initializing built-in extension DPMS
[ 23847.667] Initializing built-in extension X-Resource
[ 23847.667] Initializing built-in extension XVideo
[ 23847.668] Initializing built-in extension XVideo-MotionCompensation
[ 23847.668] Initializing built-in extension XFree86-VidModeExtension
[ 23847.668] Initializing built-in extension XFree86-DGA
[ 23847.668] Initializing built-in extension XFree86-DRI
[ 23847.668] Initializing built-in extension DRI2
[ 23847.668] (II) LoadModule: "glx"
[ 23847.671] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 23847.672] (II) Module glx: vendor="X.Org Foundation"
[ 23847.673]    compiled for 1.14.3, module version = 1.0.0
[ 23847.673]    ABI class: X.Org Server Extension, version 7.0
[ 23847.673] (==) AIGLX enabled
[ 23847.673] Loading extension GLX
[ 23847.673] (==) Matched modesetting as autoconfigured driver 0
[ 23847.674] (==) Matched fbdev as autoconfigured driver 1
[ 23847.674] (==) Assigned the driver to the xf86ConfigLayout
[ 23847.674] (II) LoadModule: "modesetting"
[ 23847.676] (WW) Warning, couldn't open module modesetting
[ 23847.676] (II) UnloadModule: "modesetting"
[ 23847.676] (II) Unloading modesetting
[ 23847.676] (EE) Failed to load module "modesetting" (module does not exist, 0)
[ 23847.676] (II) LoadModule: "fbdev"
[ 23847.678] (WW) Warning, couldn't open module fbdev
[ 23847.678] (II) UnloadModule: "fbdev"
[ 23847.678] (II) Unloading fbdev
[ 23847.678] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 23847.678] (EE) No drivers available.
[ 23847.678] (EE)
Fatal server error:
[ 23847.679] (EE) no screens found(EE)
[ 23847.679] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[ 23847.679] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 23847.679] (EE)
[ 23847.680] (EE) Server terminated with error (1). Closing log file.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sun Feb 23, 2014 1:42 pm    Post subject: Reply with quote

kaTiezei,

I use the frame buffer Xorg driver on my Pi.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
kaTiezei
n00b
n00b


Joined: 10 Mar 2013
Posts: 39

PostPosted: Sun Feb 23, 2014 5:10 pm    Post subject: Reply with quote

Ok, I have tried it, set
Code:
VIDEO_CARDS="fbdev"
,reemerged xorg-server, rebooted, but I get exactly the same error.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sun Feb 23, 2014 5:58 pm    Post subject: Reply with quote

kaTiezei,

Including
Code:
[ 23847.676] (II) LoadModule: "fbdev"
[ 23847.678] (WW) Warning, couldn't open module fbdev
[ 23847.678] (II) UnloadModule: "fbdev"

That means you don't have the driver built.

Code:
emerge xf86-video-fbdev -1av

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
kaTiezei
n00b
n00b


Joined: 10 Mar 2013
Posts: 39

PostPosted: Sun Feb 23, 2014 9:24 pm    Post subject: Reply with quote

Thank you, LXDE is running now. I assumed that fbdev would have been pulled automatically. I'd still like to know how to use the original driver.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sun Feb 23, 2014 9:33 pm    Post subject: Reply with quote

kaTiezei,

fbdev would have been build had you re emerged the drivers meta parkage.

Code:
x11-base/xorg-drivers-1.15  INPUT_DEVICES="evdev -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="fbdev nouveau nv nvidia radeon v4l vesa -apm -ast -chips -cirrus -dummy -epson -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic (-omap) (-omapfb) -qxl -r128 -radeonsi -rendition -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -via -virtualbox -vmware (-voodoo)" 0 kB


Notice that
Code:
 x11-base/xorg-server-1.15.0:0/1.15.0  USE="ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -unwind -xnest -xvfb" 0 kB
is not affected by VIDEO_CARDS= ...
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum