Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] USE flags for Intel video chipset
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fturco
Guru
Guru


Joined: 08 Dec 2010
Posts: 574
Location: Italy

PostPosted: Sat Feb 22, 2014 5:43 pm    Post subject: [SOLVED] USE flags for Intel video chipset Reply with quote

I have an Intel DQ35JO motherboard with an integrated video chipset. I set the VIDEO_CARDS variable to "intel" and it seems to work, but I wonder if it's better to set "i915" or "i965" in addition or in place of it. I read the related wiki article, but I still have doubts. And what about the "xorg" USE flag for mesa? equery uses mesa descriptions are not enough for me to understand.

Some additional informations:
Code:
# lspci
...
00:02.0 VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02)
...

Thank you.


Last edited by fturco on Thu Mar 20, 2014 2:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Sat Feb 22, 2014 8:44 pm    Post subject: Reply with quote

I don't think i915/i965 adds anything special...
I'm currently just using VIDEO_CARDS=intel and able to run WoW through wine just fine on my Sandybridge...
My Q45 board is kind of slow for WoW but I have it set the same way, but it also works.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fturco
Guru
Guru


Joined: 08 Dec 2010
Posts: 574
Location: Italy

PostPosted: Thu Mar 20, 2014 2:33 pm    Post subject: Reply with quote

I finally decided to set both "intel" and "i915" values in VIDEO_CARDS. "intel" is needed because otherwise x11-base/xorg-drivers won't depend on x11-drivers/xf86-video-intel. Package media-libs/mesa also accepts the following values: "i915" and "i965". If I don't specify any of them, mesa is built with both drivers. I discovered I need just the i915 driver. i965 doesn't work well with glxgears and glxinfo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum