Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201402-26 ] libssh: Arbitrary code execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Fri Feb 21, 2014 10:26 pm    Post subject: [ GLSA 201402-26 ] libssh: Arbitrary code execution Reply with quote

Gentoo Linux Security Advisory

Title: libssh: Arbitrary code execution (GLSA 201402-26)
Severity: normal
Exploitable: remote
Date: February 21, 2014
Bug(s): #444147
ID: 201402-26

Synopsis

Multiple vulnerabilities have been found in libssh, allowing
attackers to execute arbitrary code or cause Denial of Service.


Background

libssh is a C library providing SSHv2 and SSHv1.

Affected Packages

Package: net-libs/libssh
Vulnerable: < 0.5.3
Unaffected: >= 0.5.3
Architectures: All supported architectures


Description

Multiple buffer overflow, double free, and integer overflow
vulnerabilities have been discovered in libssh.


Impact

A remote attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All libssh users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libssh-0.5.3"
   


References

CVE-2012-4559
CVE-2012-4560
CVE-2012-4561
CVE-2012-4562
CVE-2012-6063
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum