Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PHP Warning: PHP Startup: Unable to load dynamic library
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
elmar283
Apprentice
Apprentice


Joined: 06 Dec 2004
Posts: 286
Location: Haarlem, Netherlands

PostPosted: Fri Feb 21, 2014 8:16 am    Post subject: PHP Warning: PHP Startup: Unable to load dynamic library Reply with quote

Today I noticed that php is giving a warning everytime I execute a php file. I don't know what is wrong. It has something to do with eaccelerator.so.
I don't have eaccelerator installed so no wonder it can't be found.

This is the error message:
Code:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5.3/lib/extensions/no-debug-non-zts-20090626/eaccelerator.so' - /usr/lib/php5.3/lib/extensions/no-debug-non-zts-20090626/eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5.3/lib/extensions/no-debug-non-zts-20090626/eaccelerator.so' - /usr/lib/php5.3/lib/extensions/no-debug-non-zts-20090626/eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0


I don't know what the relevant config files would be to fix this, so please tell, then I will post them.
Does anyone have clue what's wrong?
Back to top
View user's profile Send private message
hydrapolic
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2008
Posts: 124

PostPosted: Sat Mar 01, 2014 10:44 am    Post subject: Reply with quote

Check under /etc/php/cli* if it's not getting loaded somewhere. Something like:

# grep -ri eaccelerator /etc/php/*
Back to top
View user's profile Send private message
elmar283
Apprentice
Apprentice


Joined: 06 Dec 2004
Posts: 286
Location: Haarlem, Netherlands

PostPosted: Sun Mar 02, 2014 12:20 pm    Post subject: Reply with quote

Code:
elmarotter@ZaphodBeeblebrox ~ $  grep -ri eaccelerator /etc/php/*
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:extension=eaccelerator.so
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.filter=""
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/apache2-php5.3/ext-active/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:extension=eaccelerator.so
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.filter=""
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/apache2-php5.3/ext/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:extension=eaccelerator.so
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.filter=""
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/cgi-php5.3/ext-active/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:extension=eaccelerator.so
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.filter=""
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/cgi-php5.3/ext/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:extension=eaccelerator.so
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.filter=""
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/cli-php5.3/ext-active/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"
/etc/php/cli-php5.3/ext/eaccelerator.ini:extension=eaccelerator.so
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.shm_size="28"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.cache_dir="/var/cache/eaccelerator-php5/"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.enable="1"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.optimizer="1"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.debug="0"
/etc/php/cli-php5.3/ext/eaccelerator.ini:;eaccelerator.log_file="/var/log/eaccelerator_log"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.check_mtime="1"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.filter=""
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.shm_ttl="0"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.shm_prune_period="0"
/etc/php/cli-php5.3/ext/eaccelerator.ini:eaccelerator.shm_only="0"
/etc/php/cli-php5.3/ext/eaccelerator.ini:;eaccelerator.allowed_admin_path="/path/where/admin/files/shall/be/allowed"


Should I delete this? Or I can remove php5.3 and reinstall?
Back to top
View user's profile Send private message
hydrapolic
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2008
Posts: 124

PostPosted: Mon Mar 03, 2014 7:26 am    Post subject: Reply with quote

Either install dev-php/eaccelerator or remove the configurations.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum