Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fresh Gnome 3.10 install - several (PAM related?) problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MichaelM
n00b
n00b


Joined: 20 Feb 2014
Posts: 5

PostPosted: Thu Feb 20, 2014 9:23 pm    Post subject: Fresh Gnome 3.10 install - several (PAM related?) problems Reply with quote

I treated my computer to a fresh Gentoo install. I'm using the Gnome/systemd profile and everything besides Gnome works. I tried tackling the errors one by one and upgraded several packages in the process ("maybe the problem is fixed in the new version") so now i have the following packages installed:
Code:
[ebuild   R    ] sys-apps/systemd-208-r2:0/1  USE="acl cryptsetup filecaps firmware-loader gudev introspection kmod pam policykit tcpd xattr -audit -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla" ABI_X86="(64) (-32) (-x32)"  PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild   R   ~] gnome-base/gnome-3.10.0:2.0  USE="cdr classic cups -accessibility -bluetooth -extras" 0 kB
[ebuild   R   ~] gnome-base/gdm-3.10.0.1  USE="branding introspection ipv6 systemd tcpd -accessibility -audit -debug -fprint -plymouth (-selinux) -smartcard {-test} -xinerama" 0 kB
[ebuild   R   ~] gnome-base/gnome-keyring-3.10.1  USE="caps filecaps pam -debug (-selinux) {-test}" 0 kB
[ebuild   R    ] sys-auth/pambase-20120417-r3  USE="cracklib gnome-keyring sha512 systemd (-consolekit) -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild   R   ~] sys-libs/pam-1.1.8  USE="berkdb cracklib nls vim-syntax -audit -debug -nis (-selinux) {-test}" 0 kB
[ebuild   R   ~] sys-apps/dbus-1.8.0  USE="X systemd -debug -doc (-selinux) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 kB

I tried some modifications to the PAM files in /etc/pam.d i found on the Google but none of them solved my problems so I'm back to the original files provided by the packages.

    [1]Starting gdm produces the following log message:
    Code:
    gdm-launch-environment][710]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring

    When I log in and out again and check loginctl in the terminal the user session still exists and ps shows running processes for that user. Everytime I log in again a new session is created + an error message that pulseaudio is already running.
    Also restarting gdm creates a new session for gdm and sometimes but not always kills the leftover user sessions. Neither upgrading GDM nor PAM helped. Any sugestions?

    [2] I'm not sure if this is related but i found so word "session" in the log message so it might be :-)
    Code:
    org.a11y.Bus[719]: Activating service name='org.a11y.atspi.Registry'
    org.a11y.Bus[719]: Successfully activated service 'org.a11y.atspi.Registry'
    org.a11y.atspi.Registry[726]: ** (at-spi2-registryd:729): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    org.a11y.atspi.Registry[726]: ** (at-spi2-registryd:729): WARNING **: Unable to register client with session manager

    [3]After logging in I get the warning from 2) again (different PID) and the following errors:
    Code:
    gnome-keyring-daemon[952]: Gck: gck_module_new: assertion 'funcs != NULL' failed
    gnome-keyring-daemon[952]: module_instances: assertion 'module' failed
    gnome-keyring-daemon[952]: egg_error_message: assertion 'error' failed
    gnome-keyring-daemon[952]: couldn't find secret store module: (unknown)
    gnome-keyring-daemon[952]: lookup_login_keyring: assertion 'GCK_IS_SESSION (session)' failed
    gnome-keyring-daemon[952]: create_credential: assertion 'GCK_IS_SESSION (session)' failed
    gnome-keyring-daemon[952]: egg_error_message: assertion 'error' failed
    gnome-keyring-daemon[952]: couldn't create login credential: (unknown)
    gdm-password][943]: gkr-pam: the password for the login keyring was invalid.

    When i check with Seahorse the keyring is obviously unlocked :-)

I could "solve" these problems by not reading the systemlog, But one of the reasons I installed Gentoo was that I want to learn more about what my computer is doing. I hope someone has some tips or can point me in the right direction. Please let me know if you need more infos / logs / emerge info / etc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum