Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia Optimus and X server configuration still failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Subtext
n00b
n00b


Joined: 18 Feb 2014
Posts: 3

PostPosted: Tue Feb 18, 2014 9:11 am    Post subject: Nvidia Optimus and X server configuration still failing Reply with quote

Hello everyone,

in my laptop I have an optimus setup. When trying to start the x-server without using a xorg.conf, everything works more or less fine - of course, just the intel card is recognized. (xrandr just lists intel as a provider)
When I try setting up the xorg.conf according to a lot of websites dealing with the same issue, I can't get the x-server to run.
I get the following message: Screen 0 deleted because of no matching config section.

The Xorg.0.log:
http://paste.org.ru/?qd3uwn

My xorg.conf:
http://paste.org.ru/?700nrc

lspci output:
http://paste.org.ru/?mlb5cj

lsmod output:
http://paste.org.ru/?djvuvv

Setting in make.conf
VIDEO_CARDS="nvidia intel modesetting"

I already tried running nvidia-xconfig and uncommenting Option "UseDisplayDevice" "None" but to no avail, searching the internet up to now wasn't successful either.
I hope it just is a trivial issue where I am just missing something but still - help would be really appreciated :)

Thank you very much in advance!


Last edited by Subtext on Tue Feb 18, 2014 1:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Feb 18, 2014 10:02 am    Post subject: Reply with quote

Are you sure you don't want intel driver for intel ?
Also, are you sure BusID is correct for the card ?
Back to top
View user's profile Send private message
Subtext
n00b
n00b


Joined: 18 Feb 2014
Posts: 3

PostPosted: Tue Feb 18, 2014 1:19 pm    Post subject: Reply with quote

VoidMage wrote:
Are you sure you don't want intel driver for intel ?
Also, are you sure BusID is correct for the card ?


If I understood correctly I need to use modesetting in order to be able to utilize the concept of using the intel card as "sink" for the nvidia card. I took the xorg.conf I wrote directly from this site: http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html

Also I am pretty sure the BusID is correct unless I made a spelling mistake in the xorg.conf I am not aware about right now (I can't review the files right now as I am at work now and paste.ru is blocked here)

I also think the intel driver is installed correctly as I am able to use the x-server without problems when I delete the xorg.conf. But if I do that, the x-server will only use the intel card.
Back to top
View user's profile Send private message
phnx12
n00b
n00b


Joined: 07 Oct 2013
Posts: 12

PostPosted: Wed Feb 19, 2014 12:01 am    Post subject: Working configuration Reply with quote

Hi,
I have laptop with optimus. all working well. I end with this configuration is needed:

I have also a switch script witch does switch the nvidia - intel GPU for powersave - PM if you want it.

This is my xorg.conf
Code:

Section "ServerLayout"                                                                                                                                                                                                                                                         
    Identifier "layout"                                                                                                                                                                                                                                                       
    Screen 0 "nvidia"                                                                                                                                                                                                                                                         
    Inactive "intel"                                                                                                                                                                                                                                                           
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Device"                                                                                                                                                                                                                                                               
    Identifier "nvidia"                                                                                                                                                                                                                                                       
    Driver "nvidia"                                                                                                                                                                                                                                                           
    BusID "PCI:1:0:0"                                                                                                                                                                                                                                                         
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Screen"                                                                                                                                                                                                                                                               
    Identifier "nvidia"                                                                                                                                                                                                                                                       
    Device "nvidia"                                                                                                                                                                                                                                                           
    # Uncomment this line if your computer has no display devices connected to                                                                                                                                                                                                 
    # the NVIDIA GPU.  Leave it commented if you have display devices                                                                                                                                                                                                         
    # connected to the NVIDIA GPU that you would like to use.                                                                                                                                                                                                                 
    Option "UseDisplayDevice" "none"                                                                                                                                                                                                                                           
    Option "IgnoreEDID" "1"                                                                                                                                                                                                                                                   
    #Option "AllowEmptyInitialConfiguration"                                                                                                                                                                                                                                   
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Device"                                                                                                                                                                                                                                                               
    Identifier "intel"                                                                                                                                                                                                                                                         
    Driver "modesetting"                                                                                                                                                                                                                                                       
    BusID "PCI:0:2:0"                                                                                                                                                                                                                                                         
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Screen"                                                                                                                                                                                                                                                               
    Identifier "intel"
    Device "intel"
EndSection


and my /usr/share/config/kdm/Xsetup
Code:

#! /bin/sh
# Xsetup - run as root before the login dialog appears

if [[ "$( head -1 /root/nvidia)" == "1" ]]; then
    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto
fi


Hope it helps.
Back to top
View user's profile Send private message
Subtext
n00b
n00b


Joined: 18 Feb 2014
Posts: 3

PostPosted: Wed Feb 19, 2014 4:15 pm    Post subject: Reply with quote

Hello,

I have tried the proposed solutions but those weren't successful. The problem still persists with the same error message. I think the problem lies within x.org and not the driver.

Solutions tried:

- xorg.conf from phnx12 (I put the xrandr commands in the xinit file but the effect should be the same - anyway, since I can't start the x-server I can't use xrandr anyway)
- exchanging modesetting driver for intel driver
- rechecking the BusID and adding the BusID for the Intel card.

Any other ideas maybe? :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum