Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Is there a way to install webkit-gtk without ruby?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
xoma
n00b
n00b


Joined: 29 Oct 2013
Posts: 7

PostPosted: Mon Feb 17, 2014 10:45 pm    Post subject: Is there a way to install webkit-gtk without ruby? Reply with quote

The web browser I currently use is dwb. I decided I want to try using it with the gtk3 version of webkit. However unlike the gtk2 version of webkit it requires the use of Ruby. Is there a way to use it without having to install Ruby?

Here's "emerge --pretend dwb":

Code:
[ebuild  N     ] dev-libs/libyaml-0.1.5  USE="-doc -examples -static-libs {-test}"
[ebuild  N     ] app-admin/eselect-ruby-20100603
[ebuild  N     ] dev-lang/ruby-1.8.7_p374  USE="berkdb gdbm ncurses readline ssl threads -debug -doc -examples -ipv6 -libedit -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax"
[ebuild  N     ] dev-lang/ruby-2.0.0_p353  USE="berkdb gdbm ncurses rdoc readline ssl -debug -doc -examples -ipv6 -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-lang/ruby-1.9.3_p484  USE="berkdb gdbm ncurses rdoc readline ssl yaml -debug -doc -examples -ipv6 -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-ruby/rubygems-2.0.3  USE="-server {-test}" RUBY_TARGETS="ruby18 ruby19 ruby20 -jruby"
[ebuild  N     ] virtual/rubygems-6  RUBY_TARGETS="(ruby20)"
[ebuild  N     ] virtual/rubygems-4  RUBY_TARGETS="(ruby19)"
[ebuild  N     ] virtual/rubygems-1  RUBY_TARGETS="(ruby18)"
[ebuild  N     ] dev-ruby/rake-0.9.6  USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 ruby20 -jruby"
[ebuild  N     ] dev-ruby/json-1.8.0  USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 ruby20 -jruby"
[ebuild  N     ] dev-ruby/racc-1.4.9  USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 ruby20 -jruby"
[ebuild  N     ] dev-ruby/rdoc-4.0.1-r1  USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 ruby20 -jruby"
[ebuild   R    ] media-libs/harfbuzz-0.9.23  USE="icu*"
[ebuild  N     ] media-libs/freeglut-2.8.1  USE="-debug -static-libs"
[ebuild  N     ] media-libs/libwebp-0.3.1  USE="jpeg opengl png -experimental -gif -static-libs -swap-16bit-csp -tiff"
[ebuild  NS    ] media-libs/gstreamer-1.0.10 [0.10.36] USE="nls orc -introspection {-test}"
[ebuild  NS    ] media-libs/gst-plugins-base-1.0.10 [0.10.36] USE="X alsa nls ogg orc pango theora vorbis -introspection -ivorbis"
[ebuild  NS    ] net-libs/webkit-gtk-2.0.4 [1.8.3-r201] USE="gstreamer jit spell webgl (-aqua) -coverage -debug -geoloc -introspection -libsecret {-test}"
[ebuild   R   ~] www-client/dwb-2013.03.30  USE="gtk3*"
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Feb 17, 2014 10:56 pm    Post subject: Reply with quote

webkit-gtk-1.x (as you can tell yourself), hasn't that requisite.

So, I'd say USE="-gtk3" and see if that helps.

But if you want gtk3 I don't think you can do anything, other than hacking the webkit-gtk-2.x ebuild. I have no idea if it's the ebuild which enforces ruby or if it's webkit-gtk-2.x at source level, in which case I wish you good luck trying to strip it off.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3694
Location: Dallas area

PostPosted: Mon Feb 17, 2014 11:08 pm    Post subject: Reply with quote

I suppose you could mask the 2.0.4 package, it only needs >= 1.8.3 whether gtk2 or gtk3
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Mon Feb 17, 2014 11:47 pm    Post subject: Reply with quote

There was another thread about webkit-gtk and Ruby within the last few weeks. In that thread, another poster stated that webkit-gtk upstream had changed their build process to run Ruby scripts as part of the build. Building affected versions of webkit-gtk requires ruby, but running them does not.
Back to top
View user's profile Send private message
sigra
n00b
n00b


Joined: 03 Feb 2006
Posts: 73

PostPosted: Tue Jan 20, 2015 7:07 am    Post subject: Reply with quote

https://bugs.webkit.org/show_bug.cgi?id=114560
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Jan 20, 2015 9:22 am    Post subject: Reply with quote

sigra wrote:
https://bugs.webkit.org/show_bug.cgi?id=114560

Martin Robinson wrote:
Sorry. No. A change of this magnitude requires something more than personal preference and to affect more than those building WebKit.

boggles ... a build time dependency will "affect" [sic] those not building webkit?

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum