Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/usr/lib/dri/i965_dri.so not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Gentooya
n00b
n00b


Joined: 15 Nov 2013
Posts: 26

PostPosted: Mon Feb 17, 2014 8:24 am    Post subject: /usr/lib/dri/i965_dri.so not found Reply with quote

Hi I've got a problem starting the graphics on my system. In my Xorg.0.log I can see this error:

[AIGLX]: error dlopen of /usr/lib/dri/i965_dri.so failed: no such file or directory
[GLX]: could not load software renderer

I'm using the x11-drivers/xf86-video-intel driver, I have a system with Intel integrated graphics. I have tried to reinstall all related x11 packages, but those libraries seem to be missing.

When I do eselect mesa list, then I get an error saying "Can't load mesa module".

Can anyone tell me where I can find the missing i965_dri.so library? Is that in a standard package? I'm building my x11 packages with USE flag "dri" switched on. Is it possible that my package is too old for supporting DRI?

Any pointers are greatly appreciated!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Feb 17, 2014 9:15 am    Post subject: Reply with quote

What is VIDEO_CARDS set to ? Check 'emerge -1pv mesa' output.
Back to top
View user's profile Send private message
Gentooya
n00b
n00b


Joined: 15 Nov 2013
Posts: 26

PostPosted: Mon Feb 17, 2014 10:06 am    Post subject: Reply with quote

VIDEO_CARDS="intel i965"

( I have tried both cards individually as well but didn't make any difference! )

Here the log for emerge mesa

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[binary R ] media-libs/mesa-7.11.2 USE="(nptl) (pax_kernel) (pic) (video_cards_intel) -bindist -classic -debug -egl -gallium -gbm -gles (-kernel_FreeBSD) -llvm -motif -openvg -osmesa (-selinux) -shared-dricore -shared-glapi -video_cards_mach64 -video_cards_mga -video_cards_nouveau -video_cards_r128 -video_cards_radeon -video_cards_savage -video_cards_sis -video_cards_tdfx -video_cards_via -video_cards_vmware" 0 kB

Total: 1 package (1 reinstall, 1 binary), Size of downloads: 0 kB

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
Back to top
View user's profile Send private message
Gentooya
n00b
n00b


Joined: 15 Nov 2013
Posts: 26

PostPosted: Tue Feb 18, 2014 6:40 am    Post subject: Reply with quote

No one can help with this?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Feb 18, 2014 9:52 am    Post subject: Reply with quote

Well, for one, your mesa looks a bit old.
Also, it doesn't seem to contain video_cards-i965 set.
Perhaps it was a binary merge from a wrong machine ?
Back to top
View user's profile Send private message
Gentooya
n00b
n00b


Joined: 15 Nov 2013
Posts: 26

PostPosted: Tue Feb 18, 2014 10:01 am    Post subject: Reply with quote

But shouldn't video_cards_intel be sufficient?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Feb 18, 2014 2:41 pm    Post subject: Reply with quote

Let me rephrase it: what's in /usr/lib/dri/ ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum