Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Disable EDID and use non-standard resolution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
StevePER
n00b
n00b


Joined: 28 Jan 2004
Posts: 50
Location: Perth, Australia

PostPosted: Sun Feb 16, 2014 2:00 pm    Post subject: [SOLVED] Disable EDID and use non-standard resolution Reply with quote

I have a laptop in my car connected to a 7" touchscreen with a native resolution of 800x480. In my xorg.conf I use a modeline entry to set this video mode. After upgrading X and the Intel driver, it no longer uses 800x480 as the default resolution on startup. If I run the command:
Code:
xrandr --output VGA1 --auto
it reverts to 800x480. But it isn't very practical to type this in while I'm driving. :)

How do I disable EDID modes or force it to use my preferred resolution? I've tried options "PreferredMode", "IgnoreEDID", "UseEDID", and "DDC" but Xorg.0.log shows that none of these options are valid for the Intel driver (xf86-video-intel version 2.21.15), despite some of these being mentioned in the documentation from Intel.

(Normally I would include details from xorg.conf etc but it is difficult for me to copy them off the laptop... but I can get them if it's really necessary.)

Thanks,
Steve


Last edited by StevePER on Tue Feb 18, 2014 2:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Feb 16, 2014 8:30 pm    Post subject: Reply with quote

I have this in the Monitor section for my old Dell Trinitron (which I don't use any more, hmm) followed by the HorizSync, VertRefresh, and so on (eg DPMS, DPI), then the ModeLines and Option "PreferredMode". It gives dud EDID info, so I have to supply it manually.
Code:
Option       "UseEDID" "false"
# despite above we get:
# Using HorizSync/VertRefresh ranges from the EDID
# (Using EDID frequencies has been enabled on all display devices.)
Option       "UseEDIDFreqs" "false"

So latter option proved necessary, even when I turned off EDID in the Device or ServerLayout sections (tried last in desperation, before I got the above to work.) Using nvidia, but no EDID stanzas anywhere else in the file (I just use an old-style /etc/X11/xorg.conf as it's simpler. I do have other stuff for mouse in one of those new-style directories, but can't remember where.)

HTH,
steveL.
Back to top
View user's profile Send private message
StevePER
n00b
n00b


Joined: 28 Jan 2004
Posts: 50
Location: Perth, Australia

PostPosted: Mon Feb 17, 2014 12:03 am    Post subject: Reply with quote

I think my problem is slightly different because the EDID information is valid (in terms for frequencies), it just doesn't give the resolution I want.

I tried all those options in the Monitor section but the Intel driver ignores them. I'll copy in some of the Xorg log and xorg.conf. I haven't specified the refresh rates in xorg.conf because I don't know what they are. I only have the modeline.

Code:

[    90.038] (--) intel(0): Integrated Graphics Chipset: Intel(R) 945GME
[    90.039] (--) intel(0): CPU: x86, sse2, sse3, ssse3
[    90.039] (**) intel(0): Framebuffer tiled
[    90.039] (**) intel(0): Pixmaps tiled
[    90.039] (**) intel(0): "Tear free" disabled
[    90.039] (**) intel(0): Forcing per-crtc-pixmaps? no
[    90.039] (II) intel(0): Output LVDS1 using monitor section Built-in Monitor
[    90.039] (**) intel(0): Option "Disable" "yes"
[    90.040] (--) intel(0): found backlight control interface acpi_video0 (type 'firmware')
[    90.040] (II) intel(0): Output VGA1 using monitor section Touchscreen
[    90.040] (**) intel(0): Option "PreferredMode" "800x480"
[    90.040] (--) intel(0): Output VGA1 using initial mode 1920x1200 on pipe 0
[    90.040] (==) intel(0): DPI set to (96, 96)
[    90.040] (II) Loading sub module "dri2"
[    90.040] (II) LoadModule: "dri2"
[    90.040] (II) Module "dri2" already built-in
[    90.040] (==) Depth 24 pixmap format is 32 bpp
[    90.066] (II) intel(0): SNA initialized with Alviso (gen3) backend
[    90.066] (==) intel(0): Backing store disabled
[    90.066] (==) intel(0): Silken mouse enabled
[    90.066] (II) intel(0): HW Cursor enabled
[    90.066] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    90.084] (==) intel(0): DPMS enabled
[    90.086] (II) intel(0): [DRI2] Setup complete
[    90.086] (II) intel(0): [DRI2]   DRI driver: i915
[    90.086] (II) intel(0): direct rendering: DRI2 Enabled
[    90.086] (WW) intel(0): Option "PreferredMode" is not used
[    90.086] (WW) intel(0): Option "DDC" is not used
[    90.086] (WW) intel(0): Option "UseEDID" is not used
[    90.086] (WW) intel(0): Option "UseEDIDFreqs" is not used
[    90.086] (WW) intel(0): Option "IgnoreEDID" is not used
[    90.087] (==) intel(0): hotplug detection: "enabled"


Here is my xorg.conf, excluding sections related to input devices.

Code:

# This monitor is disabled.
Section "Monitor"
   Identifier   "Built-in Monitor"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   Option        "Disable" "yes"
EndSection

Section "Monitor"
   Identifier   "Touchscreen"
   VendorName   "Mini Touch"
   ModelName    "Mini Touch 700"
   Modeline "800x480" 31.746 800 864 944 1000 480 508 511 525 -hsync -vsync
   Option "PreferredMode" "800x480"
   Option "DDC" "false"
   Option "UseEDID" "false"
   Option "UseEDIDFreqs" "false"
   Option "IgnoreEDID" "true"
EndSection

Section "Device"
   Identifier  "Intel 945GME"
   Driver      "intel"
   BusID       "PCI:0:2:0"
   Option      "monitor-VGA1" "Touchscreen"
   Option      "monitor-LVDS1" "Built-in Monitor"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Intel 945GME"
   Monitor    "Touchscreen"
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes "800x480"
   EndSubSection
EndSection


xrandr output:
Code:

Screen 1: minimum 320 x 200, current 1920 x 1200, maximum 32767 x 32767
LVDS1 connected (normal left inverted right x axis y axis)
   1024x600       60.0 +
   800x600        60.3     56.2 
   640x480        59.9 
VGA1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 519mm x 324mm
   800x480        60.5 +
   1920x1200      60.0*+
   1600x1200      60.0 
   1680x1050      60.0 
   1280x1024      75.0     60.0 
   1152x864       75.0 
   1024x768       75.1     60.0 
   800x600        75.0     60.3 
   640x480        75.0     60.0 
   720x400        70.1 
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5594

PostPosted: Mon Feb 17, 2014 4:47 pm    Post subject: Reply with quote

I've had similar problems getting the DRM modesetting stuff to do what I wanted - I have a cheap "HDTV" that's actually a 1680x1050 panel with a broken EDID.

I got it working by telling *both* the kernel and X to force the mode; this is what it looks like for me:
/etc/lilo.conf:
append="video=HDMI-A-1:1680x1050M@60"

/etc/xorg.conf.d/force-res.conf:
Section "Monitor"
    Identifier "HDMI-0"
    DisplaySize 470 300
    # 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
    Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    Option "PreferredMode" "1680x1050_60.00"
EndSection

That modeline comes from $(cvt 1680 1050 60). I ended up not using any of the DDC/EDID options, they don't seem to have any effect. Also beware of X/kernel naming being different, you can figure out what the kernel calls it using $(ls /sys/class/drm).
Back to top
View user's profile Send private message
StevePER
n00b
n00b


Joined: 28 Jan 2004
Posts: 50
Location: Perth, Australia

PostPosted: Tue Feb 18, 2014 8:06 am    Post subject: Reply with quote

That seems like an excellent clue - I will investigate the kernel options. Hopefully I don't have to create my own EDID file.
Back to top
View user's profile Send private message
StevePER
n00b
n00b


Joined: 28 Jan 2004
Posts: 50
Location: Perth, Australia

PostPosted: Tue Feb 18, 2014 2:26 pm    Post subject: Reply with quote

Fixed by adding the following to my boot options: Thanks Ant P.

Code:
video=VGA-1:800x480M@60


Unfortunately this only works with my touchscreen, and not on my PC monitor, but that's not a major issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum