Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
What does thunar uses to mount devices?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Feb 14, 2014 12:56 am    Post subject: What does thunar uses to mount devices? Reply with quote

I am with the same problem as before but now with i3 window manager. I have the exact same setup and I am using thunar as my file manager, however the devices don't show up.

My .xinitrc:
Code:
numlockx &
#startxfce4 --with-ck-launch
exec i3


udisks is running:
Code:
╰─○ ps -A | grep udisks
16615 ?        00:00:00 udisksd
17191 ?        00:00:00 gvfs-udisks2-vo


groups:
Code:
groups
wheel audio cdrom video cdrw usb users portage pedro


I have udev and thunar-volman installed, I can still mount it on XFCE. What service does XFCE starts? What should I change?
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Feb 14, 2014 1:01 am    Post subject: Reply with quote

thunar uses gvfs.... pay attention to gvfs use flags as that will determine much.
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Feb 14, 2014 8:12 am    Post subject: Reply with quote

But I have gvfs running, why isn't it working?
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Feb 14, 2014 8:35 am    Post subject: Reply with quote

it probably needs to be rebuilt with the use flags changed... it probably has the use turned off for what you're trying to support, or file system is not compiled into your kernel. usb dev might be fat32 / ntfs, cd rom is like iso something in the kernel you'll need to enable them for sure. much past having that in order, and everything else from previous thread in order idk.... seems like plugdev group is for anything with a plug besides power.

Last edited by 666threesixes666 on Fri Feb 14, 2014 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 324
Location: /home

PostPosted: Fri Feb 14, 2014 10:40 am    Post subject: Reply with quote

I had to issue ck-launch-session in my .xinitrc for openbox. I also use Thunar and it automounts fine now,
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session openbox-session


I also had to dig in to /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy and change
Code:
  <action id="org.freedesktop.udisks2.filesystem-mount">
    <description>Mount a filesystem</description>
    <description xml:lang="en_GB">Mount a filesystem</description>
    <description xml:lang="fi">Liitä tiedostojärjestelmä</description>
    <message>Authentication is required to mount the filesystem</message>
    <message xml:lang="en_GB">Authentication is required to mount the filesystem</message>
    <message xml:lang="fi">Tunnistautuminen vaaditaan tiedostojärjestelmän liittämistä varten</message>
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>


This part, maybe some other. Default is
Code:
<allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin_keep</allow_active>


where you change auth_admin into yes.

But if it works just right in XFce, maybe you just have to put exec ck-launch-session dbus-launch --sh-syntax --exit-with-session i3 in your .xinitrc?
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Feb 14, 2014 4:09 pm    Post subject: Reply with quote

I tried putting that into my .xinitrc and the drivers show up but I can't mount them (it says I am not authorized). Maybe your solution works.
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Feb 14, 2014 5:08 pm    Post subject: Reply with quote

My .xinitrc
Code:
exec ck-launch-session dbus-launch --exit-with-session i3


My modified /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy and change
Code:
<action id="org.freedesktop.udisks2.filesystem-mount">
    <description>Mount a filesystem</description>
    <description xml:lang="pt_BR">Montar um sistema de arquivos</description>
    <message>Authentication is required to mount the filesystem</message>
    <message xml:lang="pt_BR">Autenticação é necessária para montar um sistema de arquivos</message>
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

 
  <action id="org.freedesktop.udisks2.filesystem-mount-system">
    <description>Mount a filesystem on a system device</description>
    <description xml:lang="pt_BR">Montar um sistema de arquivos em um dispositivo de sistemas</description>
    <message>Authentication is required to mount the filesystem</message>
    <message xml:lang="pt_BR">Autenticação é necessária para montar um sistema de arquivos</message>
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>


Harddisks are working but can't mount DVDs :( they don't even show up
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Feb 17, 2014 1:13 pm    Post subject: Reply with quote

You could as well emerge xfce with USE="-thunar -udev -udisks -consolekit -policykit", and then emerge spacefm instead of thunar, and manage your disks using udevil and/or pmount.

If that alternative appeals you and you need some pointers just ask.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum