Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
what do I need to play TS (DTV) files?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
szatox
l33t
l33t


Joined: 27 Aug 2013
Posts: 619

PostPosted: Wed Feb 12, 2014 12:18 pm    Post subject: what do I need to play TS (DTV) files? Reply with quote

I'm trying to find a way to play TS files dumped with TV by Funai. Unfortunately neither mplayer nor vlc want to do the job, even though the tv itself plays those just fine.
Output from a few seconds worth of sample:

Code:

$ file X.ts
X.ts: data


$ mplayer X.ts
MPlayer 1.1-4.7.3 (C) 2000-2012 MPlayer Team

Playing X.ts.
libavformat version 54.29.104 (external)
TS file format detected.
TS_PARSE: COULDN'T SYNC
NO VIDEO! NO AUDIO! (try increasing -tsprobe) NO SUBS (yet)!
No stream found.


Exiting... (End of file)


$ emerge --info -v mplayer
---/ snip /---

media-video/mplayer-1.1.1-r1 was built with the following:
USE="3dnow 3dnowext X a52 alsa cdio dts dv dvb dvd dvdnav enca encode faad gif iconv ipv6 jpeg jpeg2k libass live mad mmx mmxext mng mp3 (multilib) network opengl osdmenu png quicktime rar rtc sdl shm speex sse sse2 theora toolame tremor truetype twolame unicode v4l vorbis x264 xscreensaver xv xvid -aalib (-altivec) (-aqua) -bidi -bindist -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dxr3 -faac -fbcon -ftp -ggi -gsm -jack -joystick -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -nas -nut -openal -oss -pnm -pulseaudio -pvr -radio -rtmp -samba -ssse3 -tga -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" ABI_X86="64" VIDEO_CARDS="-mga -s3virge -tdfx"

increasing tsprobe value doesn't help.
since there is no way to record anything provided over analogue signal with that particular tv, I suppose it simply writes the digital stream down as it comes from provider.
I've found out vlc should be compiled with dvbpsi use flag, which is active in my case, but it doesn't play either.
Any ideas how to fix it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum