Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] MATE, polkit and Shutdown menu voice missing
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 05 Feb 2014
Posts: 94

PostPosted: Wed Feb 05, 2014 3:27 pm    Post subject: [SOLVED] MATE, polkit and Shutdown menu voice missing Reply with quote

Hi! I'm new here. I've used Gentoo for some months and I found it great! :D but now I've got a problem: after the last upgrade of MATE I noticed (as I already say in the title ;) ) that the Shutdown voice in the MATE menu is disappeared. Now, I use to make lot of mods at one time (I modified some USE Flags, rebuilt kernel for making it thinner than before and some others), so I can't understand what's the problem. Somebody has some brilliant ideas :P ? Here I left to you some more informations on my machine:

emerge --infonf
Portage 2.2.8-r1 (default/linux/x86/13.0/desktop, gcc-4.8.2, glibc-2.18-r1, 3.13.0-geek i686)
System uname: Linux-3.13.0-geek-i686-Intel-R-_Atom-TM-_CPU_N450_@_1.66GHz-with-gentoo-2.2
KiB Mem:     1015948 total,     99136 free
KiB Swap:    1991676 total,   1942664 free
Timestamp of tree: Thu, 06 Feb 2014 07:30:01 +0000
ld ld di GNU (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8-r1::init6
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: mate-overlay init6 paddymac gentoo
CFLAGS="-O2 -march=atom -mtune=atom -mfpmath=sse -msse3 -mmmx -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=atom -mtune=atom -mfpmath=sse -msse3 -mmmx -fomit-frame-pointer"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs ccache compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=atom -mtune=atom -mfpmath=sse -msse3 -mmmx -fomit-frame-pointer"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/mate /var/lib/layman/init6 /var/lib/layman/paddymac /usr/portage"
USE="X a52 aac acl acpi alsa avcodec bash-completion berkdb bluetooth branding bzip2 cairo calendar cdda cdr cli cracklib crypt cups curl curlwrappers cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran gcj gdbm gif git gpm gstreamer gtk gzip iconv imagemagick imap introspection ipv6 java javascript jit jpeg jpeg2k lame lcms ldap libffi libnotify lz4 lzma lzo mad matroska minizip mmx mng modules mp3 mp4 mpeg ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit pop3 posix ppds qt3support qt4 quicktime rar readline sasl sdl session smtp spell sqlite sse sse2 sse3 ssl startup-notification svg tcpd threads tiff timidity truetype udev udisks unicode upower usb v4l vorbis wifi wma-fixed wxwidgets x264 x86 xcb xml xscreensaver xv xvid xz zip zlib" ABI_X86="32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev mouse keyboard synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport wiki-publisher" LINGUAS="en en_GB en_US it it_IT" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

If you need something else, no problem. Just ask ;)

Last edited by loxdegio on Mon Feb 10, 2014 6:00 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 12 Dec 2003
Posts: 26
Location: Germany

PostPosted: Fri Feb 07, 2014 6:42 pm    Post subject: Reply with quote

glib-2.38 broke consolekit, so you have to downgrade it and every related package.

This is my mask file

Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 05 Feb 2014
Posts: 94

PostPosted: Sat Feb 08, 2014 8:46 am    Post subject: Reply with quote

Thank you so much. :D I'll apply your mods and try, if them works also for me I'll put the tag [SOLVED]. Thank you again
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 05 Feb 2014
Posts: 94

PostPosted: Mon Feb 10, 2014 6:01 pm    Post subject: Reply with quote

Good news: I solved my problem switching to systemd as init without masking any package :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum