Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Audacity trouble - can't use temp dir, segfaults
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Wintershade
n00b
n00b


Joined: 21 Jul 2007
Posts: 29
Location: Croatia

PostPosted: Mon Feb 10, 2014 2:28 pm    Post subject: [SOLVED] Audacity trouble - can't use temp dir, segfaults Reply with quote

Hello everyone.

I'm having trouble with Audacity; both amd64 and ~amd64 version (currently =media-sound/audacity-2.0.2 and =media-sound/audacity-2.0.5).
When I try to run it, I get an error message, saying that "Audacity could not find a place to store temporary files" (screenshot).
After clicking OK, the program segfaults. There is no useful terminal output, it just says "Segmentation fault".

I've put the output of emerge --info media-sound/audacity in the pastebin.
Also, the same thing happens with =media-sound/audacity-2.0.0. I even tried recompiling it, together with the entire dependency tree (emerge -e audacity), but to no avail.


Can anyone help me with this? Without this particular application I feel a bit stranded, i.e. I need it to do my job again.
Thanks in advance! :)
_________________
Only the best is good enough.

My make.conf file


Last edited by Wintershade on Tue Feb 11, 2014 3:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5362

PostPosted: Tue Feb 11, 2014 3:28 pm    Post subject: Reply with quote

Audacity stores temporary files in /var/tmp by default. What does

Code:

ls -lah /var/tmp


show you?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees
Back to top
View user's profile Send private message
Wintershade
n00b
n00b


Joined: 21 Jul 2007
Posts: 29
Location: Croatia

PostPosted: Tue Feb 11, 2014 3:33 pm    Post subject: Reply with quote

There was an "audacity-wintershade" dir in the /var/tmp, and I just deleted it.
After that, Audacity loads with no trouble.

Thank you very much!
_________________
Only the best is good enough.

My make.conf file
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5362

PostPosted: Fri Feb 14, 2014 2:57 am    Post subject: Reply with quote

Yeah, sometimes clearing out old cruft does the trick.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum