Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Remote: suspend/resume only once ; crashes at 2nd resume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
lexflex
Apprentice
Apprentice


Joined: 05 Mar 2006
Posts: 256
Location: the Netherlands

PostPosted: Tue Apr 15, 2014 10:04 am    Post subject: Remote: suspend/resume only once ; crashes at 2nd resume Reply with quote

Hi,

For my htpc i use an MCE remote, but I can suspend (using pm-suspend) and resume successfully only once.

After waking it up using the remote following the first suspend the system functions.
Suspending again, and at resume the system crashes: It does react, but stops responding and shows only a black screen ( _ in the topleft corner, no further response).

The remote is at /sys/class/rc/rc0 after boot. However, after the first resume it is at rc1.

Code:

HTPC2014 alex # cat /sys/class/rc/rc0/protocols
rc-5 rc-6 rc-5-sz mce_kbd [lirc]
HTPC2014 alex # pm-suspend
HTPC2014 alex # cat /sys/class/rc/rc0/protocols
cat: /sys/class/rc/rc0/protocols: No such file or directory
HTPC2014 alex # cat /sys/class/rc/rc1/protocols
rc-5 rc-6 rc-5-sz mce_kbd [lirc]


If I suspend and resume using the keyboard it reacts well: This can be repeated indefinitely , and the remote remains at /sys/class/rc/rc0 .


Any ideas?
My guess would be that making the remote stay at rc0 should/could solve the problems, but I am not sure how to do that.

Alex.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum