Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kget non vuole aprirsi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 108
Location: torino

PostPosted: Sat Feb 08, 2014 12:25 pm    Post subject: kget non vuole aprirsi Reply with quote

ciao a tutti! col vostro gentile e cortese aiuto voglio capire perche' kget (kde 4.11.2) non si apre. mi spiego meglio: la primissima volta si e' aperto. dopo che ho aggiunto la use flag "bittorrent" per sfizio mio, kget ha cessato la sua attivita'. cio' continua anche dopo l'eliminazione della suddetta flag. avete consigli? preciso che non faccio uso di kget ma trovo molto strano l'accaduto.
grazie per tutto! :wink:
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4823
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sat Feb 08, 2014 1:47 pm    Post subject: Reply with quote

Qualche errore avviandolo da konsole? ...verificando il codice di uscita se non ti spiace?
  • Un problema di configurazione legato alle dipendenze di libktorrent?
    Credo sia la cosa più probabile. Crash mascherato da normale uscita perché cerca un plugin mancante o prova ad avviare un eseguibile che non c'è.
    Dovresti piallare la conf utente di kget, ktorrent e libktorrent e vedere se nelle dir di CONFIG_PROTECT non è rimasto qualcosa a dar fastidio ( findcruft quanto mi manchi... :cry: ).
  • Dipende da boost quindi ricompilarlo sovente è d'aiuto.
  • Soliti problemi con il database?


Ammetto che non lo uso moltissimo, al massimo le rare volte che uso konqueror invece del solito dinosauro ipertrofico di FF, per scaricare file. Quindi non ho grande kompetenza. :P

Altro non posso dirti, la sfera di cristallo la ho mandata a riparare e si vede che hai un cappello di carta stagnola od un guscio di armadillo sulla testa perché non riesco a leggerti nel pensiero. :twisted: :twisted: :twisted:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 108
Location: torino

PostPosted: Sun Feb 09, 2014 7:41 pm    Post subject: Reply with quote

ciao djinnz e sempre grazie per tutto il supporto che fornisci a noi tutti :wink:

dunque, ho ricompilato boost libktorrent indi kget ma niente da fare, non si vuole aprire. adesso ho upgradato kde e sono su 4.11.5. non e' cambiato nulla. perdonami ma non so cosa vuol dire piallare e/o rinvenire la dir CONFIG_PROTECT. con la mia bella stagnola in testa di piu' non saprei che dire, abbi pazienza :) quando chiamo kget su konsole dopo che ho cliccato nel menu di kwin mi dice "kget is already running" ma non si visualizza niente. mah...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4823
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Mon Feb 10, 2014 3:38 pm    Post subject: Reply with quote

emerge non cancella i file (in genere di configurazione, situati nelle directory indicate in CONFIG_PROTECT... quei file che aggiorrni con etc-update & C) modificati quando rimuovi un pacchetto.
Stesso discorso per il file di configurazione di kget (che non ricordo dov'è ma dovrebbe essere di default in /usr/share/kde o qualcosa del genere ed in .KDE a livello utente).

Uno di questi lo potrebbe forzare a tentare di partire con i torrent anche se hai rimosso la libreria (se le hai reinstallate prova a vedere con qlist).

Potresti provare a vedere se reinstallando la libreria torrent riesci a capire cosa rimane sul filesystem o se qualche anima pia ha idea di cosa ci sia e vuol dare una mano...

Per cercare di capire qualcosa quando una applicazione kde fa le bizze è necessario lanciarla da linea di comando con le opzioni --nocrashhandler e --nofork così non ti ritrovi con una finestra di errore generica in stile windozz (ma perché stanno ancora a cercare di imitare quella fetenzia?), se anche esce fuori.
Possibile che un messaggio di errore alla fine appaia.

Personalmente credo che il problema sia nella configurazione di kget a livello utente. Visto che ti dice "already running" si blocca in attesa che un qualcosa risponda.

Potresti provare a creare un utente per prova o muovere le dir di conf e vedere se il problema si presenta o meno.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
tornadomig
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2011
Posts: 108
Location: torino

PostPosted: Thu Feb 20, 2014 12:27 pm    Post subject: Reply with quote

mi scuso con il caro djinnz per l'immane ritardo ma ero su slackware. ora ho ricollegato gentoo e posso rispondere.

Code:
$ kget --nocrashhandler
KGlobal::locale(): Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action


questo mi sembra interessante ma che vuol dire? da ricompilare i18n per risolvere l'arcano?

e poi
Code:
 $ kget --nofork
unnamed app(25196): KUniqueApplication: Can't setup D-Bus service. Probably already running.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum