Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xedit and nano do not play perfectly well together
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
paradigm-X
Apprentice
Apprentice


Joined: 19 Sep 2013
Posts: 168

PostPosted: Thu Feb 06, 2014 3:17 pm    Post subject: xedit and nano do not play perfectly well together Reply with quote

When an X window is launched from xterm with command 'nano', the presence of text extending beyond the width of the window is indicated symbolically by "$" at the end of the visible line. That's a good thing. When I select this line of text by swiping the cursor from below it to above it, and then paste the selection in xedit, instead of getting the complete line of text, I get only the visible part along with the "$" symbol. So, it displays properly but selects literally. Is there a way to affect this behavior?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10156
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu Feb 06, 2014 3:27 pm    Post subject: Reply with quote

Nope. Nano is completely unaware of X (and X is unaware of Nano). More capable editor is recommended. If you want X integration to work perfectly, then you want an X aware editor. All the biggies are—but even they will have some issues when run in text mode in an X terminal.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum