Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem when using pip to upgrade flexget
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Silmano
n00b
n00b


Joined: 10 Mar 2012
Posts: 38

PostPosted: Thu Feb 06, 2014 9:24 am    Post subject: Problem when using pip to upgrade flexget Reply with quote

I have the stable portage versions of dev-python/setuptools and dev-python/pip and I have manually installed flexget (I'm not using the portage one).

When there's a new version and I want to update, running 'pip install --upgrade flexget' installs the needed files, but also latest setuptools version. This seems to update the python-exec binary, so if I try to run again pip install, it doesn't work:
Code:
server peter # pip install
Searching for install
Reading https://pypi.python.org/simple/install/
Couldn't find index page for 'install' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or download links found for install
error: Could not find suitable distribution for Requirement.parse('install')

And I need to reinstall it in order to recover its functionality.

Is there a way to update flexget and avoid overwriting python-exec binary?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8593

PostPosted: Sun Feb 09, 2014 11:46 pm    Post subject: Reply with quote

Generally, running multiple package managers on the same system is a recipe for trouble if they do not communicate with one another. The pip authors like to think of themselves as running a package manager. If running pip breaks something managed by Portage, that sounds like a bug in pip. Is there a good reason why you are not using Portage to install this package?
Back to top
View user's profile Send private message
Silmano
n00b
n00b


Joined: 10 Mar 2012
Posts: 38

PostPosted: Mon Feb 10, 2014 12:00 pm    Post subject: Reply with quote

Hu wrote:
Is there a good reason why you are not using Portage to install this package?

net-misc/flexget package has been in version 1.2.31 for over a month, while the direct package managed from pip is right now in 1.2.84. I know portage packages always are some versions below, but there is great changes between X.X.31 and X.X.78 (the one I'm using right now) that I really like and/or need.

If portage version updates to anything over X.X.75, I could install back that version instead, but it seems the ebuild movement for this package its been almost none.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum