Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] GNOME 3.10 - x11 keyboard french canadian
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aramis_qc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2006
Posts: 106
Location: Québec - Canada

PostPosted: Fri Feb 07, 2014 12:14 am    Post subject: [SOLVED] GNOME 3.10 - x11 keyboard french canadian Reply with quote

I'm running GNOME 3.10.

Keyboard is OK when used in Command Line.

Somehow layout is not correctly mapped in X environment.

Here is output of localectl :

Code:

System Locale: LANG=fr_CA.utf8
       VC Keymap: cf
      X11 Layout: ca


How it is mapped [img]http://www.zimagez.com/miniature/agencement-clavierfrca.png[/img]

How it should be [img]http://www.zimagez.com/miniature/frenchcanadakeyboard.png[/img]

How can I fix it ?
_________________
Profil et systèmes


Last edited by aramis_qc on Fri Feb 07, 2014 11:37 pm; edited 2 times in total
Back to top
View user's profile Send private message
aramis_qc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2006
Posts: 106
Location: Québec - Canada

PostPosted: Fri Feb 07, 2014 2:36 am    Post subject: Reply with quote

setxkbmap -query returns :

Code:

rules:      evdev
model:      pc104
layout:     ca,us
variant:    ,
options:    esperanto:dvorak


I really don't know why options is set to esperanto:dvorak.

The only workaround is to run :

Code:

setxkbmap -layout ca -option


I must do that each time I log in.
_________________
Profil et systèmes
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1675
Location: United Kingdom

PostPosted: Fri Feb 07, 2014 5:22 am    Post subject: Reply with quote

You could try doing it directly in xorg.conf if your keyboard device is already specified in that file, or in a separate file /etc/X11/xorg.conf.d/00-keyboard.conf if your keyboard device is not already specified in xorg.conf. You may already have a file *-keyboard.conf in /etc/X11/xorg.conf.d/ which you could edit accordingly.

All the possible XkbModels, XkbLayouts, XkbVariants and XkbOptions are listed in the text file /usr/share/X11/xkb/rules/xorg.lst on your machine.

So you could try a file /etc/X11/xorg.conf.d/00-keyboard.conf along the following lines:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "ca,us"
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


If you don't want to toggle between a French Canadian keyboard layout and a US English keyboard layout then drop the "us" and the XkbOptions. On my main laptop I have specified the XkbOptions option to be "grp:alt_shift_toggle" so that I can use Alt+Shift to toggle between the keyboard layouts. The key combination options for toggling are also listed in /usr/share/X11/xkb/rules/xorg.lst. You'll need to play around with the options. On some of my machines I want to be able to switch keyboard layouts between British English, US English, Brazilian Portuguese and Spanish, so I have a file /etc/X11/xorg.conf.d/00-keyboard.conf that looks like the following:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "gb,us,br,es"
    Option "XkbVariant" ""
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


The different keyboard variants are also listed in /usr/share/X11/xkb/rules/xorg.lst. For example, "eng" is an English (Canada) variant, if you have one.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
aramis_qc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2006
Posts: 106
Location: Québec - Canada

PostPosted: Fri Feb 07, 2014 5:03 pm    Post subject: Reply with quote

Thank's Fitzcarraldo but your solution didn't fix anything.

This issue is user account related.

When I create a new account and use it or when I connect to gnome-session as root, keyboard is correctly set and mapped.

When I use my regular account :

Code:

guy@Funtoo-Gnome ~ $ localectl status
   System Locale: LANG=fr_CA.utf8
       VC Keymap: cf
      X11 Layout: ca,us
     X11 Variant: fr,
     X11 Options: alt_shift_toggle


Code:

guy@Funtoo-Gnome ~ $ setxkbmap -query
rules:      evdev
model:      pc104
layout:     ca,us
variant:    ,
options:    esperanto:dvorak


I really don't know why options is set as esperanto:dvorak.

Perhaps the only way to get rid of that is to recreate my user account.

Settings of setxkbmap override ones of localectl. For example, ALT + SHIFT does not work. When setxkbmap -option is ran, keyboard is ok.
_________________
Profil et systèmes
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Fri Feb 07, 2014 6:17 pm    Post subject: Reply with quote

If you use the startx command to open an X session as a normal user, you can add extra commands in your ~/.xinitrc
Code:
setxkbmap -layout ca -option
exec gnome-session

If you use a display manager to open an X session as a normal user, you can add extra commands in your ~/.xsessionrc
Code:
setxkbmap -layout ca -option

If this do not resolv your problem, the issue can come from the Gnome keyboard setting itself who change the layout.
_________________
Paul
Back to top
View user's profile Send private message
aramis_qc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2006
Posts: 106
Location: Québec - Canada

PostPosted: Fri Feb 07, 2014 11:36 pm    Post subject: Reply with quote

Thank to all... problem now is solved.

I've been told to look at org/gnome/desktop/input-sources (dconf). Xkb-options field set to esperanto:dovrak.

I reset to default value (blank) and keyboard layout was ok. Upon restart the field now is set to alt_shift_toogle. That's the value I entered last time localectl was ran. Keyboard layout OK.

Is it a bug with GNOME3.10 ?
_________________
Profil et systèmes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum