Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X + SLiM + dwm - how to chain together?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Wed Feb 05, 2014 12:44 pm    Post subject: X + SLiM + dwm - how to chain together? Reply with quote

Hey all,

[X and dwm]

I recently installed the binary ati-drivers for my Radeon HD6870 and it worked fine (after struggling a little bit with aticonfig --initial). When starting X manually with
Code:
startx
, X comes up with some xterm windows (installed for testing purpose). When I execute
Code:
dwm
from xterm, dwm comes up and everything is fine.

[X and SLiM]
I also merged SLiM and set it up with
Code:
rc-update add xdm default
and when I reboot, X and SLiM starts automatically, as expected.

So far.

[X and SLiM and dwm]
However, when I set up SLiM so that it shall start dwm as X session (following the wiki), it does not work. I reboot into SLiM and when I logged in successfully, a black screen appears and the mouse cursor is the black X (cross). No dwm. No xterms. No nothing.
(BTW: when switching to TTY1 and trying to stop X with /etc/init.d/xdm stop some error (?) comes up that says sth. like
Code:
start-stop-daemon no matching processes found
and when switching back to ALT+F7, the same black screen with mouse cursor is still there)

I tried the following alternatives from wiki to get it run:
  • simple configuration
  • Default configuration - no default session
  • Setting a global default session
  • Per-user default session using bundled session files
  • Per-user default session using the customized ~/.xsession file

None of them worked. Everytime the same result, so I think anything else is not working correctly. Also, in some of the alternatives, I can choose between Xsession and dwm pressing F1 in SLiM. But even, when I select dwm, it does not work.

I also tried some different approaches found online, like different kinds (and complexities) of .xinitrc. Nothing changes.

Please help :cry:
Back to top
View user's profile Send private message
Tractor Girl
Apprentice
Apprentice


Joined: 16 May 2013
Posts: 159

PostPosted: Wed Feb 05, 2014 2:09 pm    Post subject: Reply with quote

Display manager with dwm? Come on, this is almost a crime :wink:
Why not just put this into .xinitrc?
Code:
exec dwm
Back to top
View user's profile Send private message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Wed Feb 05, 2014 2:16 pm    Post subject: Reply with quote

Tractor Girl wrote:
Display manager with dwm?

If I stick to only dwm, yeah, you're right. But first I want it to get working (maybe for some different WM).

Tractor Girl wrote:
Why not just put this into .xinitrc?
Code:
exec dwm

Dude, I really tried this already :D
_________________
[140205|15:13:07] < terabit>| fuck!! wtf happened ? bash: emerge: command not found
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Wed Feb 05, 2014 6:10 pm    Post subject: Reply with quote

if dwm works via startx

slim simple configuration is basically startx.....

i run slim via add xdm default & systemctl enable slim for systemd....

exec dwm should be in .xinitrc

it should work just as that. i dont like all the awesomeness to the slim wiki.

tested and functioning.
Back to top
View user's profile Send private message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Wed Feb 05, 2014 7:10 pm    Post subject: Reply with quote

Ok I did it again, just to go sure. Does. not. work. :( :( :(
I even created a .xinitrc for the root, but I think root does not need it (when I do not login with root on DM)

/root/.xinitrc
Code:
exec dwm

~/.xinitrc
Code:
exec dwm

both with permissions 700
both without #!/bin/bash in the beginning

/etc/slim.conf:
Code:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session
# login_cmd           exec /bin/bash -login /usr/share/slim/Xsession %session

and
Code:
# Available sessions:
# The current chosen session name replaces %session in the login_cmd
# above, so your login command can handle different sessions.
# If no session is chosen (via F1), %session will be an empty string.
# see the xinitrc.sample file shipped with slim sources
#sessions            xfce4,icewm-session,wmaker,blackbox
# Alternatively, read available sessions from a directory:
sessiondir           /etc/X11/Sessions

I think the last one does not matter. /etc/env.d/ has not file 90xsession and $XSESSION is not set.
nothing.

I really really despair of it....
_________________
[140205|15:13:07] < terabit>| fuck!! wtf happened ? bash: emerge: command not found
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Wed Feb 05, 2014 7:17 pm    Post subject: Reply with quote

Quote:
both with permissions 700


mine are 644

then /etc/init.d/xdm restart

as root

it should load up slim that will in turn dump you into dwm. it probably wont change the background, it didnt for me. i merged dwm to test it it was small enough to do so.

/etc/env.d/ has not file 90xsession and $XSESSION is not set. same...
Back to top
View user's profile Send private message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Wed Feb 05, 2014 7:35 pm    Post subject: Reply with quote

Same with 644........ :evil:

Code:
startx

starts dwm, because startx executes first .xinitrc and then xsesssion stuff... so xinitrc works.

/etc/init.d/xdm restart says
Code:
Stopping slim ...
start-stop-daemon: no matching processes found                 [ok]
Setting up slim ...                 [ok]

Then, I switch to ALT+F7 and Slim is up ready for login. I login aaaaand black screen (after some short flickering). I cannot imagine that this has to do with slim or .xinitrc. Something different must go wrong. Maybe Slim starts X not with startx but different (and this maybe does not recognize my graphics card or sth...)

I found a line in Xorg.[$].log that says
Code:
(WW) fglrx: no matching Device section for instance (BusID PCI:0@1:0:1) found

But this cannot be serious problem because in other lines I can read ati driver detected my gpu and I can also run fglrxinfo and fgl_gears successfully. I can also run Catalyst Control Center and eveything is just working when I type startx...... It is so strange....

Update: According to my lspci output this device where fglrx cannot find device section is a sound card on ati graphics card. So I think it is the HDMI sound output which is pretty normal until I will have installed a driver for it. So just ignore my note about it...
_________________
[140205|15:13:07] < terabit>| fuck!! wtf happened ? bash: emerge: command not found
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Wed Feb 05, 2014 7:47 pm    Post subject: Reply with quote

for me its not flickering and just leaving slim artifacts / background in the dwm. (in all honesty i think slims kinda junky and that lightdm is a vastly superior alternative, though much much heavier than dwm) i think you're either getting artifacts of slim, or you've found a bug. i used slim on my friends ati/amd box, but i used auto login method after i made sure standard login method was working well.
Back to top
View user's profile Send private message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Wed Feb 05, 2014 8:02 pm    Post subject: Reply with quote

No artifacts. Screen flickers to ... lets say light-black (like when you press startx and monitor resolution changes) for a second and then is dark black again, with black mouse curser cross. No keys work (except of CTRL+ALT+F1 e.g.). I can move the mouse but thats all. No dwm. No xterm. Nothing.

Now, I noticed the following:
When I switch from this state to TTY1 and type startx, it starts X with dwm!!! Does this mean, that X was not running before?
When I then type
Code:
ps aux | grep X
I get:
Code:
root     10085  0.0  0.0  11288   972 pts/0    S+   20:58   0:00 grep --colour=auto X
root     17071  0.2  1.0 272180 89792 tty7     Ss+  20:04   0:09 /usr/bin/X -nolisten tcp -br -deferglyphs 16 vt07 -auth /var/run/slim.auth
root     18040  0.0  0.0  15916   896 tty1     S+   20:51   0:00 xinit /root/.xinitrc -- /etc/X11/xinit/xserverrc :2 -auth /root/.serverauth.18024
root     18041  1.5  0.8 276316 73460 tty8     S<s+ 20:51   0:05 /usr/bin/X -nolisten tcp :2 -auth /root/.serverauth.18024
root     18047  0.1  0.2  84488 16584 ?        Ss   20:53   0:00 xterm -class UXTerm -title uxterm -u8

I recognize the fist instance (17071) from /etc/slim.conf.
The second instance (18041) must be from startx command.
Can anyone do something with that?

Update: Oh and now I recognize, that the working one is on TTY8 and the black screen with cross mouse pointer is still on TTY7....
_________________
[140205|15:13:07] < terabit>| fuck!! wtf happened ? bash: emerge: command not found
Back to top
View user's profile Send private message
fachexot
n00b
n00b


Joined: 01 Feb 2014
Posts: 34
Location: Nuremberg, Germany

PostPosted: Thu Feb 06, 2014 10:17 pm    Post subject: Reply with quote

Solved it. Installed slim without consolekit USE flag and it worked with simple configuration...
_________________
[140205|15:13:07] < terabit>| fuck!! wtf happened ? bash: emerge: command not found
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum