Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Login via Slim now = Black Screen, startx ok
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shrike
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2004
Posts: 136
Location: Closer to home

PostPosted: Mon Feb 03, 2014 4:26 pm    Post subject: Login via Slim now = Black Screen, startx ok Reply with quote

Hi,

Following a recent 'world' update (~amd64) I get just a black screen after entering UsrID/passwd. rc-status shows xdm 'crashed' from tty1. The setup for xfce/Slim login seems ok:

Code:

cat /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="slim"

cat /etc/env.d/90xsession
XSESSION="Xfce4"

cat .xinitrc
exec > /home/shrike/.xsession-errors 2>&1

exec startxfce4
# exec startxfce4 --with-ck-launch


Log files show errors:

Code:

cat /var/log/slim.log

slim: waiting for X server to begin accepting connections.
slim: open_session: Unable to open session: Unable to get information about the calling process


cat .xsession-errors
 
/usr/bin/startxfce4: X server already running on display :0

(polkit-gnome-authentication-agent-1:1583): polkit-gnome-1-WARNING **: Unable to determine the session we are in: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '1583'

(xfdesktop:1551): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed

(xfdesktop:1551): GLib-GIO-CRITICAL **: g_file_get_path: assertion 'G_IS_FILE (file)' failed


Yet with this information I don't see a cause. Bug 499738 seems a possibility.

Thanks,

shrike
Back to top
View user's profile Send private message
opascariu
n00b
n00b


Joined: 08 Jun 2006
Posts: 35

PostPosted: Thu Feb 06, 2014 9:19 pm    Post subject: Reply with quote

Hi,

I experience the same issue, after an world update.
My slim.log, besides the lines posted by shrike, also contain the following lines
Code:
slim: waiting for X server to begin accepting connections.
slim: pam_authentication(): Authentication failure


It seems that an workaround would be to compile slim without pam and consolekit, which makes me believe that bug #499738 is not the cause of this issue.


Last edited by opascariu on Fri Feb 07, 2014 9:33 am; edited 1 time in total
Back to top
View user's profile Send private message
manny15
Guru
Guru


Joined: 01 Dec 2002
Posts: 473
Location: USA

PostPosted: Fri Feb 07, 2014 3:33 am    Post subject: Reply with quote

I have the same symptom, but my slim.log looks a bit different:
Code:

slim: waiting for X server to begin accepting connections.
slim: open_session: Unable to open session: Unable to get information about the calling process
Back to top
View user's profile Send private message
opascariu
n00b
n00b


Joined: 08 Jun 2006
Posts: 35

PostPosted: Fri Feb 07, 2014 9:31 am    Post subject: Reply with quote

@manny15
Those lines appear in my slim.log also, but they were mentioned by shrike and I have omitted them from my post.
Sorry for the confusion
Back to top
View user's profile Send private message
jetboo
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2007
Posts: 94

PostPosted: Sun Feb 23, 2014 1:31 am    Post subject: Reply with quote

Hi, im also having the same issue

Code:
slim: open_session: Unable to open session: Unable to get information about the calling process


startx works fine tho

Jetboo
Back to top
View user's profile Send private message
Mistwolf
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2007
Posts: 121
Location: Edmonton, AB

PostPosted: Sun Feb 23, 2014 3:56 am    Post subject: Reply with quote

If you have the line
Code:
slim: open_session: Unable to open session: Unable to get information about the calling process


in your logs, the issue is https://bugs.gentoo.org/show_bug.cgi?id=501330. It appears that it is caused by upgrading to GLib 2.38.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum