Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] GDM Won't Start After Upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
stunirvana21
n00b
n00b


Joined: 24 May 2011
Posts: 41

PostPosted: Sun Feb 02, 2014 3:24 pm    Post subject: [Solved] GDM Won't Start After Upgrade Reply with quote

I recently upgraded my system which includes gnome2.32->gnome3.8, a new kernel (3.10.25), and systemd. However, gdm won't start properly. I can however use the awesome desktop environment. Curiously, I can't run any gnome suite appliactions in awesome. For instance, I used to be able to run gnome-terminal in awesome, but now I get an error. Cearly I must have botched something during the update that is disabling gnome. Any ideas? Thanks!

Code:

# /usr/sbin/gdm
<5>Child process 4260 was already dead.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 0.011933 seconds
<5>Failed to give slave programs access to the display. Trying to proceed.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 1.408487 seconds
<5>Failed to give slave programs access to the display. Trying to proceed.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 1.469679 seconds
<5>Failed to give slave programs access to the display. Trying to proceed.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 1.529611 seconds
<5>Failed to give slave programs access to the display. Trying to proceed.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 1.489596 seconds
<5>Failed to give slave programs access to the display. Trying to proceed.
<3>GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
<3>GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
<5>GdmDisplay: display lasted 1.489644 seconds
<5>GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors

Note: X clearly does start because the monitor switches to that X session for a brief ~1.5 seconds and then back to the tty I started gdm from.


Code:

$ gnome-terminal
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/libexec/gnome-terminal-server received signal 5


Last edited by stunirvana21 on Mon Feb 03, 2014 3:31 am; edited 1 time in total
Back to top
View user's profile Send private message
stunirvana21
n00b
n00b


Joined: 24 May 2011
Posts: 41

PostPosted: Mon Feb 03, 2014 3:31 am    Post subject: Reply with quote

I was able to solve the issue by rebuilding all the dependencies of gdm.

Code:
emerge -eq gdm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum