Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net-wireless/bluez - not working anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 41

PostPosted: Tue Jan 28, 2014 1:58 pm    Post subject: net-wireless/bluez - not working anymore Reply with quote

Hey there,

since today i got a hard issue and i really dont know what happens.
Bad to say nothing more about this - sorry. :-/

Today i started my laptop (lenovo thinkpad x230) and all is coming up, except bluetooth.

blueman wont start, the icon is missed - after approx 5mins the icon is loaded but nothing worked with bluetooth.
The applet dont work too.

The daemon starts normal (i used it with -n -d), so no errors are given, but after launching the blueman-applet it shows me the errors given in attachment.

I tried to keep up working with several kernels:
  • 3.10.25
  • 3.12.8
  • 3.12.9
  • 3.13.0-r1
...but no-one worked?

I also upgraded dbus from stable-1.6.12 to 1.6.18-r1 - nothing changed.

Reinstalled bluez/blueman to different versions (bluez-5.12 instead of 4.101-r8) - nothing changed.

I dont really know what to do more because my knowledge is not enough for this :-(

If you need and informations, please let me know!

lsusb:
Code:
Bus 001 Device 003: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]

Logfiles:
kernel.log
blueman-applet.log

Ty for any ideas, hints, suggestions or help! Ty !
_________________
Alex / seVes
Back to top
View user's profile Send private message
WorBlux
n00b
n00b


Joined: 07 May 2011
Posts: 35

PostPosted: Tue Jan 28, 2014 7:56 pm    Post subject: Reply with quote

I would try ruling out bluez + udev +kernel first. Does hcitool work?
If not does it work as root?

https://wiki.gentoo.org/wiki/Bluetooth
Back to top
View user's profile Send private message
seVes
n00b
n00b


Joined: 06 Jan 2011
Posts: 41

PostPosted: Thu Jan 30, 2014 1:30 pm    Post subject: Reply with quote

I checked all changelog's but nothing changes in the past.

hcitool is working so far, i can find other devices, but when i try to pair i get the following error...

alex@x230 ~ $ hcitool scan:
Scanning ...
   00:02:76:4D:62:AD   ThinkPad Bluetooth Laser Mouse

alex@x230 ~ $ simple-agent hci0 00:02:76:4D:62:AD:
ERROR:dbus.proxies:Introspect error on :1.6:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/simple-agent", line 115, in <module>
    path = manager.FindAdapter(args[0])
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusExceptio
</busconfig>[/cn: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

alex@x230 ~ $ cat /etc/dbus-1/system.d/bluetooth.conf:
<!-- This configuration file specifies the required security policies
     for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
    <allow send_interface="org.bluez.HandsfreeAgent"/>
    <allow send_interface="org.bluez.MediaEndpoint"/>
    <allow send_interface="org.bluez.MediaPlayer"/>
    <allow send_interface="org.bluez.Watcher"/>
    <allow send_interface="org.bluez.ThermometerWatcher"/>
  </policy>

  <policy group="plugdev">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>

alex@x230 ~ $ cat /etc/dbus-1/system.d/org.blueman.Mechanism.conf:
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
   <policy user="root">
      <allow own="org.blueman.Mechanism"/>
   </policy>
        <policy group="plugdev">
                <allow send_destination="org.bluez"/>
        </policy>
     <policy context="default">
          <allow send_destination="org.blueman.Mechanism"/>
     </policy>
</busconfig>

For me it looks like something is blocking my bluetooth-data or dbus is rejecting everything...?

Versions:
- udev-208
- bluez-4.101-r8
- blueman-1.23-r2
- dbus-1.6.12

I'am in plugdev-group. :-/
_________________
Alex / seVes
Back to top
View user's profile Send private message
WorBlux
n00b
n00b


Joined: 07 May 2011
Posts: 35

PostPosted: Sun Feb 02, 2014 2:45 am    Post subject: Reply with quote

same result as root?



what are you keyword options on bluez and dbus ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum